View Issue Details

IDProjectCategoryView StatusLast Update
0007928ardourbugspublic2020-03-19 22:10
Reporterio7m2 Assigned To 
Status newResolutionopen 
PlatformLinuxOSArch LinuxOS Version5.5.8-arch1-1
Product Version5.12 
Summary0007928: Crash on opening project
DescriptionThe 2/broadway_2/broadway_2.ardour project will reliably crash Ardour 5.12 on opening with the following error:

(ardour-5.12.0:5010): glibmm-ERROR **:
unhandled exception (type std::exception) in signal handler:
what: std::bad_array_new_length
Trace/breakpoint trap (core dumped)

I've verified this against both the Arch Linux OS packages, and the 5.12 demo available on
Steps To ReproduceDownload the ~250mb project from here:

Apologies for the large size. This is a real project and I don't know how else to reproduce the issue.

1. Open 2/broadway_2/broadway_2.ardour
2. Ardour will mention that there are missing files. Ignore them.
3. The UI will load but, just before any regions appear, the program will crash.



2020-03-13 18:25

reporter   ~0021020

The gdb backtrace looks like this:

#0 0x00007ffff6ca8f46 in () at /usr/lib/
0000001 0x00007ffff6ca9136 in g_log_default_handler () at /usr/lib/
#2 0x00007ffff6ca98be in g_logv () at /usr/lib/
#3 0x00007ffff6ca9ac0 in g_log () at /usr/lib/
0000004 0x00007ffff6e0d100 in () at /usr/lib/
0000005 0x00007ffff600c8df in () at /usr/lib/
#6 0x00007ffff692003c in () at /usr/lib/
#7 0x00007ffff6dac61a in g_closure_invoke () at /usr/lib/
0000008 0x00007ffff6d8d0e8 in () at /usr/lib/
0000009 0x00007ffff6d905cc in g_signal_emit_valist () at /usr/lib/
0000010 0x00007ffff6d926b0 in g_signal_emit () at /usr/lib/
0000011 0x00007ffff6a3c6f8 in () at /usr/lib/
0000012 0x00007ffff691ee11 in gtk_main_do_event () at /usr/lib/
0000013 0x00007ffff6779a90 in () at /usr/lib/
0000014 0x00007ffff6779a33 in () at /usr/lib/
#15 0x00007ffff6779a33 in () at /usr/lib/
0000016 0x00007ffff6779a33 in () at /usr/lib/
#17 0x00007ffff67764cf in () at /usr/lib/
0000018 0x00007ffff6776e20 in gdk_window_process_all_updates () at /usr/lib/
0000019 0x00007ffff6776e79 in () at /usr/lib/
0000020 0x00007ffff6755257 in () at /usr/lib/
0000021 0x00007ffff6cb188f in g_main_context_dispatch () at /usr/lib/
0000022 0x00007ffff6cb3831 in () at /usr/lib/
0000023 0x00007ffff6cb3871 in g_main_context_iteration () at /usr/lib/
#24 0x00007ffff691ddc2 in gtk_main_iteration () at /usr/lib/
0000025 0x00007ffff70e7ca5 in Gtkmm2ext::UI::flush_pending(float) () at /usr/lib/ardour5/
0000026 0x00005555559d420c in ()
0000027 0x00005555559e368e in ()
0000028 0x00005555559e497d in ()
0000029 0x00007ffff70e650c in Gtkmm2ext::UI::run(Receiver&) () at /usr/lib/ardour5/
0000030 0x00005555559a0040 in ()
0000031 0x00007ffff4f7b023 in __libc_start_main () at /usr/lib/
0000032 0x00005555559a4a9e in ()

Admittedly that's not too useful without symbols.


2020-03-14 01:56



2020-03-14 01:56

administrator   ~0021021

> 1. Open 2/broadway_2/broadway_2.ardour
> 2. Ardour will mention that there are missing files. Ignore them.

So far so good. It also mentions that most plugins are not available, in particular calf ones.

>3. The UI will load but, just before any regions appear, the program will crash.

It loads just fine here using ardour-5.12 from (see screenshot)
Have you tried loading the session in "safe mode (disable all plugins)" checkbox in the open-session dialog?


2020-03-14 10:15

reporter   ~0021022

Interesting! No, I hadn't tried safe mode. With safe mode enabled, the project does indeed open without crashing.

I hesitate to ask, but how do I track down which plugin is causing the issue? Disabling all of them (safe mode) replaces them all with stubs. I can't see a way to selectively re-enable individual plugins.


2020-03-15 17:16

administrator   ~0021024

Sadly there's no easy way to find out which plugin causes this. It may also be due to a combination of plugins.

Make a backup, open in safe mode, remove half of the plugins, re-load session.. test and repeat.


2020-03-16 11:23

reporter   ~0021028

Hm. I've actually gone through all of the plugins one by one and removed _all_ of them. Via safe mode, I managed to get to the mixer view and from there I could remove individual plugins, saving and reloading after each removal. Even with no plugins on any channel (and including with safe mode enabled), attempting to switch to the editor view immediately crashes Ardour.

I've attached the session files with the removals made.
broadway_2.ardour (280,707 bytes)
broadway_2.history (15,151 bytes)
instant.xml (1,990 bytes)


2020-03-16 18:39

reporter   ~0021031

Is there anything more useful I could be doing to assist? I don't want to just be throwing these things at you and implicitly demanding help. :)


2020-03-19 22:10

administrator   ~0021036

We're working on getting ardour 6.0 to release. We're not likely to back up and dig into this unless it also happens in the current master code (if you're a subscriber you could try a nightly build to see if the behavior is the same for you).

Issue History

Date Modified Username Field Change
2020-03-13 18:24 io7m2 New Issue
2020-03-13 18:25 io7m2 Note Added: 0021020
2020-03-13 18:26 io7m2 Tag Attached: crash
2020-03-14 01:56 x42 File Added: Screenshot at 2020-03-14 02-47-30.png
2020-03-14 01:56 x42 Note Added: 0021021
2020-03-14 10:15 io7m2 Note Added: 0021022
2020-03-15 17:16 x42 Note Added: 0021024
2020-03-16 11:23 io7m2 File Added: broadway_2.ardour
2020-03-16 11:23 io7m2 File Added: broadway_2.history
2020-03-16 11:23 io7m2 File Added: instant.xml
2020-03-16 11:23 io7m2 Note Added: 0021028
2020-03-16 18:39 io7m2 Note Added: 0021031
2020-03-19 22:10 paul Note Added: 0021036