View Issue Details

IDCategoryLast Update
0007128bugs2016-11-22 22:11
Reporterjohmue-eoAssigned To 
Reproducibilityhave not tried 
Status closedResolutionduplicate 
Product Version5.4 
Fixed in Version 
Summary0007128: Ardour crashes suddenly while recording without further user interaction
DescriptionAs the title says, crashes occur while recording. No further user interaction whatsoever. Suddenly the ardour window disappears, due to a failed assertion in cairo

ardour-5.4.0: ../../../../src/cairo-surface.c:928: cairo_surface_reference: Zusicherung »CAIRO_REFERENCE_COUNT_HAS_REFERENCE (&surface->ref_count)« nicht erfüllt.

(in English: assertion »CAIRO_REFERENCE_COUNT_HAS_REFERENCE (&surface->ref_count)« failed.)

The whole terminal output I put into the additional information. The coredump I can't upload right now, because I don't have a net connection here to upload several hundred megs.

I will run the self compiled ardbg from now on, hoping to get a more usable core dump on the next crash.
Steps To ReproduceNot reliably reproducible. However it happens often enough to harm one's trust in Ardour.
Additional InformationTerminal output:

joh@kaksi <0> $ ardour5
bind txt domain [gtk2_ardour5] to /usr/local/share/ardour5/locale
Ardour5.4.0 (built using 5.4 and GCC version 6.2.0 20161005)
ardour: [INFO]: Your system is configured to limit Ardour to only 65.536 open files
ardour: [INFO]: Loading system configuration file /usr/local/etc/ardour5/system_config
ardour: [INFO]: Loading user configuration file /home/joh/.config/ardour5/config
ardour: [INFO]: CPU vendor: GenuineIntel
ardour: [INFO]: AVX-capable processor
ardour: [INFO]: CPU brand: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
ardour: [INFO]: Using SSE optimized routines
ardour: [INFO]: Loading default ui configuration file /usr/local/etc/ardour5/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/joh/.config/ardour5/ui_config

(ardour-5.4.0:17474): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

(ardour-5.4.0:17474): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
ardour: [INFO]: Loading color file /usr/local/share/ardour5/themes/dark-ardour.colors

(ardour-5.4.0:17474): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

(ardour-5.4.0:17474): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
ardour: [INFO]: Loading ui configuration file /usr/local/etc/ardour5/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /usr/local/etc/ardour5/clearlooks.rc
curl failed: HTTP request failed: (6) Could not resolve host: community.ardour.org
Found 2 along /home/joh/.config/ardour5/templates:/usr/local/share/ardour5/templates
run dialog
protocol Mackie active ? 0
protocol Generic MIDI active ? 1
protocol PreSonus FaderPort active ? 0
protocol Wiimote active ? 0
protocol Open Sound Control (OSC) active ? 1
protocol Ableton Push 2 active ? 0
Scanning folders for bundled LV2s: /usr/local/lib/ardour5/LV2
KP is ardour.keys
Set cursor set to default
Set buffering params to 262144|131072|10|10
protocol Mackie active ? 0
protocol Open Sound Control (OSC) active ? 1
protocol PreSonus FaderPort active ? 0
protocol Generic MIDI active ? 1
Set buffering params to 262144|131072|10|10
Skip explicit buffer seconds, preset in use
Skip explicit buffer seconds, preset in use
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 19.9 ms
OE: set current page to 2
OE: set current page to 1
OE: set current page to 0
OE: set current page to 10
OE: set current page to 4
OE: set current page to 5
OE: set current page to 3
OE: set current page to 2
OE: set current page to 15
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 35.4 ms
OE: set current page to 16
OE: set current page to 0
OE: set current page to 1
OE: set current page to 2
OE: set current page to 3
OE: set current page to 4
OE: set current page to 6
OE: set current page to 7
OE: set current page to 10
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 9.7 ms
OE: set current page to 0
OE: set current page to 2
OE: set current page to 3
OE: set current page to 4
OE: set current page to 3
OE: set current page to 4
OE: set current page to 6
OE: set current page to 7
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 21.6 ms
OE: set current page to 10
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 20.4 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 40.8 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 44.5 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 26.9 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 46.5 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 24.4 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.ardour
saved state in 25.8 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 25.6 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 38.9 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 43.9 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.ardour
saved state in 19.7 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.ardour
saved state in 16.9 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.ardour
saved state in 17.1 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.ardour
saved state in 15.3 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.ardour
saved state in 15.3 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.ardour
saved state in 12.3 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.ardour
saved state in 13.8 ms
actually writing state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.tmp
renaming state to /data/Registrado/KP101-Astronomio/KP101-Astronomio.pending
saved state in 11.3 ms
ardour-5.4.0: ../../../../src/cairo-surface.c:928: cairo_surface_reference: Zusicherung »CAIRO_REFERENCE_COUNT_HAS_REFERENCE (&surface->ref_count)« nicht erfüllt.
[1] 17474 abort (core dumped) ardour5
TagsNo tags attached.

Relationships

duplicate of 0006478 closedx42 Crash after some time of recording 

Activities

johmue-eo

2016-11-19 11:56

developer   ~0018988

It happened again. This time I have a backtrace. At least I hope so.

joh@kaksi <0> $ gtk2_ardour/ardbg
GNU gdb (Ubuntu 7.11.90.20161005-0ubuntu1) 7.11.90.20161005-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from gtk2_ardour/../build/gtk2_ardour/ardour-5.4.0...done.
(gdb) run
Starting program: /home/joh/Devel/ardour/build/gtk2_ardour/ardour-5.4.0
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
bind txt domain [gtk2_ardour5] to /usr/local/share/ardour5/locale
Ardour5.4.0 (built using 5.4 and GCC version 6.2.0 20161005)
ardour: [INFO]: Your system is configured to limit Ardour to only 65.536 open files
ardour: [INFO]: Loading system configuration file /home/joh/Devel/ardour/system_config
ardour: [INFO]: Loading user configuration file /home/joh/.config/ardour5/config
[New Thread 0x7fffe0cbb700 (LWP 25331)]
ardour: [INFO]: CPU vendor: GenuineIntel
ardour: [INFO]: AVX-capable processor
ardour: [INFO]: CPU brand: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
ardour: [INFO]: Using SSE optimized routines
[New Thread 0x7fffe04ba700 (LWP 25332)]
[New Thread 0x7fffdfcb9700 (LWP 25333)]
[New Thread 0x7fffdf4b8700 (LWP 25334)]
[New Thread 0x7fffd7fff700 (LWP 25335)]
[New Thread 0x7fffd77fe700 (LWP 25336)]
ardour: [INFO]: Loading default ui configuration file /home/joh/Devel/ardour/build/gtk2_ardour/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/joh/.config/ardour5/ui_config
ardour: [INFO]: Loading color file /home/joh/Devel/ardour/gtk2_ardour/themes/dark-ardour.colors
ardour: [INFO]: Loading ui configuration file /home/joh/Devel/ardour/build/gtk2_ardour/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /home/joh/Devel/ardour/build/gtk2_ardour/clearlooks.rc
[New Thread 0x7fffd5e15700 (LWP 25337)]
[New Thread 0x7fffd5d94700 (LWP 25338)]
[Thread 0x7fffd5d94700 (LWP 25338) exited]
[Thread 0x7fffd5e15700 (LWP 25337) exited]
[New Thread 0x7fffd5e15700 (LWP 25339)]
[New Thread 0x7fffd5d94700 (LWP 25340)]
[Thread 0x7fffd5d94700 (LWP 25340) exited]
[Thread 0x7fffd5e15700 (LWP 25339) exited]
[New Thread 0x7fffd4c03700 (LWP 25341)]
[New Thread 0x7fffbffff700 (LWP 25342)]
[New Thread 0x7fffbf7fe700 (LWP 25343)]
[New Thread 0x7fffbeffd700 (LWP 25344)]
Found 2 along /home/joh/.config/ardour5/templates:gtk2_ardour/../templates:gtk2_ardour/../build/templates:gtk2_ardour/../gtk2_ardour/templates:gtk2_ardour/../build/gtk2_ardour/templates:./templates
run dialog
[Thread 0x7fffbf7fe700 (LWP 25343) exited]
[Thread 0x7fffbeffd700 (LWP 25344) exited]
[New Thread 0x7fffbeffd700 (LWP 25347)]
[Thread 0x7fffbeffd700 (LWP 25347) exited]
[Thread 0x7fffbffff700 (LWP 25342) exited]
[New Thread 0x7fffd5e15700 (LWP 25418)]
[New Thread 0x7fffd5d94700 (LWP 25419)]
[New Thread 0x7fffd5ba6700 (LWP 25420)]
protocol Open Sound Control (OSC) active ? 1
protocol PreSonus FaderPort active ? 0
protocol Generic MIDI active ? 1
protocol Mackie active ? 0
protocol Wiimote active ? 0
protocol Ableton Push 2 active ? 0
Scanning folders for bundled LV2s: gtk2_ardour/../build/libs/LV2
KP is ardour.keys
[New Thread 0x7fffbffff700 (LWP 25421)]
[New Thread 0x7fffbeffd700 (LWP 25422)]
[New Thread 0x7fffbf7fe700 (LWP 25423)]
Set cursor set to default
[New Thread 0x7fffd409f700 (LWP 25425)]
[New Thread 0x7fffbe5fb700 (LWP 25426)]
[New Thread 0x7fffbe57a700 (LWP 25427)]
Set buffering params to 262144|131072|10|10
[New Thread 0x7fffbc0d4800 (LWP 25428)]
[New Thread 0x7fffa959c700 (LWP 25429)]
[Thread 0x7fffbffff700 (LWP 25421) exited]
[Thread 0x7fffbeffd700 (LWP 25422) exited]
protocol Mackie active ? 0
protocol Open Sound Control (OSC) active ? 1
protocol PreSonus FaderPort active ? 0
protocol Generic MIDI active ? 1
Set buffering params to 262144|131072|10|10
Skip explicit buffer seconds, preset in use
Skip explicit buffer seconds, preset in use
[New Thread 0x7fffbeffd700 (LWP 25448)]
[New Thread 0x7fffbffff700 (LWP 25460)]
[New Thread 0x7fff83a13700 (LWP 25461)]
[New Thread 0x7fff83212700 (LWP 25462)]
[New Thread 0x7fff82211700 (LWP 25472)]
[Thread 0x7fff82211700 (LWP 25472) exited]
[Thread 0x7fffbf7fe700 (LWP 25423) exited]
OE: set current page to 11
actually writing state to /data/Registrado/KP102-Astronomio/KP102-Astronomio.tmp
renaming state to /data/Registrado/KP102-Astronomio/KP102-Astronomio.pending
saved state in 12.6 ms
actually writing state to /data/Registrado/KP102-Astronomio/KP102-Astronomio.tmp
renaming state to /data/Registrado/KP102-Astronomio/KP102-Astronomio.ardour
saved state in 42.1 ms
actually writing state to /data/Registrado/KP102-Astronomio/KP102-Astronomio.tmp
renaming state to /data/Registrado/KP102-Astronomio/KP102-Astronomio.pending
saved state in 48.7 ms
actually writing state to /data/Registrado/KP102-Astronomio/KP102-Astronomio.tmp
renaming state to /data/Registrado/KP102-Astronomio/KP102-Astronomio.pending
saved state in 43.8 ms
[New Thread 0x7fffbf7fe700 (LWP 25792)]
ardour-5.4.0: ../../../../src/cairo-surface.c:928: cairo_surface_reference: Zusicherung »CAIRO_REFERENCE_COUNT_HAS_REFERENCE (&surface->ref_count)« nicht erfüllt.

Thread 33 "ardour-5.4.0" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffbf7fe700 (LWP 25792)]
malloc_consolidate (av=av@entry=0x7fff74000020) at malloc.c:4210
4210 malloc.c: Datei oder Verzeichnis nicht gefunden.
(gdb) bt
#0 malloc_consolidate (av=av@entry=0x7fff74000020) at malloc.c:4210
0000001 0x00007fffefcd7d7f in _int_malloc (av=av@entry=0x7fff74000020, bytes=bytes@entry=15872) at malloc.c:3485
#2 0x00007fffefcd9de4 in __GI___libc_malloc (bytes=15872) at malloc.c:2925
#3 0x00007ffff05cab18 in operator new(unsigned long) () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
0000004 0x00007ffff7903dc4 in ArdourCanvas::WaveView::generate_image (this=0x55555ce59960, req=..., in_render_thread=true) at ../libs/canvas/wave_view.cc:995
0000005 0x00007ffff7905e97 in ArdourCanvas::WaveView::drawing_thread () at ../libs/canvas/wave_view.cc:1595
#6 0x00005555562d6519 in sigc::pointer_functor0<void>::operator() (this=0x55555ce56b68) at /usr/include/sigc++-2.0/sigc++/functors/ptr_fun.h:77
#7 0x00005555562d3450 in sigc::adaptor_functor<sigc::pointer_functor0<void> >::operator() (this=0x55555ce56b60) at /usr/include/sigc++-2.0/sigc++/adaptors/adaptor_trait.h:256
0000008 0x00005555562ce738 in sigc::internal::slot_call0<sigc::pointer_functor0<void>, void>::call_it (rep=0x55555ce56b30) at /usr/include/sigc++-2.0/sigc++/functors/slot.h:115
0000009 0x00007ffff43989ad in ?? () from /usr/lib/x86_64-linux-gnu/libglibmm-2.4.so.1
0000010 0x00007ffff3e58305 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000011 0x00007ffff0fbd70a in start_thread (arg=0x7fffbf7fe700) at pthread_create.c:333
0000012 0x00007fffefd5c0af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105
(gdb) quit

colinf

2016-11-20 16:48

updater   ~0019010

This looks to me like it might be a duplicate of 0006478.

johmue-eo

2016-11-22 20:50

developer   ~0019025

Indeed probably a duplicate. How do I mark it a duplicate?

Issue History

Date Modified Username Field Change
2016-11-19 09:58 johmue-eo New Issue
2016-11-19 11:56 johmue-eo Note Added: 0018988
2016-11-20 16:48 colinf Note Added: 0019010
2016-11-22 20:50 johmue-eo Note Added: 0019025
2016-11-22 22:10 timbyr Relationship added duplicate of 0006478
2016-11-22 22:11 timbyr Status new => closed
2016-11-22 22:11 timbyr Resolution open => duplicate