Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002832 [ardour] bugs minor always 2009-08-19 04:28 2010-06-02 10:54
Reporter timblech View Status public  
Assigned To paul
Priority normal Resolution fixed  
Status resolved   Product Version 2.8.2
Summary 0002832: `mute' doesn't mute
Description with the attached session, muting a track doesn't mute the track. all tracks are connected to the master bus, which is connected to the out ports of the audio interface.

when pressing mute, the track is not muted, though. the vu meters of the specific track fall to zero, but the audio signal is still sent to the master bus.
Additional Information
Tags fixed in A3
Attached Files ? file icon iod4.ardour [^] (38,562 bytes) 2009-08-19 04:28
? file icon ardour2-mute_fix.patch [^] (2,817 bytes) 2009-10-02 07:29 [Show Content]

- Relationships
has duplicate 0003017resolvedpaul The "mute" track button doesn't work by default 
has duplicate 0003579resolvedcth103 mute button on audio track in main window not muting 

-  Notes
(0006575)
thorgal (reporter)
2009-08-20 10:33

right-click on the mute button of a track, select what should be muted. This is no bug :)
(0006576)
timblech (reporter)
2009-08-20 11:39

now, that is not really the most user-friendly implementation of this feature :/

i don't know, but isn't it more logical from a user point of view, that by default _all_ mute points should be enabled and not disabled? i usually prefer to spend my time composing, rather than filing bug reports because i cannot find some hidden controls ...
(0006581)
thorgal (reporter)
2009-08-21 01:38

I too was surprised that the default changed but on the other hand, you discovered that the "mute" button is more flexible than it looks ;)
(0006582)
timblech (reporter)
2009-08-21 02:33

yes .. however when i explained the issue on the #ardour irc channel, the answer i got after discussing this was `there seems to be a bug, please try an older revision first'
:/
(0006663)
schivmeister (reporter)
2009-09-22 14:32

This cannot be a "feature" because changing the mute options do not hold through. It will revert back to none on the next session. As such, that is definitely not something intended.

Another reason why this is obviously a bug is because /etc/ardour2/ardour_system.rc has:

<Option name="mute-affects-pre-fader" value="yes"/>
<Option name="mute-affects-post-fader" value="yes"/>
<Option name="mute-affects-control-outs" value="yes"/>
<Option name="mute-affects-main-outs" value="yes"/>

But ~/.ardour2 has:

<Option name="mute-affects-pre-fader" value="0"/>
<Option name="mute-affects-post-fader" value="0"/>
<Option name="mute-affects-control-outs" value="0"/>
<Option name="mute-affects-main-outs" value="0"/>

You have to close ardour, edit ~/.ardour2 and change the values to "1", not "yes".
(0006679)
the_CLA (reporter)
2009-10-02 07:03

I just did a quick test: I changed the values in etc/ardour2/ardour_system.rc from "yes" to "1" and now the file ~/.ardour2/ardour.rc gets recreated with the correct values.

So it seems the fix would be to change the default ardour_system.rc accordingly. Sorry, don't know how to create a patch. Someboy else?
(0006680)
schivmeister (reporter)
2009-10-02 07:31

So it was that simple =/

Anyway patch uploaded against current ongoing.
(0006683)
paul (administrator)
2009-10-02 13:57

an alternate (and much more extensive) patch has been committed. this now treats "1" and "yes" (and several other affirmative english forms) as equivalent everywhere that we might test for this. it should fix the mute problem totally, and ensure that similar issues do not arise again.

i'd appreciate confirmation that the fix works.
(0006689)
the_CLA (reporter)
2009-10-06 07:51
edited on: 2009-10-06 07:51

As of revision 5740 ~/.ardour2/ardour.rc still gets created with mute options set to "0" - mute not muting by default.

(0007609)
cth103 (administrator)
2010-04-26 15:57

Confirmed as still a problem in latest 2.0. Fixed in A3.
(0008112)
rlameiro (reporter)
2010-06-01 07:05

patches were committed on Ubuntu and Debian.
see:
https://bugs.launchpad.net/ubuntustudio/+bug/581786 [^]
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=582938 [^]
(0008114)
the_CLA (reporter)
2010-06-01 11:00

The patch in Debian/Ubuntu seems to be only a limited exerpt of the patch previously submitted by shivmeister (see above). AFAIR this patch was considered a workaround but not a real fix, so it didn't get applied.

Unfortunately Pauls attempt of a deeper fix seems to not have worked out for everyone - including me. Just tried current 2.0-ongoing (rev. 7202) on Arch Linux - still the same behaviour.
(0008115)
paul (administrator)
2010-06-01 11:25

please (a) define "fixed" - new session, old session, new tracks, old tracks?
(b) did you remove your own ardour.rc and the system ardour.rc file?
(0008116)
paul (administrator)
2010-06-01 11:27

to clarify my last remark: the correct fix for this will not correct existing tracks in existing sessions. but current versions of ardour do not, i claim, have this behaviour for new sessions or new tracks added to existing sessions. this is true as long as neither your ardour.rc file nor (in some circumstances) the system ardour.rc, have the wrong mute default settings.
(0008117)
the_CLA (reporter)
2010-06-01 11:32
edited on: 2010-06-01 11:38

@paul: New session with ~/.ardour2/ardour.rc removed before starting Ardour.

(it then gets (re)created with the wrong defaults)

(0008118)
paul (administrator)
2010-06-01 12:05

what about the system ardour.rc file?
(0008119)
the_CLA (reporter)
2010-06-01 12:38

ardour_system.rc has value="yes" for mute options in it.
(0008122)
paul (administrator)
2010-06-01 17:30

for those listening in, the_CLA and i went over this on IRC, and there is indeed a bug in ardour. Specifically, stuff in the <Options> section of various RC files is parsed in such a way that "1" and "0" will work to define values correctly as true/false, but "yes" and "no" will both set the value to "false". a fix (and a new release of Ardour) will be forthcoming. the workaround is to use "1" or "0" in all RC files and NOT "yes" or "no".
(0008131)
the_CLA (reporter)
2010-06-02 05:49

Seems fixed in rev. 7205. Newly created ~/ardour2/ardour.rc now contains values as "yes" and "no" instead of "0" and "1". Mute now works by default in newly created projects/tracks.
(0008138)
paul (administrator)
2010-06-02 10:54

caused by incorrect conversion of XML element values to booleans. fixed in 2.0-ongoing and 3.0.

- Issue History
Date Modified Username Field Change
2009-08-19 04:28 timblech New Issue
2009-08-19 04:28 timblech File Added: iod4.ardour
2009-08-20 10:33 thorgal Note Added: 0006575
2009-08-20 11:39 timblech Note Added: 0006576
2009-08-21 01:38 thorgal Note Added: 0006581
2009-08-21 02:33 timblech Note Added: 0006582
2009-09-04 05:13 nettings cost => 0.00
2009-09-04 05:13 nettings Status new => assigned
2009-09-04 05:13 nettings Resolution open => no change required
2009-09-22 14:32 schivmeister Note Added: 0006663
2009-10-02 07:03 the_CLA Note Added: 0006679
2009-10-02 07:29 schivmeister File Added: ardour2-mute_fix.patch
2009-10-02 07:31 schivmeister Note Added: 0006680
2009-10-02 13:57 paul Note Added: 0006683
2009-10-06 07:51 the_CLA Note Added: 0006689
2009-10-06 07:51 the_CLA Note Edited: 0006689
2010-04-25 09:00 cth103 Relationship added has duplicate 0003017
2010-04-26 15:57 cth103 Note Added: 0007609
2010-04-26 15:58 cth103 Tag Attached: fixed in A3
2010-06-01 07:05 rlameiro Note Added: 0008112
2010-06-01 11:00 the_CLA Note Added: 0008114
2010-06-01 11:25 paul Note Added: 0008115
2010-06-01 11:27 paul Note Added: 0008116
2010-06-01 11:32 the_CLA Note Added: 0008117
2010-06-01 11:38 the_CLA Note Edited: 0008117
2010-06-01 12:05 paul Note Added: 0008118
2010-06-01 12:38 the_CLA Note Added: 0008119
2010-06-01 17:30 paul Note Added: 0008122
2010-06-02 05:49 the_CLA Note Added: 0008131
2010-06-02 10:54 paul Note Added: 0008138
2010-06-02 10:54 paul Status assigned => resolved
2010-06-02 10:54 paul Resolution no change required => fixed
2010-06-02 10:54 paul Assigned To => paul
2010-12-13 14:03 cth103 Relationship added has duplicate 0003579


Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker