Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003017 [ardour] bugs minor always 2010-02-07 21:32 2010-06-02 10:53
Reporter ronj View Status public  
Assigned To paul
Priority normal Resolution fixed  
Status resolved   Product Version 2.8.4
Summary 0003017: The "mute" track button doesn't work by default
Description Hello,

Right-clicking on the mute button of a track reveals several options to mute: pre fader, post fader, control out, main out.
However, by default, none of these options are checked, which means the mute button is ineffective, which looks a lot like a bug.

Setting "main out" as default seems a more sensible options:
- Novice users will have the plain mute they want
- Advanced users who expect more options from this button will try right-clicking
Additional Information IRC log:

<ronj> hello
<ronj> bugreport (?): Clicking the record button of a track mutes the track, and the mute (m) button is ineffective. I'm using Ardour 2.8.7 compiled from source / ubuntu studio 9.10 / ffado
<ronj> note: the behaviour is correct when recording (hitting record actually switches recording on), but not when playing back
<dissected> ronj, try right-clicking on the various buttons and explore the different options
<ronj> dissected, thanks! I did not know about these pre/post fader and control/main out. Still, I think what most users expect by default is a simple brutal mute thus "main out" seems a better default to me. Am I missing something? Has it been discussed? Should I file a bug?
<ronj> The current design means these options are more discoverable _if_ the user thinks about right-clicking the mute button (I did not). Else it's just frustating and looks like a bug.
<dissected> ronj, I still consider it a bug
<ronj> agreed, I'm adding it to the tracker
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0002832resolvedpaul `mute' doesn't mute 

-  Notes
(0007350)
the_CLA (reporter)
2010-02-08 08:02

This is a duplicate of http://tracker.ardour.org/view.php?id=2832 [^]
(0008137)
paul (administrator)
2010-06-02 10:53

caused by incorrect conversion of XML element values to boolean values. fixed in 2.0-ongoing and 3.X.

- Issue History
Date Modified Username Field Change
2010-02-07 21:32 ronj New Issue
2010-02-08 08:02 the_CLA Note Added: 0007350
2010-04-24 03:28 cth103 Category bugs => bugs2
2010-04-24 03:30 cth103 Category bugs2 => bugs
2010-04-25 09:00 cth103 Relationship added duplicate of 0002832
2010-04-26 16:01 cth103 Status new => confirmed
2010-06-02 10:53 paul cost => 0.00
2010-06-02 10:53 paul Note Added: 0008137
2010-06-02 10:53 paul Status confirmed => resolved
2010-06-02 10:53 paul Resolution open => fixed
2010-06-02 10:53 paul Assigned To => paul


Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker