View Issue Details

IDCategoryLast Update
0000038bugs2008-11-21 00:03
ReporterpaulAssigned Tov2 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000038: timefx doesn't obey requested lengths
Descriptionwhen stretching time on a region, the result isn't the same length as was requested
Additional Informationthis is a bug in the soundtouch library. other apps (e.g. audacity) are also searching for a fix.
TagsNo tags attached.

Relationships

has duplicate 0000369 closedtaybin timefx does not accurately stretch regions 
related to 0001388 closedtaybin Stretching audio with TimeFX crashes Ardour 
related to 0001483 closedtimbyr Tim's Tracking bug for proposed updates for 2.1 

Activities

taybin

2003-12-12 21:49

administrator   ~0000286

With a bug like that, maybe the feature should be disabled until the library is fixed?

taybin

2004-04-20 16:54

administrator   ~0000644

http://www.clearscale.org looks promising. We'll probably use it when it becomes available.

atreju

2006-11-19 17:31

updater   ~0002808

Closing it since the duplicate has been closed.

taybin

2006-11-19 17:37

administrator   ~0002810

Reopening. The duplicate was closed because it is a duplicate. This bug is still an issue.

atreju

2006-11-19 17:56

updater   ~0002812

clearscale is now know as DIRAC. the liscence is not GPL and thus needs some reading.

Dirac's home page can be found here : http://www.dspdimension.com/index.html?dirac.html

atreju

2006-11-26 21:37

updater   ~0002825

Dirac is not free as discussed on irc.

essej pointed another project that has to be looked into :
http://quitte.de/dsp/pvoc.html

taybin

2006-11-30 19:58

administrator   ~0002833

PVOC looks promising but since they're ladspa plugins, I suspect this would have to wait for the "process region with plugin" feature first.

v2

2008-02-19 06:35

developer   ~0004727

We're using Rubber Band now. This shouldn't be much of an issue anymore.

Issue History

Date Modified Username Field Change
2003-10-07 23:53 paul New Issue
2003-12-12 21:49 taybin Note Added: 0000286
2004-04-20 16:45 taybin Relationship added has duplicate 0000369
2004-04-20 16:54 taybin Note Added: 0000644
2004-04-21 00:55 taybin Status new => confirmed
2006-11-19 17:31 atreju Status confirmed => closed
2006-11-19 17:31 atreju Note Added: 0002808
2006-11-19 17:31 atreju Resolution open => fixed
2006-11-19 17:37 taybin Note Added: 0002810
2006-11-19 17:37 taybin Status closed => confirmed
2006-11-19 17:56 atreju Note Added: 0002812
2006-11-26 21:37 atreju Note Added: 0002825
2006-11-30 19:58 taybin Note Added: 0002833
2007-01-04 20:18 taybin Relationship added related to 0000306
2007-01-04 20:39 taybin Relationship added related to 0001388
2007-02-12 02:43 timbyr Relationship added related to 0001483
2008-02-19 06:35 v2 Status confirmed => resolved
2008-02-19 06:35 v2 Assigned To => v2
2008-02-19 06:35 v2 Note Added: 0004727
2008-11-21 00:03 seablade Status resolved => closed
2010-07-22 14:13 oofus Relationship deleted related to 0000306