View Issue Details

IDCategoryLast Update
0001388bugs2008-11-20 23:50
ReporterflowbotAssigned Totaybin 
Reproducibilityalways 
Status closedResolutionunable to reproduce 
Product Version 
Fixed in Version 
Summary0001388: Stretching audio with TimeFX crashes Ardour
DescriptionWith latest svn on Ubuntu Edgy, use of the TimeFX tool causes ardour to crash after applying it with the default settings. Backtrace attached.
TagsNo tags attached.

Relationships

related to 0000038 closedv2 timefx doesn't obey requested lengths 

Activities

2006-12-30 02:10

 

ardour_crash_on_timestretch.txt (11,073 bytes)
(gdb) run
Starting program: /home/flowbot/dev/svn/ardour2-vst/gtk2_ardour/ardour.bin 
Failed to read a valid object file image from memory.
[Thread debugging using libthread_db enabled]
[New Thread -1237162320 (LWP 6794)]
Ardour/GTK 2.0beta10
   (built using 1239 and GCC version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5))
Copyright (C) 1999-2006 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker

Ardour comes with ABSOLUTELY NO WARRANTY
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
This is free software, and you are welcome to redistribute it 
under certain conditions; see the source for copying conditions.
Loading ui configuration file gtk2_ardour/ardour2_ui.rc
theme_init() called from internal clearlooks engine!
[New Thread -1239364704 (LWP 6806)]
loading system configuration file /etc/ardour2/ardour_system.rc
loading user configuration file /home/flowbot/.ardour2/ardour.rc
OSC @ osc.udp://localhost:3819/
[New Thread -1247900768 (LWP 6807)]
ardour: [INFO]: Using SSE optimized routines
ardour: [INFO]: looking for control protocols in /home/flowbot/.ardour2/surfaces/:/usr/lib/ardour2/surfaces/
ardour: [INFO]: Control surface protocol discovered: "Generic MIDI"
ardour: [INFO]: Control protocol Tranzport not usable
ardour: [WARNING]: Your system generates "Mod2" when the NumLock key is pressed. This can cause problems when editing so Ardour will use Mod3 to mean Meta rather than Mod2
loading bindings from gtk2_ardour/ardour.bindings
[New Thread -1268159584 (LWP 6812)]
[New Thread -1276552288 (LWP 6813)]
Loading session /home/flowbot/audio-projects/ardour/Wishing_Well using snapshot Wishing_Well (1)
[New Thread -1288066144 (LWP 6820)]
[New Thread -1296458848 (LWP 6821)]
Loading history from '/home/flowbot/audio-projects/ardour/Wishing_Well/Wishing_Well.history'.
ardour: [ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR11AudioRegionE id = 1154164203
[New Thread -1356657760 (LWP 6878)]
actually writing state
actually writing history
[Thread -1356657760 (zombie) exited]
[New Thread -1356657760 (LWP 6887)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1356657760 (LWP 6887)]
end () at libs/soundtouch/cpu_detect_x86_gcc.cpp:136
136         return res & ~_dwDisabledISA;
(gdb) thread apply all bt

Thread 9 (Thread -1356657760 (LWP 6887)):
#0  end () at libs/soundtouch/cpu_detect_x86_gcc.cpp:136
#1  0xb6b4c56c in soundtouch::FIRFilter::newInstance ()
    at libs/soundtouch/FIRFilter.cpp:219
#2  0xb6b4bc5d in AAFilter (this=0xa88d448, length=32)
    at libs/soundtouch/AAFilter.cpp:63
#3  0xb6b4e560 in RateTransposer (this=0x9c41470)
    at libs/soundtouch/RateTransposer.cpp:129
#4  0xb6b4e614 in RateTransposerFloat (this=0x9c41470)
    at libs/soundtouch/RateTransposer.cpp:501
#5  0xb6b4e697 in soundtouch::RateTransposer::newInstance ()
    at libs/soundtouch/RateTransposer.cpp:116
#6  0xb6b4fb37 in SoundTouch (this=0xaf23023c)
    at libs/soundtouch/SoundTouch.cpp:97
#7  0xb7ea708f in ARDOUR::Session::tempoize_region (this=0x8ea09a8, 
    tsr=@0xaa2c644) at libs/ardour/session_timefx.cc:47
#8  0x085089d2 in Editor::do_timestretch (this=0x8c91550, dialog=@0xaa2c630)
    at gtk2_ardour/editor_timefx.cc:201
#9  0x08508dad in Editor::timestretch_thread (arg=0xaa2c630)
    at gtk2_ardour/editor_timefx.cc:229
#10 0xb6940504 in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#11 0xb68d451e in clone () from /lib/tls/i686/cmov/libc.so.6
---Type <return> to continue, or q <return> to quit---

Thread 7 (Thread -1296458848 (LWP 6821)):
#0  0xb7f3e410 in ?? ()
#1  0xb2b99358 in ?? ()
#2  0xffffffff in ?? ()
#3  0x00000002 in ?? ()
#4  0x00000002 in ?? ()
#5  0xb2b99ba0 in ?? ()
#6  0x00000000 in ?? ()

Thread 6 (Thread -1288066144 (LWP 6820)):
#0  0xb7f3e410 in ?? ()
#1  0xb339a338 in ?? ()
#2  0xffffffff in ?? ()
#3  0x00000001 in ?? ()
#4  0x00000000 in ?? ()

Thread 5 (Thread -1276552288 (LWP 6813)):
#0  0xb7f3e410 in ?? ()
#1  0xb3e94428 in ?? ()
#2  0x000003e8 in ?? ()
#3  0x00000002 in ?? ()
#4  0x00000000 in ?? ()
---Type <return> to continue, or q <return> to quit---

Thread 4 (Thread -1268159584 (LWP 6812)):
#0  0xb7f3e410 in ?? ()
#1  0xb46963f8 in ?? ()
#2  0xffffffff in ?? ()
#3  0x00000001 in ?? ()
#4  0x00000000 in ?? ()

Thread 3 (Thread -1247900768 (LWP 6807)):
#0  0xb7f3e410 in ?? ()
#1  0xb59e83f8 in ?? ()
#2  0xffffffff in ?? ()
#3  0x00000002 in ?? ()
#4  0x00000000 in ?? ()

Thread 2 (Thread -1239364704 (LWP 6806)):
#0  0xb7f3e410 in ?? ()
#1  0xb620c3a8 in ?? ()
#2  0xb77131e4 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb620c38c in ?? ()
#4  0xb6946bf6 in __nanosleep_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb76cd2f2 in g_usleep () from /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#6  0xb6de0481 in Glib::usleep (microseconds=10000)
    at libs/glibmm2/glibmm/timer.cc:68
#7  0xb7d43b82 in ARDOUR::AudioEngine::meter_thread (this=0x896a1d8)
    at libs/ardour/audioengine.cc:400
#8  0xb7d46bfc in sigc::bound_mem_functor0<void, ARDOUR::AudioEngine>::operator() (this=0x8969f04) at libs/sigc++2/sigc++/functors/mem_fun.h:1781
#9  0xb7d46c1e in sigc::adaptor_functor<sigc::bound_mem_functor0<void, ARDOUR::AudioEngine> >::operator() (this=0x8969f00)
    at libs/sigc++2/sigc++/adaptors/adaptor_trait.h:251
#10 0xb7d46c4a in sigc::internal::slot_call0<sigc::bound_mem_functor0<void, ARDOUR::AudioEngine>, void>::call_it (rep=0x8969ee8)
    at libs/sigc++2/sigc++/functors/slot.h:103
#11 0x083538f6 in sigc::slot0<void>::operator() (this=0x896cfd8)
    at libs/sigc++2/sigc++/functors/slot.h:440
#12 0xb6de6933 in call_thread_entry_slot (data=0x896cfd8)
    at libs/glibmm2/glibmm/thread.cc:43
#13 0xb76cb38f in g_thread_create_full () from /usr/lib/libglib-2.0.so.0
#14 0xb6940504 in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#15 0xb68d451e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread -1237162320 (LWP 6794)):
#0  0xb7f3e410 in ?? ()
#1  0xbff266c8 in ?? ()
---Type <return> to continue, or q <return> to quit---
#2  0x0000000d in ?? ()
#3  0xb76b0813 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#4  0xb76b0d45 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb73b83e4 in gtk_main_iteration () from /usr/lib/libgtk-x11-2.0.so.0
#6  0x0850a1f2 in Editor::run_timestretch (this=0x8c91550, regions=@0x8cb4f2c, 
    fraction=-4.72223377) at gtk2_ardour/editor_timefx.cc:149
#7  0x084bf8a6 in Editor::end_time_fx (this=0x8c91550, item=0xaa30fd8, 
    event=0xaa280c0) at gtk2_ardour/editor_mouse.cc:4808
#8  0x084c726c in Editor::end_grab (this=0x8c91550, item=0xaa30fd8, 
    event=0xaa280c0) at gtk2_ardour/editor_mouse.cc:1686
#9  0x084d09e4 in Editor::button_release_handler (this=0x8c91550, 
    item=0xaa30fd8, event=0xaa280c0, item_type=RegionItem)
    at gtk2_ardour/editor_mouse.cc:837
#10 0x084a3525 in Editor::canvas_region_view_event (this=0x8c91550, 
    event=0xaa280c0, item=0xaa30fd8, rv=0xaa30e50)
    at gtk2_ardour/editor_canvas_events.cc:231
#11 0x08634e1d in sigc::bound_mem_functor3<bool, PublicEditor, _GdkEvent*, Gnome::Canvas::Item*, RegionView*>::operator() (this=0xa597760, _A_a1=@0xbff26a84, 
    _A_a2=@0xbff269e4, _A_a3=@0xa597770)
    at libs/sigc++2/sigc++/functors/mem_fun.h:1958
#12 0x08634e59 in sigc::adaptor_functor<sigc::bound_mem_functor3<bool, PublicEditor, _GdkEvent*, Gnome::Canvas::Item*, RegionView*> >::operator()<_GdkEvent* const&, Gnome::Canvas::Group*&, RegionView*&> (this=0xa59775c, 
---Type <return> to continue, or q <return> to quit---
    _A_arg1=@0xbff26a84, _A_arg2=@0xa59776c, _A_arg3=@0xa597770)
    at libs/sigc++2/sigc++/adaptors/adaptor_trait.h:123
#13 0x08634e8d in sigc::bind_functor<-1, sigc::bound_mem_functor3<bool, PublicEditor, _GdkEvent*, Gnome::Canvas::Item*, RegionView*>, Gnome::Canvas::Group*, RegionView*, sigc::nil, sigc::nil, sigc::nil, sigc::nil, sigc::nil>::operator()<_GdkEvent* const&> (this=0xa597758, _A_arg1=@0xbff26a84)
    at libs/sigc++2/sigc++/adaptors/bind.h:1335
#14 0x08634eb3 in sigc::internal::slot_call1<sigc::bind_functor<-1, sigc::bound_mem_functor3<bool, PublicEditor, _GdkEvent*, Gnome::Canvas::Item*, RegionView*>, Gnome::Canvas::Group*, RegionView*, sigc::nil, sigc::nil, sigc::nil, sigc::nil, sigc::nil>, bool, _GdkEvent*>::call_it (rep=0xa597740, a_1=@0xbff26a84)
    at libs/sigc++2/sigc++/functors/slot.h:137
#15 0xb78b7037 in sigc::slot1<bool, _GdkEvent*>::operator() (this=0x989b2dc, 
    _A_a1=@0xbff26a84) at libs/sigc++2/sigc++/functors/slot.h:512
#16 0xb6fdd5b6 in (anonymous namespace)::Item_signal_event_callback (
    self=0xaa6ed08, p0=0xaa280c0, data=0x989b2d8)
    at libs/libgnomecanvasmm/libgnomecanvasmm/item.cc:138
#17 0xb7633160 in gnome_canvas_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgnomecanvas-2.so.0
#18 0xb765179b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#19 0xb7661e81 in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
#20 0xb7662e7f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#21 0xb7663279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#22 0xb762e974 in gnome_canvas_window_to_world ()
   from /usr/lib/libgnomecanvas-2.so.0
#23 0xb76300d8 in gnome_canvas_set_scroll_region ()
   from /usr/lib/libgnomecanvas-2.so.0
#24 0xb78b01d8 in Gtk::Widget_Class::button_release_event_callback (
    self=0x8c96030, p0=0xa3662f0) at libs/gtkmm2/gtk/gtkmm/widget.cc:3805
#25 0xb73bdb00 in _gtk_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgtk-x11-2.0.so.0
#26 0xb764ffb9 in g_value_set_boxed () from /usr/lib/libgobject-2.0.so.0
#27 0xb765179b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#28 0xb76621e3 in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
#29 0xb7662e7f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#30 0xb7663279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#31 0xb74d15f8 in gtk_widget_get_default_style ()
   from /usr/lib/libgtk-x11-2.0.so.0
#32 0xb73b6ef3 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#33 0xb73b80f7 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#34 0xb72407ea in _gdk_events_init () from /usr/lib/libgdk-x11-2.0.so.0
#35 0xb76ad802 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0xb76b07df in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#37 0xb76b0b89 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#38 0xb73b8574 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#39 0xb78cfa8d in Gtk::Main::run_impl (this=0x87e57a8)
    at libs/gtkmm2/gtk/gtkmm/main.cc:503
#40 0xb78cf89a in Gtk::Main::run () at libs/gtkmm2/gtk/gtkmm/main.cc:450
#41 0xb7b398b3 in Gtkmm2ext::UI::run (this=0x87e57e8, old_receiver=@0x87c1260)
    at libs/gtkmm2ext/gtk_ui.cc:214
#42 0x085907c9 in main (argc=1, argv=0xbff277b4) at gtk2_ardour/main.cc:453
136         return res & ~_dwDisabledISA;
(gdb) 

taybin

2007-01-04 20:41

administrator   ~0003002

This looks to be internal to libsoundtouch. Can you recompile with DEBUG=yes, and recreate it?

flowbot

2007-01-05 09:01

reporter   ~0003009

i built ardour2beta10 with debugging, but cannot reproduce now. also, with latest svn (1273) it is working, too.

Issue History

Date Modified Username Field Change
2006-12-30 02:10 flowbot New Issue
2006-12-30 02:10 flowbot File Added: ardour_crash_on_timestretch.txt
2007-01-04 20:39 taybin Relationship added related to 0000038
2007-01-04 20:41 taybin Note Added: 0003002
2007-01-05 09:01 flowbot Note Added: 0003009
2007-01-05 12:46 taybin Status new => resolved
2007-01-05 12:46 taybin Fixed in Version => 2.0beta10
2007-01-05 12:46 taybin Resolution open => fixed
2007-01-05 12:46 taybin Assigned To => taybin
2007-01-05 12:46 taybin Resolution fixed => unable to reproduce
2008-11-20 23:50 seablade Status resolved => closed