View Issue Details

IDCategoryLast Update
0008810bugs2021-12-01 04:54
ReporterthorgalAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformDebian GNUOSLinuxOS Version(any)
Product Version6.9 
Fixed in Version 
Summary0008810: Jack connections are not reestablished after disconnecting from and reconnecting to jack
DescriptionWhen disconnecting from jack from the audio setup window, all tracks and busses are disconnected from jack as they should. When reconnecting to jack from the same menu, no connection is reestablished. I had seen this in 6.8 as well.
Steps To Reproduce- make sure jackd is running
- create new empty session and use jack as audio backend
- add a few audio tracks and / or busses (preferably auto-connecting), check that all tracks / busses are connected to hw inputs and master bus
- bring up the audio setup window
- disconnected from jack, but leave jackd running
- check that all tracks and busses are connected to nothing, master bus ins have lost all connections as well
- reconnect to jack: no connection is back

Additional InformationAs far as I know, 6.8 has the same bug. I also noticed that occasionally, after disconnecting from jack, ardour may crash when clicking on some button.
A session example is added with 4 audio tracks, none of them are connected after the above actions.
TagsNo tags attached.

Relationships

duplicate of 0008723 closedx42 inputs and outputs lost when reconnecting to jack 

Activities

thorgal

2021-10-10 17:11

reporter  

session.tar.bz2 (6,207 bytes)

Daniele1971

2021-10-23 12:55

reporter   ~0026195

Confirmed, it happens with both jack and pipewire-jack. All connections lost and the only "fix" is remaking them all one by one.

x42

2021-11-03 22:55

administrator   ~0026212

Fixed in 7.0-pre0-1157-g79330f909e

Issue History

Date Modified Username Field Change
2021-10-10 17:11 thorgal New Issue
2021-10-10 17:11 thorgal File Added: session.tar.bz2
2021-10-23 12:55 Daniele1971 Note Added: 0026195
2021-11-03 22:55 x42 Assigned To => x42
2021-11-03 22:55 x42 Status new => resolved
2021-11-03 22:55 x42 Resolution open => fixed
2021-11-03 22:55 x42 Note Added: 0026212
2021-12-01 04:54 x42 Relationship added duplicate of 0008723