View Issue Details

IDCategoryLast Update
0008723bugs2021-12-01 04:55
Reporterjayache80Assigned Tox42 
Reproducibilitysometimes 
Status closedResolutionfixed 
PlatformGNUOSLinuxOS Version(any)
Product Version6.7 
Fixed in Version 
Summary0008723: inputs and outputs lost when reconnecting to jack
DescriptionIf the jackd process ended while Ardour was running, Ardour will detect this. If the user restarts the jackd process, and reconnects Ardour to jack, sometimes the inputs/output assignments are lost. For example, the typical output of "Master in" for each track may be set to nothing, and the master track's hardware outputs (e.g. out 1+2) may be set to nothing. Similarly, inputs maybe set to nothing in the same way.
Steps To Reproduce1. Run an Ardour session that uses jack
2. Kill jackd suddenly
3. Restart jackd
4. Reconnect Ardour to jack using Audio/MIDI Setup dialogue box
5. Observe missing output and input assignments
Additional InformationI was using jack2 when this happened to me, but this was purportedly reproduced using jack 1 as well.
TagsNo tags attached.

Relationships

has duplicate 0008810 resolvedx42 Jack connections are not reestablished after disconnecting from and reconnecting to jack 

Activities

Werner Back

2021-05-26 09:06

reporter   ~0025891

Same or similar problem here, I wanted to change the audio interface , after that all audio was disconnected. Worse than that, EVERY routing was gone, even if no hardware i/o was involved, eg. a input channel to a bus.

telbel

2021-06-13 09:02

reporter   ~0025951

Similar issue, different steps to reproduce:

1. Run an Ardour session that uses JACK.
2. Goto Audio/MIDI setup.
3. Press stop.
4. Change audio system to ALSA.
5. Change audio system to JACK.
6. Choose a different buffer size.
7. Press start.
8. All input and output audio assignments have been disconnected.

The purpose of step 4 and 5 is to allow me to change the buffer size in step 6. If I skip step 4 and 5, the sample rate list only shows the current buffer size.

telbel

2021-06-13 10:31

reporter   ~0025952

Just noticed it happen when changing period instead of buffer size:

1. Run an Ardour session that uses JACK.
2. Goto Audio/MIDI setup.
3. Press stop.
4. Choose a different period.
5. Press start.
6. All input and output audio assignments have been disconnected.

x42

2021-12-01 04:55

administrator   ~0026267

Fixed since 7.0-pre0-1157-g79330f909e

anonymous

2021-12-01 04:55

viewer   ~0026268

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-05-24 22:06 jayache80 New Issue
2021-05-26 09:06 Werner Back Note Added: 0025891
2021-06-13 09:02 telbel Note Added: 0025951
2021-06-13 10:31 telbel Note Added: 0025952
2021-12-01 04:54 x42 Relationship added has duplicate 0008810
2021-12-01 04:55 x42 Note Added: 0026267
2021-12-01 04:55 x42 Assigned To => x42
2021-12-01 04:55 x42 Status new => resolved
2021-12-01 04:55 x42 Resolution open => fixed
2021-12-01 04:55 anonymous Note Added: 0026268
2021-12-01 04:55 anonymous Status resolved => closed