View Issue Details

IDCategoryLast Update
0008626bugs2021-05-16 21:31
ReportererojahnAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.6 
Fixed in Version 
Summary0008626: GUI pool out of memory when inserting silence.
DescriptionI have a project with 26 Tracks and when i try to insert silence to all tracks the project crashes. I get the message that the GUI pool is out of memory and i should recpompile with larger size.
TagsNo tags attached.

Relationships

related to 0008576 closedx42 "GUI POOL OUT OF MEMORY" crash when using Alt+7 on a group of audio clips 

Activities

x42

2021-03-21 13:49

administrator   ~0025625

Do you mean Track > Insert Time?

How do you "insert silence"? Can you share the .ardour session file and a description how you reproduce the issue?

In a quick test with 32 tracks, insert time works fine here. So there must be an additional factor in your case (many regions, automation or..)

erojahn

2021-03-21 18:19

reporter   ~0025627

Yes, i do mean that.
Before doing the menu clicking i just select all tracks with strg+t. Then Track>Insert Time. I try to add 8 bars.
On the end of the Project it does work. I also tried it in the beginning of the projects, so there are no regions under the positionmarker. There it doesnt work.
So it seems maybe it is just too much to move around... There is pretty heavy processing on the Tracks. I have another installation of 6.5 and there it works.
Do you mean this file?

erojahn

2021-03-21 18:22

reporter   ~0025628

The file was too big here is the compressed file.

erojahn

2021-03-21 18:23

reporter   ~0025629

ok something doesnt work with the upload

erojahn

2021-03-21 18:32

reporter   ~0025630

Here it is: https://nextcloud05.webo.cloud/s/jCC2RyrrGHme2Hs
Password is Ardour6.6

x42

2021-03-21 18:46

administrator   ~0025631

Got the file (you can remove it again). Thanks

x42

2021-03-21 18:49

administrator   ~0025632

reproduced the issue (adding 8 bars at session-start).

x42

2021-03-21 21:47

administrator   ~0025634

Fixed in 6.6.157 - please test

anonymous

2021-05-16 21:31

viewer   ~0025856

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-03-17 21:31 erojahn New Issue
2021-03-21 13:49 x42 Note Added: 0025625
2021-03-21 18:19 erojahn Note Added: 0025627
2021-03-21 18:22 erojahn Note Added: 0025628
2021-03-21 18:23 erojahn Note Added: 0025629
2021-03-21 18:32 erojahn Note Added: 0025630
2021-03-21 18:46 x42 Note Added: 0025631
2021-03-21 18:49 x42 Assigned To => x42
2021-03-21 18:49 x42 Status new => confirmed
2021-03-21 18:49 x42 Note Added: 0025632
2021-03-21 21:47 x42 Note Added: 0025634
2021-03-21 21:48 x42 Status confirmed => resolved
2021-03-21 21:48 x42 Resolution open => fixed
2021-03-21 21:49 x42 Relationship added related to 0008576
2021-05-16 21:31 anonymous Note Added: 0025856
2021-05-16 21:31 anonymous Status resolved => closed