View Issue Details

IDCategoryLast Update
0008472bugs2021-02-19 23:52
Reportermartin.vlkAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.3 
Fixed in Version 
Summary0008472: Newly added audio tracks are not correctly compensated for latency until Ardour session is reloaded
DescriptionWhen I add one track to a new sassion, the compensation works fine.
On a second and next newly added tracks latency compensation is wrong, leading to the recording being off.
Tagsjack

Relationships

related to 0008365 new Randomly introduced latency 
related to 0008304 feedbackx42 Latency compensation failure 
has duplicate 0008502 feedback Duplicate tracks are not correctly aligned 
has duplicate 0008575 feedbackx42 Newly added audio tracks have unexpected and uncompensated latency 
has duplicate 0008564 assignedx42 New track has a short delay. 

Activities

x42

2020-11-21 20:10

administrator   ~0025247

I cannot reproduce this. Does this only happen with jack? and if so which version of jack?

martin.vlk

2020-11-21 20:16

reporter   ~0025248

Ah, yes I forgot to mention it is with JACK v1.9.12

Xard

2020-11-21 22:59

reporter   ~0025249

I'm affected by this issue as well and it's quite easy to see that adding tracks to loaded session are not in sync with the existing tracks. This covers both audio and midi tracks.

As requested I did a "jack_lsp -l" after
1. adding a track to existing project
2. saving the project and reloading it

Ardour_jack_latency_dbg.log (8,228 bytes)

Xard

2020-11-21 23:04

reporter   ~0025250

I'll upload to new file as the copy & paste from terminal was borked in the last post and this forum does not seem to support editing.

Ardour_jack_latency_dbg2.log (9,731 bytes)

Xard

2020-11-21 23:47

reporter   ~0025251

And before forgetting I also have JACK2 1.9.12 so that seems to match.

Xard

2020-11-21 23:57

reporter   ~0025252

Also this seems to consider only new tracks being added to existing projects. After saving and loading a project everything is in sync again.

To mitigate this issue a pool of needed (audio, midi, bus) tracks can be created in advance and then saving and loading the project again as changing tracks routing and plugins does not affect the latency.

consint

2020-11-25 10:36

reporter   ~0025267

I can confirm this issue with Ardour 6.3 on Ubuntu 20.4 using JACK. I also have this problem when I use the import dialog to load an audio file into a new track of an existing project.

x42

2021-01-14 02:25

administrator   ~0025418

Possibly fixed in 6.5-120-g0c81ba33d2, please test!

Xard

2021-01-26 19:15

reporter   ~0025471

Hello,

Sorry this took a while to try but I tested using Jack with 6.5-172-g046d7d01f5 build which I pulled from git master branch and the problem is still present. However as I'm not sure which commit was related to the potential fix so I'm not sure if it's included in my build or not. (or if there's something related to build environment)

magnetophon

2021-02-15 11:32

reporter   ~0025521

I just tried with https://github.com/Ardour/ardour/commit/d05572e14a1f95ed3da0c9ed2fde07f9c9c732da and the bug is still there.
I'm using jackdmp 1.9.17.

x42

2021-02-19 23:52

administrator   ~0025536

Last edited: 2021-02-19 23:52

View 2 revisions

FIxed in 6.5-264-g4a5b355d3d

anonymous

2021-02-19 23:52

viewer   ~0025537

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-11-21 20:08 martin.vlk New Issue
2020-11-21 20:10 x42 Relationship added related to 0008365
2020-11-21 20:10 x42 Note Added: 0025247
2020-11-21 20:16 martin.vlk Note Added: 0025248
2020-11-21 20:17 martin.vlk Tag Attached: jack
2020-11-21 22:59 Xard File Added: Ardour_jack_latency_dbg.log
2020-11-21 22:59 Xard Note Added: 0025249
2020-11-21 23:04 Xard File Added: Ardour_jack_latency_dbg2.log
2020-11-21 23:04 Xard Note Added: 0025250
2020-11-21 23:47 Xard Note Added: 0025251
2020-11-21 23:57 Xard Note Added: 0025252
2020-11-25 10:36 consint Note Added: 0025267
2020-12-15 23:12 x42 Relationship added has duplicate 0008502
2021-01-14 02:24 x42 Relationship added related to 0008304
2021-01-14 02:25 x42 Assigned To => x42
2021-01-14 02:25 x42 Status new => feedback
2021-01-14 02:25 x42 Note Added: 0025418
2021-01-26 19:15 Xard Note Added: 0025471
2021-02-15 11:32 magnetophon Note Added: 0025521
2021-02-15 17:41 x42 Relationship added has duplicate 0008575
2021-02-18 20:32 x42 Relationship added has duplicate 0008564
2021-02-19 23:52 x42 Status feedback => resolved
2021-02-19 23:52 x42 Resolution open => fixed
2021-02-19 23:52 x42 Note Added: 0025536
2021-02-19 23:52 anonymous Note Added: 0025537
2021-02-19 23:52 anonymous Status resolved => closed
2021-02-19 23:52 x42 Note Edited: 0025536 View Revisions