View Issue Details

IDCategoryLast Update
0008307bugs2020-07-18 23:52
ReporterunfaAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformArchOSLinuxOS Version(any)
Product Version 
Fixed in Version 
Summary0008307: Fan out creates redundant audio routing
DescriptionRecently when I was using Geonkick (16-channel) in Ardour 6.0 I've noticed that when I add the plug-in and enable the fan-out routing in Ardour - it'll create 16 mono buses, and route appropriate plug-in outputs to them, but it'll also leave the 16 outputs being sent to Master (odd sent to Master L, and even sent to Master R).

I would expect the "default" direct routing from the MIDI track to the Master bus to be removed if there's buses created between them.
Additional InformationHere you an see me adding a MIDI track with Geonkick using fan-out, and later fixing the audio routing:
https://youtu.be/MmGLTOkNenc?t=2540
TagsNo tags attached.

Relationships

related to 0008317 resolvedx42 MIDI track are created with no output routing 

Activities

x42

2020-07-13 15:47

administrator   ~0024727

That seems like a bug.
However I cannot reproduce this with AVLDrums or drumgizmo. Can you?
Ardour 6.2?

I don't have geonkick installed, one explanation would be that it does specify an additional master out in its LV2 meta-data.

x42

2020-07-13 17:06

administrator   ~0024730

Sadly I cannot reproduce this with geonkick either.
geonkick v2.2.3-5-g829e602 (current git), Ardour 6.2.0 from ardour.org (ALSA backend)

unfa

2020-07-13 21:32

reporter   ~0024733

I need to test with 6.2, maybe it's fixed there already. I'll let know if it still happens there.

x42

2020-07-13 23:53

administrator   ~0024735

Testing with a https://nightly.ardour.org/ build (demo is fine) would be useful.

I also checked with JACK just now and cannot reproduce the issue here (jack 1.9.12 from debian/stable), but taking JACK out of the loop would be another thing to try.

x42

2020-07-18 23:39

administrator   ~0024768

Fixed since Ardour 6.2-42-gc778ded411

unfa

2020-07-18 23:52

reporter   ~0024769

Fantastic! Thank you!

Issue History

Date Modified Username Field Change
2020-07-13 10:32 unfa New Issue
2020-07-13 15:47 x42 Note Added: 0024727
2020-07-13 15:47 x42 Assigned To => x42
2020-07-13 15:47 x42 Status new => feedback
2020-07-13 17:06 x42 Note Added: 0024730
2020-07-13 17:06 x42 Assigned To x42 =>
2020-07-13 21:32 unfa Note Added: 0024733
2020-07-13 21:32 unfa Status feedback => new
2020-07-13 23:53 x42 Note Added: 0024735
2020-07-18 20:35 x42 Relationship added related to 0008317
2020-07-18 23:39 x42 Assigned To => x42
2020-07-18 23:39 x42 Status new => resolved
2020-07-18 23:39 x42 Resolution open => fixed
2020-07-18 23:39 x42 Note Added: 0024768
2020-07-18 23:52 unfa Note Added: 0024769