View Issue Details

IDCategoryLast Update
0008063bugs2020-06-27 00:15
ReporterserdemanAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformIntel i3 laptopOSLinuxOS VersionMint 19 Cinnamon
Product Version6.0-pre1 
Fixed in Version 
Summary0008063: 6rc1.107: Half-Crash on channel PFL
DescriptionAfter a PFL selection, audio would stop, meters froze at current state, and the transport became unresponsive. I could still select channel strips and they would highlight. I could also open up the log window (Though the log did not have any new entries). I could also select every main menu at the top and their drop-downs would open up. yet, none of their action would work. Trying to Close the session did nothing.
Steps To ReproduceIn the Edit window. Opened up an LSP plugin on a channel. Pressed the channel's PFL.

Note: I was doing this in the Edit window. I noticed that the little Horizontal channel strip's PFL button, when pressed, would not look engaged. yet, since I have the edit window view set so each selected track's mixer strip shows up on the left side, I could see that strip had it's PFL engaged. Once this half-locked up state happens, you cannot disengage the PFL.

gdb file is attached.
TagsNo tags attached.

Relationships

related to 0008055 closedx42 Ardour 6.0.rc1.82 - Session Crash 

Activities

serdeman

2020-04-28 00:15

reporter  

Ardour 6rc1.107 gdb output (60,649 bytes)

x42

2020-04-28 00:37

administrator   ~0023977

Fixed in 6.0-rc1-120-g24d3bf25a9

serdeman

2020-04-28 00:49

reporter   ~0023978

x42, that was a fast resolve! Can't wait to download 120.

anonymous

2020-06-27 00:15

viewer   ~0024511

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-04-28 00:15 serdeman New Issue
2020-04-28 00:15 serdeman File Added: Ardour 6rc1.107 gdb output
2020-04-28 00:36 x42 Relationship added related to 0008055
2020-04-28 00:37 x42 Assigned To => x42
2020-04-28 00:37 x42 Status new => resolved
2020-04-28 00:37 x42 Resolution open => fixed
2020-04-28 00:37 x42 Note Added: 0023977
2020-04-28 00:49 serdeman Note Added: 0023978
2020-06-27 00:15 anonymous Note Added: 0024511
2020-06-27 00:15 anonymous Status resolved => closed