View Issue Details

IDCategoryLast Update
0008052bugs2020-05-18 20:58
Reporteragus.terolAssigned To 
Reproducibilityalways 
Status closedResolutionduplicate 
PlatformGNU/Linux x86_64OSDebianOS Versionsid
Product Version 
Fixed in Version 
Summary0008052: A MIDI device connected after opening “Audio/MIDI Setup” window appears when calibrating another MIDI device
DescriptionA MIDI device that is connected after opening “Audio/MIDI Setup” window does not appear in the list of MIDI devices after clicking “Midi Device Setup” button (issue 0008051 can help with this), but it appears when calibrating another MIDI device. This results in users can select in “Output channel” and “Input channel” drop-down lists another MIDI device that was connected just before opening the calibration window of an already connected MIDI device.
Steps To Reproduce    1. After launching Ardour and opening (or creating) a session, the “Audio/MIDI Setup” window is displayed.
    2. Click on “Midi Device Setup”, and check current available devices.
    3. Connect a new USB MIDI device.
    4. Connected device will not appear in the list, so click on “Calibrate” button of any other device.

Expected: “Output channel” and “Input channel” drop-down lists only show the current device.
Actually: “Output channel” and “Input channel” drop-down lists show the current device plus the new device recently connected.
TagsNo tags attached.

Relationships

duplicate of 0008053 new A MIDI device connected after opening “Audio/MIDI Setup” window appears when calibrating another MIDI device 

Activities

agus.terol

2020-04-24 19:32

reporter   ~0023901

Please, close this issue as duplicated of 0008053, which has more info. I thought this was not created after receiving a error message from the bug tracker.

Issue History

Date Modified Username Field Change
2020-04-24 18:30 agus.terol New Issue
2020-04-24 19:32 agus.terol Note Added: 0023901
2020-05-18 20:58 x42 Status new => closed
2020-05-18 20:58 x42 Resolution open => duplicate
2020-05-18 20:58 x42 Relationship added duplicate of 0008053