View Issue Details

IDCategoryLast Update
0008051features2020-06-23 18:25
Reporteragus.terolAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformGNU/Linux x86_64OSDebianOS Versionsid
Product Version6.0-pre1 
Fixed in Version 
Summary0008051: Add a “Refresh devices” button in “Audio/MIDI Setup” window
DescriptionUsually after opening Ardour, I realize that I have not turned on all my music gear. So, I turn them on, but they do not appear in the drop-down selection widgets. For instance, if you have an USB audio interface with a on/off switch, after turning it on, it will not appear. A workaround is to switch between audio engines and it appears (for instance, having ALSA selected, go to JACK, and then go back to ALSA).

Something similar happens with MIDI devices. The above workaround also works here, but there is another workaround that would prevent to mess the already measured audio latency values if using a USB device (usually change after an audio engine “stop"-"start" cycle), which consists in to select “None” in “MIDI System”, and then go back to the previously MIDI system.

So, a “Refresh devices” button might help to improve here the workflow and help users in a more obvious way if for some reason, after launching Ardour their devices are turned on, and they do not appear in the drop-down selection widgets or in the MIDI devices list.
TagsNo tags attached.

Activities

x42

2020-04-24 20:04

administrator   ~0023902

If you use ALSA Sequencer, Ardour6 allows to hotplug MIDI devices. No Start/Stop cycle is needed.

agus.terol

2020-04-24 20:09

reporter   ~0023903

That is good to know. However, I do not know the difference between "ALSA Sequencer" and "ALSA Raw", do you recommend one above the other? I mean, is there any advantage or disadvantage?

Anyway, in that case, the button will do nothing for "ALSA Sequencer", but it still would need to do something for audio devices or "ALSA Raw" MIDI devices.

x42

2020-04-29 00:33

administrator   ~0023995

"Refresh Devices" was added in 6.0-rc1-140-g47bb331bfa

As for the MIDI options:
* ALSA Sequencer: the kernel time-stamps the MIDI events, and handles the messages. The device can be shared with other ALSA apps.
* ALSA Raw: Ardour directly communicates with the hardware. This requires exclusive access to exchange raw midi message.

In some cases the timing (latency and jitter) is better (lower) when Ardour directly uses the hardware without indirection. In many cases there is however little difference.
There are too many factors (kernel version, soundcard, bus (PCI/USB), chipset etc). So you have to test the timing on your machine by measuring it.
Another relevant question is if you want to use other ALSA Sequencer apps (eg. VMPK) alongside Ardour, or if you want to prevent those from accessing the device (raw).

agus.terol

2020-05-04 12:49

reporter   ~0024060

I could verify it in 6.0-rc1-176-gacb8f9eb28. Thank you!

Very appreciated also the explanation about ALSA sequencer and ALSA raw.

anonymous

2020-06-23 18:25

viewer   ~0024494

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-04-24 18:25 agus.terol New Issue
2020-04-24 20:04 x42 Note Added: 0023902
2020-04-24 20:09 agus.terol Note Added: 0023903
2020-04-29 00:33 x42 Assigned To => x42
2020-04-29 00:33 x42 Status new => resolved
2020-04-29 00:33 x42 Resolution open => fixed
2020-04-29 00:33 x42 Note Added: 0023995
2020-05-04 12:49 agus.terol Note Added: 0024060
2020-06-23 18:25 anonymous Note Added: 0024494
2020-06-23 18:25 anonymous Status resolved => closed