View Issue Details

IDCategoryLast Update
0008035translation2020-06-19 16:31
ReporterimportmidiAssigned Tox42 
ReproducibilityN/A 
Status closedResolutionfixed 
PlatformSome Other LinuxOSSome Other LinuxOS Versionunknown
Product Version6.0-pre1 
Fixed in Version 
Summary0008035: update french translation
Descriptionduring the translation I have met :

one typo in gtk2_ardour/po : line 2155 >> loAcate

W/Ardour is running : in session/properties/misc : 2 ticked boxes empty behind "glue to bars & beats"

                                     up right in monitor-section of the mixer : isolated solo button doesn't blink but operates (it stops isolating)


TagsNo tags attached.

Relationships

has duplicate 0008019 closedx42 Update french translation 

Activities

importmidi

2020-04-20 16:31

reporter  

0004-update-french-translation.patch.bz2 (20,500 bytes)

x42

2020-04-20 17:22

administrator   ~0023830

"isolated solo button doesn't blink but operates (it stops isolating)"

That is normal, also clicking on "solo" resets solo state, and "audition" button disables auditioning. The Solo Isolate button only blinks when a track is solo isolated (solo is enabled).

importmidi

2020-04-20 17:31

reporter   ~0023831

yes, that's what I was wanting to say (sorry) the solo isolate doesn't blink when you isolate a solo

x42

2020-04-20 21:58

administrator   ~0023832

I've applied the patch Ardour 6.0-rc1-31-g1c7c0533c2

I have not found the "loAcate" and I don't know what you mean with "2 ticked boxes empty behind glue to bars & beats"

session-props.png (33,466 bytes)
session-props.png (33,466 bytes)

x42

2020-04-20 22:03

administrator   ~0023833

is "défilement" what audio-engineers use for "transport" in french? I was under the impression that it's "le transport"

importmidi

2020-04-20 23:27

reporter   ~0023835

Sorry for the mix I have done between "tape speed", that in my young years on Studer 24 we used to call "vitesse de défilement" or "vitesse de transport" and the (transport, rec. ready etc..) remote control, that we called "télécommande" these years... Would you like that I change that in all entries including "Transport" and add a bz2 file here, or do you prefers in another issue?

For the glue to bars.. I joined here what I have, but it's not on the rc1 build, it was the pre1-403 that I have build

I can see loacate in gtk2_ardour/po : line 2155, as shown in the image joined

session_properties_misc.png (166,430 bytes)
session_properties_misc.png (166,430 bytes)
gtk2_ardour_po.png (181,449 bytes)
gtk2_ardour_po.png (181,449 bytes)

importmidi

2020-04-21 00:11

reporter   ~0023836

I replace the loacate image so it's faster for you to see it: and then I see that something is wrong in the translation too! I will fix it with "transport" lines of course, and check another time just to be sure no other error is included... Translation is not a quick'N'easy task and I don't think I can do that for a non-musical software ;)

I will build the rc tomorrow morning too, and let you know about the glue to bars missing.

Please tell me if you prefers another issue or add the new fix here?

loacate2.png (135,219 bytes)
loacate2.png (135,219 bytes)

importmidi

2020-04-21 10:26

reporter   ~0023839

updating the translation this morning I remember it clearly, after looking at the Studer MKII french specs!

"défilement" is used for anything about the tape movement (or stop): it can be something in the hardware, the tape itself, or the movement (forward, rewind, play)
"transport" is used for any man/machine interface that gives control on that movement (eg: Studer remote control that includes rec.ready/auto-input/tape play/locator/etc AND transport)

is that ok for you if it's translated in that mood (that "everyone in business" can understand in french), or you prefers transport for every instance?

x42

2020-04-21 14:58

administrator   ~0023841

I don't have any personal preference and my French isn't very good either.
Yet for some reason I just thought "Transport Masters" -> "Maîtres du Défilement" sounded odd, so I thought I'd ask.

Thanks for the explanation. So since this one is about user/machine-control, should it be "Maîtres des Transport"?

x42

2020-04-21 15:00

administrator   ~0023842

Re: "For the glue to bars.. "

Could it be that is is due to "&" (et sign).

importmidi

2020-04-21 18:36

reporter   ~0023847

It wil be "transport"... I'll try to post here a new patch ASAP, to respond to your 2 notes before. Let say thursday evening, with some luck!

importmidi

2020-04-22 16:11

reporter   ~0023858

All "&" have been replaced, except in 2338: small>i>This can later be changed in Preferences > Appearance./i>/small> Next build, I'll tell you if it was the point!

Every "transport" talking about HMI is replaced

0005-update-french-translation.patch.bz2 (4,766 bytes)

x42

2020-04-24 01:50

administrator   ~0023890

There were various comments by other translators on Ardour IRC yesterday.

Many translations are too long and lead to an unusable GUI.

e.g. "Lock" -> "Pas de déplacement horizontal" results in a very big dropdown. It should probably be "Verrouiller" (and "Slide" -> "Glisser" etc.)
Various similar phrases that are used in the main toolbar are likewise too long. They should be single-words.

Would you mind coordinating this with Olivier Humbert (trebmuh@tuxfamily.org) and Julien Rivaud (frnchfrgg@free.fr)?

x42

2020-04-24 02:25

administrator   ~0023891

The 0005 update was merged in 6.0-rc1-77-gf1ec998653

importmidi

2020-04-24 11:42

reporter   ~0023894

Thanks for the addresses of Olivier & Julien, I will mail them

importmidi

2020-04-27 01:31

reporter  

0006-update-french-translation.patch.bz2 (18,488 bytes)
Capture du 2020-04-27 03-06-49.png (304,874 bytes)

importmidi

2020-04-27 01:32

reporter   ~0023949

No response from Olivier or Julien yet, but here is a new update with shorter translations.

One of they have to be validated I think, it's for the playhead: "Cellule" which is twice shortest than "Tête de Lecture" but might be sort of confusing? Please let me know if it's better to reverse to "Tête de Lecture".

Here's a screenshot so you can have a quick look at it.
Could you please explain me the use of the "G" column in the Regions List that you can see in that picture?

x42

2020-04-27 02:24

administrator   ~0023951

The screenshot looks nice!

"Glued|G" the tooltip for that is "Region position glued to Bars|Beats time" : The region's position is not using absolute timecode, but the tempo-map to Music-time (tempo, time-signature).

I cannot judge if "Cellule" is appropriate.
ProTools uses "curseur de lecture" [1] for "Playhead". but that's even longer than "Tête de Lecture".

[1] http://akmedia.digidesign.com/support/compressed/Pro_Tools_12_3_docs_FR.zip might be good for some inspiration regarding naming conventions.

x42

2020-04-28 16:06

administrator   ~0023982

The 0006-update was applied in 6.0-rc1-129-gd94a747180

importmidi

2020-04-28 18:19

reporter   ~0023987

Thanks for the link to the PT docs, but I will stay on Ardour!

More seriously, they shows (in 5 minutes, thanks Ctrl+F) that PT translators met the same "flavor':
* they talk about "défilement" or "transport" for the same concepts we talked about up here,
* they use "tête de lecture" or "curseur de lecture" depending the context,
* sometimes they translate "scrubber" > "scrubbing", that I don't even searched in a french dictionnary!
* etc...

So I think that "Tête" will translate well "Playhead" and shorten "tête de lecture". I mean, there's nothing else related to "tête" in a DAW (header is "en-tête")), and "tête" is understood easily by one who remember the head block in multitrack hardwares.

"Cellule" was sounding strange, that's why I have asked you about it. Those PT docs were good to brainstorm!
I don't see other strange words in the .po, and can't translate more Lua/MIDI/Video at the moment, so it seems so my work is done now with that last update. I have added some to the tooltip you can see in the image, to explain the functions that I have questionned myself up on for years, just in case some other do!!

It was nice, first because it forced to practice english, reading the context with Poedit showed some functions unused, and test to see if Ardour really makes what translations describes has helped to discover new features. Last but not least, it have eased that period out of time we are all living...

Could you please add my name to the french translators line in the .po?

0008-update-french-translation.patch.bz2 (8,670 bytes)

x42

2020-04-28 19:03

administrator   ~0023991

I've added the name in the source and applied 0008-update in 6.0-rc1-131-g571067f70b

importmidi

2020-04-28 19:41

reporter   ~0023993

Thanks Robin,

I have read "We need people to update and/or write new sections in the manual 36 to reflect all these changes. Please get in touch if you’d like to be a part of this effort." in:
https://discourse.ardour.org/t/development-update-6-0-pre1-now-ready-for-testing/103072

 Is where you read those lines the good place to get in touch ?

paul

2020-04-29 22:17

administrator   ~0024001

The forums are fine to use to get in touch, or the ardour-dev mailing list.

importmidi

2020-04-29 22:26

reporter   ~0024003

ok thanks, I'll go there

importmidi

2020-05-19 19:25

reporter   ~0024207

Using Ardour6 I found some lines not fine. Here's an update.

0010-update-french-translation.patch.bz2 (33,863 bytes)

x42

2020-05-19 20:36

administrator   ~0024209

Applied as 6.0-rc1-370-g6c72862801

anonymous

2020-06-19 16:31

viewer   ~0024484

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-04-20 16:31 importmidi New Issue
2020-04-20 16:31 importmidi File Added: 0004-update-french-translation.patch.bz2
2020-04-20 17:22 x42 Note Added: 0023830
2020-04-20 17:31 importmidi Note Added: 0023831
2020-04-20 21:58 x42 File Added: session-props.png
2020-04-20 21:58 x42 Note Added: 0023832
2020-04-20 22:03 x42 Note Added: 0023833
2020-04-20 23:27 importmidi File Added: session_properties_misc.png
2020-04-20 23:27 importmidi File Added: gtk2_ardour_po.png
2020-04-20 23:27 importmidi Note Added: 0023835
2020-04-21 00:11 importmidi File Added: loacate2.png
2020-04-21 00:11 importmidi Note Added: 0023836
2020-04-21 10:26 importmidi Note Added: 0023839
2020-04-21 14:58 x42 Note Added: 0023841
2020-04-21 15:00 x42 Note Added: 0023842
2020-04-21 18:36 importmidi Note Added: 0023847
2020-04-22 16:11 importmidi File Added: 0005-update-french-translation.patch.bz2
2020-04-22 16:11 importmidi Note Added: 0023858
2020-04-24 01:50 x42 Note Added: 0023890
2020-04-24 02:25 x42 Note Added: 0023891
2020-04-24 02:29 x42 Relationship added has duplicate 0008019
2020-04-24 11:42 importmidi Note Added: 0023894
2020-04-27 01:31 importmidi File Added: 0006-update-french-translation.patch.bz2
2020-04-27 01:32 importmidi File Added: Capture du 2020-04-27 03-06-49.png
2020-04-27 01:32 importmidi Note Added: 0023949
2020-04-27 02:24 x42 Note Added: 0023951
2020-04-28 16:06 x42 Note Added: 0023982
2020-04-28 18:19 importmidi File Added: 0008-update-french-translation.patch.bz2
2020-04-28 18:19 importmidi File Added: Capture du 2020-04-28 18-52-15.png
2020-04-28 18:19 importmidi Note Added: 0023987
2020-04-28 19:03 x42 Note Added: 0023991
2020-04-28 19:41 importmidi Note Added: 0023993
2020-04-29 22:17 paul Note Added: 0024001
2020-04-29 22:26 importmidi Note Added: 0024003
2020-05-19 19:25 importmidi File Added: 0010-update-french-translation.patch.bz2
2020-05-19 19:25 importmidi Note Added: 0024207
2020-05-19 20:36 x42 Assigned To => x42
2020-05-19 20:36 x42 Status new => resolved
2020-05-19 20:36 x42 Resolution open => fixed
2020-05-19 20:36 x42 Note Added: 0024209
2020-06-19 16:31 anonymous Note Added: 0024484
2020-06-19 16:31 anonymous Status resolved => closed