View Issue Details

IDCategoryLast Update
0007971bugs2020-04-06 19:42
ReportersaltedcoffeeAssigned Tojohmue-eo 
Reproducibilityalways 
Status closedResolutionfixed 
Platformx86_64OSmacOSOS Version10.15 Catalina
Product Version6.0-pre1 
Fixed in Version 
Summary0007971: Session Templates cannot be imported with Ardour 6
DescriptionArdour 6 is not able to import Session Templates. It can neither import Session Templates from Ardour 5 (because the template export format seems to have changed) nor Ardour 6 (because it simply doesn't work).
Steps To Reproduce1. Create a session in Ardour 6 and save it as a template.
2. Go to Window > Templates, click Export all and choose a name and location for the template archive.
3. Remove the existing template.
4. Click Import, navigate to the exported template archive and select it.
5. Click OK and watch Ardour 6 do nothing instead of importing the template.
6. Also try to import templates that were imported with Ardour 5. This time, you're stuck at step 4 because the file browser won't even show the template archive from Ardour 5.
Additional InformationI came across this when I tried to reuse some of my Session Templates that I created with Ardour 5. I exported them as a template archive but couldn't make it show up in the file browser window from the "Import template archives" dialog in Ardour 6. To investigate why this is the case, I created and exported some session templates in Ardour 6 itself and noticed that the file extension differs: While Ardour 5 exports the Template archive as a regular TAR archive with XZ compression (the file extension is .tar.xz), Ardour 6 uses .ardour-template-archive as the file extension.

I can rename the extension for .tar.xz to .ardour-template-archive, but obviously, I cannot test whether this would already do the trick because Ardour 6 fails to import even the newer .ardour-template-archive files so I can't spot any differences.

The conclusion is: Ardour 6 should be able to import template archives from Ardour 5 so users can easily migrate their session templates to the new version, but it should also be able to import template archives that were created with Ardour 6 itself.

The existing issue 0007968 does provide a workaround (open a session and save it as template), but this would be rather time consuming if you have a lot of session templates. Apart from that, the bug report is actually about something else (it suggest Ardour 6 should automatically find and display templates from the previous version), so I created a new issue.
TagsNo tags attached.

Relationships

related to 0007968 closedjohmue-eo Session templates from 5.12 not available in 6.0-pre1 

Activities

saltedcoffee

2020-04-02 21:05

reporter   ~0021139

Under "Steps To Reproduce", the first sentence under step 6 should read: "Also try to import templates that were exported with Ardour 5."

johmue-eo

2020-04-02 21:36

developer   ~0021140

Reproduced

johmue-eo

2020-04-02 22:31

developer   ~0021141

Sorry, but I can actually not reproduce it. At first I thought I could but obviously I was clicking on a wrong file which for some reason appeared in "Recently used".

When I follow your recipe, the templates are imported as expected.

Importing Ardour5 templates is possible as of 7a2e9bf. (see. https://github.com/Ardour/ardour/compare/1439610f95...41fa647)

johmue-eo

2020-04-03 11:47

developer   ~0021151

Can you please start ardour in terminal, trigger the bug and post the terminal output?

Thanks

saltedcoffee

2020-04-03 21:44

reporter   ~0021160

I'm stuck with this because other than Ardour 5, Ardour 6 doesn't give me any terminal output when I call the shellscript wrapper with

`ARDOUR_BUNDLED=1 /Applications/Ardour6.app/Contents/MacOS/Ardour6`

Console.app doesn't report anything when triggering the bug. What am I doing wrong?

I've attached a screenshot where you can see the issue: Ardour doesn't show any template archives in the file browser, but from the Finder window with the same path on the right, you can see they're actually there. Interestingly enough, I can drag one of those files from Finder to Ardour's file browser and that would make both of them appear. But then again, it's the same as with Ardour 6 template archives (which do show in the file browser): Importing them does not work.

Screenshot 2020-04-03 at 01.05.41.png (518,259 bytes)

johmue-eo

2020-04-04 09:02

developer  

just_one_simple.ardour-template-archive (3,248 bytes)

johmue-eo

2020-04-04 09:04

developer   ~0021165

Ardour5 templates should be found by the latest nightly built.

Does importing of ardour5 templates work in ardour5 on your system?

I uploaded a simple template archive that I made on ardour6. Can please try to import that one.
 
Can you please attach a (simple) ardour6 template archive file, created by your Ardour6 here?

saltedcoffee

2020-04-04 19:11

reporter   ~0021169

> Ardour5 templates should be found by the latest nightly built.
Yes, they do! Having installed the latest Ardour 6 nightly, I can now see the .tar.xz files in the file browser.

> Does importing of ardour5 templates work in ardour5 on your system?
No, it doesn't. Now that's interesting. Sorry for having missed that, I could have tried that on my own. It's just that I never needed that functionality in Ardour 5, so I didn't check.

> I uploaded a simple template archive that I made on ardour6. Can please try to import that one.
I did, and it works! I just can't import any template archives that I exported on my own, though.

 > Can you please attach a (simple) ardour6 template archive file, created by your Ardour6 here?
Of course, here you go.

another_simple.ardour-template-archive (3,934 bytes)

johmue-eo

2020-04-04 21:25

developer   ~0021170

Ok. Now we know the problem is actually the export, even in Ardour5.

The contents of the file that your posted is
`-P19TI0/templates/another_simple/another_simple.template`

It should be
`templates/another_simple/another_simple.template`

Obviously something's behaving differently on MacOS than on Linux. Will need to figure out what exactly.

saltedcoffee

2020-04-04 21:51

reporter   ~0021171

Please let me know if there's anything else I can do to help you track down the issue.

johmue-eo

2020-04-05 14:54

developer   ~0021183

Potential fix pushed in 6.0-pre1-149-g605b3d83a8.

Please test in nightly builds from tomorrow (04/06). Please also test with route templates.

Thx

saltedcoffee

2020-04-06 19:28

reporter   ~0021222

From what I can see, the issue seems to be fixed in the current nightly build of Ardour 6. Both session templates and track templates import as expected following the procedure described here. Importing template archives from Ardour 5 also works (again, I tested this with session and track templates) despite the errornous path inside the archive. This is great, thank you!

johmue-eo

2020-04-06 19:39

developer   ~0021223

Glad to hear. If there's no further problems, please mark the issue as closed.

Thanks for your collaboration.

saltedcoffee

2020-04-06 19:42

reporter   ~0021224

Fixed with https://github.com/Ardour/ardour/commit/605b3d83a8c48c4ffb132ca74c69d9bdc95d1890.

Issue History

Date Modified Username Field Change
2020-04-02 18:36 saltedcoffee New Issue
2020-04-02 18:46 x42 Relationship added related to 0007968
2020-04-02 21:05 saltedcoffee Note Added: 0021139
2020-04-02 21:35 johmue-eo Assigned To => johmue-eo
2020-04-02 21:36 johmue-eo Status new => assigned
2020-04-02 21:36 johmue-eo Note Added: 0021140
2020-04-02 22:31 johmue-eo Note Added: 0021141
2020-04-03 11:47 johmue-eo Status assigned => feedback
2020-04-03 11:47 johmue-eo Note Added: 0021151
2020-04-03 21:44 saltedcoffee File Added: Screenshot 2020-04-03 at 01.05.41.png
2020-04-03 21:44 saltedcoffee Note Added: 0021160
2020-04-03 21:44 saltedcoffee Status feedback => assigned
2020-04-04 09:02 johmue-eo File Added: just_one_simple.ardour-template-archive
2020-04-04 09:04 johmue-eo Status assigned => feedback
2020-04-04 09:04 johmue-eo Note Added: 0021165
2020-04-04 19:11 saltedcoffee File Added: another_simple.ardour-template-archive
2020-04-04 19:11 saltedcoffee Note Added: 0021169
2020-04-04 19:11 saltedcoffee Status feedback => assigned
2020-04-04 21:25 johmue-eo Note Added: 0021170
2020-04-04 21:51 saltedcoffee Note Added: 0021171
2020-04-05 14:54 johmue-eo Status assigned => feedback
2020-04-05 14:54 johmue-eo Note Added: 0021183
2020-04-06 19:28 saltedcoffee Note Added: 0021222
2020-04-06 19:28 saltedcoffee Status feedback => assigned
2020-04-06 19:39 johmue-eo Status assigned => resolved
2020-04-06 19:39 johmue-eo Resolution open => fixed
2020-04-06 19:39 johmue-eo Note Added: 0021223
2020-04-06 19:42 saltedcoffee Status resolved => closed
2020-04-06 19:42 saltedcoffee Note Added: 0021224