View Issue Details

IDCategoryLast Update
0007968bugs2020-07-03 04:09
ReporterjohnzoAssigned Tojohmue-eo 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformSome Other LinuxOSSome Other LinuxOS Versionunknown
Product Version6.0-pre1 
Fixed in Version 
Summary0007968: Session templates from 5.12 not available in 6.0-pre1
DescriptionHave a long-evolving session template in 5.12 that's been a big timesaver, but that
template is not present when I launch 6.0-pre1
Steps To Reproduce1. Launch Ardour 6.0-pre1
2. "New Session"
3. List of templates does not include templates I saved in 5.12 -- it includes only "Empty Template",
"Advanced Session", and "Recording Session"
Additional InformationSuccessfully worked around by loading a 5.12 song built from the template into 6.0 and then saving it as a template.
Tagstemplate

Relationships

related to 0007971 closedjohmue-eo Session Templates cannot be imported with Ardour 6 

Activities

johmue-eo

2020-04-02 22:43

developer   ~0021142

By 41fa647 from 2020/04/02 it is possible to import a5 templates in a6. So launch ardour5 and go to Windows->Templates and click on "Export all". Then start ardour6 and also go to Windows->Templates and import the archive file that you previously exported in ardour5.

The plugins should then be available in ardour6.

Can you please test and report if that works?

inFlowiaLab

2020-05-30 13:39

reporter   ~0024313

I tried to do “Export Everything” and import into Ardour 6 and nothing works. No error or notice. Just an empty list after import. (tried to restart)

johmue-eo

2020-05-31 12:32

developer   ~0024321

Last edited: 2020-05-31 12:34

View 3 revisions

Can you attach the template archive here, so that I can check what's going wrong?

inFlowiaLab

2020-05-31 14:46

reporter   ~0024322

Ok

ArdourTemplates4Migrationto6.tar.xz (344,699 bytes)

johmue-eo

2020-05-31 15:48

developer   ~0024323

Obviously something went wrong in your template export. Paths in your template archive are `route_templates/emplates/<template_name>/...` but they are supposed to be `route_templates/<template_name>/...` Without the `emplates`.

I am attaching a repaired version of your archive file that imports to Ardour6 without problems.

Remains the question, what happened during your export in Ardour 5.12. Can you elaborate a little on how you have done the export?

What exact version of Ardour were you using for the export?

From where is the installation of your Ardour 5.12? (ardour.org? Some distro?)

Have you changed something in your configuration? In particular paths.

ArdourTemplates4Migrationto6-repaired.tar.xz (344,304 bytes)

inFlowiaLab

2020-05-31 16:54

reporter   ~0024324

Export:
Window -> Templates -> TrackTemplates -> ExportAll -> Select Volume "Tmp" -> Input Name of file -> OK

apt show ardour
Package: ardour
Version: 1:5.12.0-3
Priority: optional
Section: universe/sound

Info from "About":
Ardour 5.12.0
"Working Backwards"
(???????? 1:5.12.0-3)
Intel 64-bit

Language - russian.

Most likely this is the version that was installed automatically with Ubuntu Studio 19.10 but this is not accurate. I have Ardour bought from the official site, and when problems begin I can sometimes install it, but it seems to me I did not do this this time.

The strangest thing I did with the settings is that I store the settings directory (~ / .config / ardour5) on a separate disk volume and point to it using a symbolic link.

inFlowiaLab

2020-05-31 17:16

reporter   ~0024325

Thank for repairing template pack. Everything is almost fine there except for the plug-in a-MIDI Monitor. It turns off and does not turn on until you delete it and add the plugin again. I think this is all because LUA plugins are built-in.

johmue-eo

2020-06-01 08:31

developer   ~0024339

I have no explanation for the observed behavior.

I did some experiments with ~/.config/ardour5 symlinked to a separate volume. I suspected non-ascii characters in the path to the config dir, but I could not reproduce a broken template export.

paul

2020-07-03 04:09

administrator   ~0024573

this appears resolved. if not, open a more specific report. thanks.

anonymous

2020-07-03 04:09

viewer   ~0024574

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-04-01 18:23 johnzo New Issue
2020-04-01 18:23 johnzo Tag Attached: template
2020-04-02 18:46 x42 Relationship added related to 0007971
2020-04-02 22:43 johmue-eo Assigned To => johmue-eo
2020-04-02 22:43 johmue-eo Status new => feedback
2020-04-02 22:43 johmue-eo Note Added: 0021142
2020-05-30 13:39 inFlowiaLab Note Added: 0024313
2020-05-31 12:32 johmue-eo Note Added: 0024321
2020-05-31 12:34 johmue-eo Note Edited: 0024321 View Revisions
2020-05-31 12:34 johmue-eo Note Edited: 0024321 View Revisions
2020-05-31 14:46 inFlowiaLab File Added: ArdourTemplates4Migrationto6.tar.xz
2020-05-31 14:46 inFlowiaLab Note Added: 0024322
2020-05-31 15:48 johmue-eo File Added: ArdourTemplates4Migrationto6-repaired.tar.xz
2020-05-31 15:48 johmue-eo Note Added: 0024323
2020-05-31 16:54 inFlowiaLab Note Added: 0024324
2020-05-31 17:16 inFlowiaLab Note Added: 0024325
2020-06-01 08:31 johmue-eo Note Added: 0024339
2020-07-03 04:09 paul Status feedback => resolved
2020-07-03 04:09 paul Resolution open => fixed
2020-07-03 04:09 paul Note Added: 0024573
2020-07-03 04:09 anonymous Note Added: 0024574
2020-07-03 04:09 anonymous Status resolved => closed