View Issue Details

IDCategoryLast Update
0007712bugs2018-12-21 16:35
ReporterITicDiggerAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformKXStudioOSLinuxOS Version14.04.5
Product Version5.12 
Fixed in Version 
Summary0007712: "Insert time" moves points of automation longer than the regions
Description"Insert time" moves points of automation longer than the regions
Its true for MIDI and audio tracks. If i make "insert time" in track with automation points behind the line of insertion, then automation points will be moved not synchronously with mover regions. ?hey are 2 times farther than they should be. Sometimes more. But I think this value depends on length of inserted time.
Steps To ReproduceCreate midi or audio track, with 2 regions.
Put playhed between regions.
Select track by clicking header.
Make "Insert time" trough main menu.
Screenshots for midi and audio-tracks in attachment. In this case im insert 2 bars
Additional InformationFor me its most bigest and creepiest bug in Ardour. Because of him, I have to not use automation until the very end of the work. Instead of trying out my ideas on arrangement related to the automation right away, I'm forced to take notes and remember how I want it to end up sounding.
    Insert automation immediately I do not dream even in the worst nightmare, because if in the process I want to put somewhere at the beginning of a piece or just a pause waiting for me quite a long and very dangerous process of alignment of all automation tracks manually, and such tracks I usually have at least 40. Hell in other words.
    A similar problem was in this report http://tracker.ardour.org/view.php?id=5044 but i decided to create it new separate report because in old says that this bug occurs not only when make time insertion from main menu bot when manually drag regions. And as far as I know, in the current version, when moving regions, automation does not move.
TagsNo tags attached.

Relationships

related to 0005044 new Automation not moved correctly 

Activities

ITicDigger

2018-12-21 13:41

reporter  

after inserting.png (109,616 bytes)
after inserting.png (109,616 bytes)

ITicDigger

2018-12-21 13:42

reporter  

before inserting.png (109,847 bytes)
before inserting.png (109,847 bytes)

ITicDigger

2018-12-21 13:42

reporter  

sets.png (33,770 bytes)
sets.png (33,770 bytes)

x42

2018-12-21 13:57

administrator   ~0020547

Confirmed.

It seems the issue is that

1. Region is moved. the automation below the region (if any) moves along with the region
2. Automation after insert point is shifted.

Result: the automation below a region moves twice as far, and all automation that's in between this double distance is lost.

x42

2018-12-21 16:35

administrator   ~0020548

Fixed in Ardour 6.0-pre0-1439 df666326f

Issue History

Date Modified Username Field Change
2018-12-21 13:41 ITicDigger New Issue
2018-12-21 13:41 ITicDigger File Added: after inserting.png
2018-12-21 13:42 ITicDigger File Added: before inserting.png
2018-12-21 13:42 ITicDigger File Added: sets.png
2018-12-21 13:50 x42 Relationship added related to 0005044
2018-12-21 13:57 x42 Note Added: 0020547
2018-12-21 16:35 x42 Note Added: 0020548
2018-12-21 16:35 x42 Status new => resolved
2018-12-21 16:35 x42 Resolution open => fixed
2018-12-21 16:35 x42 Assigned To => x42