View Issue Details

IDCategoryLast Update
0007134features2017-03-05 00:04
ReportertimbyrAssigned Totimbyr 
Reproducibilityalways 
Status resolvedResolutionfixed 
Product Version5.8 
Fixed in Version5.X git (version in description) 
Summary0007134: Percussive MIDI Notes added by Draw Mode/Pencil Tool in single drag/operation should be a single Undo/Redo step
DescriptionTested with build 5.4.410.

It is now possible to add more than a single note in one drag operation using the Draw mode/Pencil tool with the Grid on by clicking and dragging the mouse and a new note will be placed at each snap/quantize point.

The issue is that an Undo/Redo entry is added for each note that is added. My expectation is that a single Undo/Redo entry is added all the notes added in one drag/operation.

TagsNo tags attached.

Relationships

related to 0007130 resolvednmains Incorrect ghost note displayed in percussive note mode 

Activities

nick_m

2017-03-04 14:58

reporter   ~0019476

this should be fixed by commit fb4b72231a76751

timbyr

2017-03-05 00:04

developer   ~0019480

Resolved in master by commit fb4b72231a, tested with a build of 5.8.64

Issue History

Date Modified Username Field Change
2016-11-21 23:37 timbyr New Issue
2016-11-21 23:38 timbyr Relationship added related to 0007130
2017-03-04 14:58 nick_m Note Added: 0019476
2017-03-05 00:03 timbyr Product Version 5.X git (version in description) => 5.8
2017-03-05 00:03 timbyr Target Version 5.X git (version in description) =>
2017-03-05 00:04 timbyr Note Added: 0019480
2017-03-05 00:04 timbyr Status new => resolved
2017-03-05 00:04 timbyr Fixed in Version => 5.X git (version in description)
2017-03-05 00:04 timbyr Resolution open => fixed
2017-03-05 00:04 timbyr Assigned To => timbyr