View Issue Details

IDCategoryLast Update
0006795other2020-04-19 20:17
Reporterx42Assigned Tox42 
ReproducibilityN/A 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0006795: Midi Buffer Split-Cycle and Offset
DescriptionThe Ardour::Buffer API has both src and dst offset (for the current cycle)

This is currently not properly implemented for Midi Buffers provided to Plugins.

When Ardour splits the process cycle (loop, automation)

1) midi buffers ignore the cycle-length:
  e.g a sub-cycle 0..64 can contain later events (e.g. at 1023)

2) the offset is not applied for sub-cycles

3) Timecode / BBT which is sent to plugins is not updated/offset for split-cycles.

(NB. looping is handled by Midi Diskstream a level above)
TagsNo tags attached.

Relationships

parent of 0006790 closedx42 Hanging notes, if (dense) automation for the LV2 synth plugin is on "play" 

Activities

system

2020-04-19 20:17

developer   ~0023595

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-02-26 14:10 x42 New Issue
2016-02-26 14:10 x42 Relationship added parent of 0006790
2020-03-15 17:17 x42 Assigned To => x42
2020-03-15 17:17 x42 Status new => resolved
2020-03-15 17:17 x42 Resolution open => fixed
2020-04-19 20:17 system Note Added: 0023595
2020-04-19 20:17 system Status resolved => closed