View Issue Details

IDCategoryLast Update
0005737bugs2014-05-26 00:06
ReporterzthAssigned To 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0005737: VST plugins does not receive PPQ information
DescriptionIt seems like VST plugins does not receive PPQ information (not my words, but someone who actually knows what they're talking about ;) ).
I attatch a screenshot of the JuceDemoPlugin loaded in Ardour and in Carla for illustrative purposes.
TagsNo tags attached.

Relationships

duplicate of 0002561 closedx42 Make Ardour to report time and tempo to VST plugins 

Activities

2013-10-19 14:37

 

ppq-screenshot.png (97,377 bytes)
ppq-screenshot.png (97,377 bytes)

zth

2013-10-19 14:43

reporter   ~0015411

https://github.com/falkTX/Carla/blob/master/source/backend/plugin/VstPlugin.cpp#L1053 <- link to code that does that

paul

2013-10-21 20:37

administrator   ~0015421

are you talking about Bars|Beats|Ticks or PPQ (which is quite different)

zth

2013-10-22 14:01

reporter   ~0015433

Here's from falkTX (who I found the issue with):

<falktx> zth: vst doesn't have BBT per say, all the info is contained in PPQ
<falktx> zth: we need to encode the BBT info from jack/ardour to vst PPQ
<falktx> plugins will then know what to do

mcdebugger

2013-11-10 22:39

reporter   ~0015480

I don't know it it's related but I can't make Filter-2 plugin to work (both LV2 and lxvst versions). The problem is it's not running envelope/automation inside a plugin. Position changes only when I hit stop and try from some other place on the timeline of a session. So it updates only on stop-start but it should do it automatically for envelope curve to work.

paul

2014-01-15 21:08

administrator   ~0015582

I've just pushed changes to master that will provide a lot more BBT-based time info to VST plugins. I'd appreciate feedback on whether it works.

paul

2014-01-16 03:46

administrator   ~0015583

more changes pushed. i've tested this with the "again" VST test plugin and it shows correct values at all times. if the plugin you test with doesn't update its display, that would suggest a problem with its GUI rather then the VST time information.

paul

2014-01-19 04:50

administrator   ~0015587

this is fixed now, yes?

zth

2014-01-19 10:50

reporter   ~0015593

Yes, fixed and working! :)

mcdebugger

2014-01-19 12:09

reporter   ~0015594

Last edited: 2014-01-19 12:26

Fixed problem for me with VST version of TAL-FilterII plugin.
Could you please fix it for LV2 too?

x42

2014-05-26 00:04

administrator   ~0015810

@mcdebugger, there has never been a problem with LV2 regarding this. LV2 plugins receive tempo, BBT, speed and transport position just fine if they ask for it.

If there's a specific issue, it is most likely with the plugin in question.

x42

2014-05-26 00:06

administrator   ~0015811

tested and confirmed working in 3.5.308.

Issue History

Date Modified Username Field Change
2013-10-19 14:37 zth New Issue
2013-10-19 14:37 zth File Added: ppq-screenshot.png
2013-10-19 14:43 zth Note Added: 0015411
2013-10-21 20:37 paul Note Added: 0015421
2013-10-22 14:01 zth Note Added: 0015433
2013-11-10 22:39 mcdebugger Note Added: 0015480
2014-01-15 21:08 paul Note Added: 0015582
2014-01-15 21:08 paul Status new => feedback
2014-01-16 03:46 paul Note Added: 0015583
2014-01-19 04:50 paul Note Added: 0015587
2014-01-19 10:50 zth Note Added: 0015593
2014-01-19 12:09 mcdebugger Note Added: 0015594
2014-01-19 12:26 mcdebugger Note Edited: 0015594
2014-05-26 00:04 x42 Note Added: 0015810
2014-05-26 00:06 x42 Note Added: 0015811
2014-05-26 00:06 x42 Status feedback => closed
2014-05-26 00:06 x42 Resolution open => fixed
2014-05-26 00:07 x42 Relationship added duplicate of 0002561