View Issue Details

IDCategoryLast Update
0002561features2020-04-19 20:13
ReporteragorkaAssigned Tox42 
ReproducibilityN/A 
Status closedResolutionfixed 
PlatformOSLinuxOS Version
Product Version2.7.1 
Fixed in Version 
Summary0002561: Make Ardour to report time and tempo to VST plugins
DescriptionVST specifications support asking host for tempo and time. It widely used for delay syncing, trance-gate syncing and for voice tuning by Melodine VST Plugin. As Ardour's VST support improved a lot, I'd like to see Ardour supporting this feature.

So functions to be implemented are: getTimeInfo and tempoAt.
For testing I found a simple metronome blinking vst plug-in.
It's called blinker and can be found here:
http://www.breathcube.com/vst/vst.html

It seem to be made in synthedit so it creates some additional files in order to run, so I had to make /usr/local/lib/vst folder writable. So I'm able to open this VST plugin in Ardour2, but it doesn't blink. I'll put a bounty for the one who would make it blink.
TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = US$ 52

2009-02-22 17:36: agorka (US$ 52)
Users sponsoring this issue (Total Sponsorship = US$ 52)

Relationships

has duplicate 0005737 closed VST plugins does not receive PPQ information 

Activities

thorgal

2009-04-09 18:56

reporter   ~0005872

that's something for the FST author, as ardour is using FST for its VST support. Try to contact the FST author and tell him about it.

x42

2014-05-26 00:10

administrator   ~0015812

It's quite some time..

This should no longer be an issue since ardour 3.5.308
Please confirm and close (or reopen) this issue.

system

2020-04-19 20:13

developer   ~0021869

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2009-02-22 17:36 agorka New Issue
2009-02-22 17:36 agorka Sponsorship Added agorka: US$ 50
2009-02-22 17:36 agorka Sponsorship Total 0 => 50
2009-04-09 16:03 agorka Sponsorship Updated agorka: US$ 5
2009-04-09 16:03 agorka Sponsorship Total 50 => 5
2009-04-09 16:04 agorka Sponsorship Updated agorka: US$ 52
2009-04-09 16:04 agorka Sponsorship Total 5 => 52
2009-04-09 18:56 thorgal Note Added: 0005872
2014-05-26 00:07 x42 Relationship added has duplicate 0005737
2014-05-26 00:10 x42 Note Added: 0015812
2014-05-26 00:10 x42 Status new => resolved
2014-05-26 00:10 x42 Resolution open => fixed
2014-05-26 00:10 x42 Assigned To => x42
2020-04-19 20:13 system Note Added: 0021869
2020-04-19 20:13 system Status resolved => closed