View Issue Details

IDCategoryLast Update
0005654bugs2020-04-19 20:16
ReporterDazgardAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0005654: Ardour 3 does not save/remember midnam selection
DescriptionArdour version : 3.3 upstream and 3.3 git head.
NOTE : The "Product Version" list in mantis is not uptodate

Ardour does not remember midi patch file selection when the patch name has more than one entry.

The "Generic" entry has two "sub" values : "MIDI" and "General Midi".
Selecting "General Midi" will never be saved.

Seems like only the first "CustomDeviceMode name" will be saved

furthermore, changing the midnam from the drop down menu does not mark the session as in need to be saved.


if more info is needed please let me know
Additional Informationsee the attached screenshot file
TagsNo tags attached.

Relationships

has duplicate 0007895 resolved Changing MIDNAM preset in track-header will revert to Plugin Provided upon project reload 

Activities

2013-08-13 02:43

 

ardour midnam bug.png (16,065 bytes)
ardour midnam bug.png (16,065 bytes)

x42

2020-04-15 01:54

administrator   ~0021350

Fixed (again) in Fixed in 6.0-pre1-90-g42af08fb92

system

2020-04-19 20:16

developer   ~0023266

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2013-08-13 02:43 Dazgard New Issue
2013-08-13 02:43 Dazgard File Added: ardour midnam bug.png
2020-04-15 01:53 x42 Relationship added has duplicate 0007895
2020-04-15 01:54 x42 Assigned To => x42
2020-04-15 01:54 x42 Status new => resolved
2020-04-15 01:54 x42 Resolution open => fixed
2020-04-15 01:54 x42 Note Added: 0021350
2020-04-19 20:16 system Note Added: 0023266
2020-04-19 20:16 system Status resolved => closed