View Issue Details

IDCategoryLast Update
0004214bugs2020-04-19 20:15
ReporternandingaAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformUbuntuOSLinuxOS VersionMaverick
Product Version3.0-alpha9 
Fixed in Version 
Summary0004214: LV2 instrument MIDI input lost when reloading a saved session
DescriptionWhen using an LV2 plugin on a MIDI track everything works fine, but after you save, close Ardour and reopen the session, MIDI input doesn't work.

It is correctly reconnected in Jack upon load, and if the plugin is removed (deleted, not only deactivated) and inserted again (all plugin settings lost) the input works again.
Steps To ReproduceAlways happens. My steps to reproduce:
- New session
- New MIDI track
- Connect Jack input (a2j to MIDI keyboard)
- Insert Calf Monosynth or Calf Organ
- Test keys: you get sound ok now
- Save session, close Ardour3, open again
- Test keys: no sound now
- Delete instrument plugin from track
- Insert plugin again
- Test keys: all working again
Additional InformationI'm using:

jackdmp 1.9.6
caalf 0.0.18.5
TagsNo tags attached.

Activities

nandinga

2011-07-20 15:55

reporter   ~0011180

Hmm... well, I've created it as Major because it makes using LV2 instruments impossible for me, but not sure about the criteria to set the severity here. Any docs about that or is just about personal appreciation?

nandinga

2011-07-20 15:59

reporter   ~0011181

Ah, forgot to say:

You can say the problem is with MIDI input because you can still get sound from the sequencer keyboard on the track, and if you set the meter to "in", you don't see any activity when pressing keys on the external MIDI keyboard.

cth103

2011-10-24 23:31

administrator   ~0011777

This works for me with current SVN; is it still a problem for you?

johmue-eo

2012-02-11 11:11

developer   ~0012782

Last edited: 2012-02-12 22:23

In beta2 I experience the problem as described above, or at least a similar one.

When applying the fluidsynth plugin of the Calf collection to a midi track, the instrument to be used by fluidsynth is not saved to the .ardour file.

When I use Calf's fluidsynth in the Calf jack host, the instrument is saved. So it does not seem to be a Calf bug.

In beta3 I can't test it, because I cannot apply calf fluidsynth to a MIDI channel due to 0004708.

johmue-eo

2012-06-24 10:43

developer   ~0013681

Update:

The behaviour I am experiencing now (beta4 and svn12910) is the following:

I set up a MIDI-track and insert a calf-fluidsynth plugin into it. The state for the plugin is obviously saved correctly.

Terminal output of ardour:
********************************************************
Loading /usr/share/sounds/sf2/FluidR3_GM.sf2
sid=1
LV2 Calf Fluidsynth has state interface
NEW DIR: /tmp/testsession/plugins/141/state1
Saved LV2 state to /tmp/testsession/plugins/141/state1
********************************************************

.../plugins/141/state1/state.ttl looks ok:
********************************************************
@prefix atom: <http://lv2plug.in/ns/ext/atom#> .
@prefix lv2: <http://lv2plug.in/ns/lv2core#> .
@prefix pset: <http://lv2plug.in/ns/ext/presets#> .
@prefix rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#> .
@prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
@prefix state: <http://lv2plug.in/ns/ext/state#> .
@prefix xsd: <http://www.w3.org/2001/XMLSchema#> .

<>
        a pset:Preset ;
        lv2:appliesTo <http://calf.sourceforge.net/plugins/Fluidsynth> ;
        state:state [
                <urn:calf:soundfont> "/usr/share/sounds/sf2/FluidR3_GM.sf2" ;
                <urn:calf:preset_key_set> "3"
        ] .
***************************************************************

Also the section in the sessionfile:
***************************************************************
<Processor id="141" name="Calf Fluidsynth" active="yes" user-latency="0" type="lv2" unique-id="http://calf.sourceforge.net/plugins/Fluidsynth" count="1">
        <lv2 last-preset-uri="" last-preset-label="" parameter-changed-since-last-preset="no" state-dir="state1">
          <Port symbol="master" value="+0.500000"/>
          <Port symbol="interpolation" value="+2.000000"/>
          <Port symbol="reverb" value="+1.000000"/>
          <Port symbol="chorus" value="+1.000000"/>
        </lv2>
        <Controllable name="Volume" id="143" flags="" value="0.500000000000" parameter="2"/>
        <Controllable name="Interpolation" id="145" flags="" value="2.000000000000" parameter="3"/>
        <Controllable name="Reverb" id="147" flags="" value="1.000000000000" parameter="4"/>
        <Controllable name="Chorus" id="149" flags="" value="1.000000000000" parameter="5"/>
      </Processor>
*************************************************************

At least state1 is referenced correctly, I don't know how ardour makes up the leading 141.

So all in all saving seems to work.


Now let's look at reloading the session:

Terminal output of ardour:
*******************************************************
Loading LV2 state from /tmp/testsession/plugins/141/state1/state.ttl
Calling configure on soundfont
Loading /usr/share/sounds/sf2/FluidR3_GM.sf2
sid=1
Calling configure on preset_key_set
Loading LV2 state from /tmp/testsession/plugins/141/state1/state.ttl
Calling configure on soundfont
Loading /usr/share/sounds/sf2/FluidR3_GM.sf2
sid=1
Calling configure on preset_key_set
*************************************************************

looks ok, the correct state.ttl is found.


So far everything seems to be fine. Now to the things that don't work:

The playback of the MIDI-signal is in a wrong pitch. When I open the setup-dialog of the plugin, the parameter for the soundfont file is set to "none", the instrument is indicated correctly. In order to get a correct playback I need to pick the soundfond file and the desired instrument.

HTH

paul

2012-06-24 12:06

administrator   ~0013683

this sounds like there is at least a 50% chance that its a bug in the plugin.

johmue-eo

2012-06-24 12:23

developer   ~0013684

Last edited: 2012-06-24 12:23

The plugin is working fine in Calf JACK Host. So maybe a bug in the plugin that's somehow not triggered by Calf JACK Host.

Does anybody know of another LV2 host application to test that?

paul

2012-06-24 12:37

administrator   ~0013685

the output you're pasting is actually from the plugin, so it might make sense to compare the output seen in CALF Jack Host and Ardour from the same plugin with the same preset/settings.

johmue-eo

2012-06-24 13:03

developer   ~0013686

Last edited: 2012-06-24 13:05

Here you go (lines in <> indicate user interaction with the UI):

First setting it up:

joh@yksi <0> $ calfjackhost
<Adding Fluidsynth plugin>
Creating a blank synth
<Clicking Edit to get into the UI of the plugin>
<Choosing Soundfont-file>
Loading /usr/share/sounds/sf2/FluidR3_GM.sf2
sid=1
<Choosing instrument>


Now reloading it:


joh@yksi <0> $ calfjackhost
<Choosing file>
Size 1
Loading fluidsynth
Creating a blank synth
Creating a blank synth
Loading /usr/share/sounds/sf2/FluidR3_GM.sf2
sid=1
<Clicking Edit to see that the parameters are restored correctly>


The file that calf jack host produced:

<rack>
<plugin type="fluidsynth" instance-name="fluidsynth" output-index="1" midi-index="1">
<preset bank="0" program="0" plugin="fluidsynth" name="">
  <param name="master" value="0.5" />
  <param name="interpolation" value="2" />
  <param name="reverb" value="1" />
  <param name="chorus" value="1" />
  <var name="preset_key_set">3</var>
  <var name="soundfont">/usr/share/sounds/sf2/FluidR3_GM.sf2</var>
</preset>
</plugin>
</rack>

johmue-eo

2013-02-01 16:15

developer   ~0014621

Update: the issue seems to be gone here.

SVN 14041 as well as beta5 work as expected regarding the calf fluidsynth plugin. When I first tested beta5 when it appeared it did not work.

I don't know what happened in the meantime. I am using the same calf version as before.

Older sessions have the same problem. When I load an older session into beta5 today the problem occurs. When I save the session by beta5 and reopen it, it works as expected.

So maybe it's due to some LV2-lib that have been updated in the meantime by my distro (Ubuntu). I am using the precompiled beta5. I don't know whether this is using its own LV2 libs or the ones of the distro.

paul

2013-02-01 16:38

administrator   ~0014622

see notes

system

2020-04-19 20:15

developer   ~0022684

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2011-07-20 15:50 nandinga New Issue
2011-07-20 15:55 nandinga Note Added: 0011180
2011-07-20 15:59 nandinga Note Added: 0011181
2011-07-20 16:58 cth103 cost => 0.00
2011-07-20 16:58 cth103 Target Version => 3.0-beta1
2011-10-24 23:31 cth103 Note Added: 0011777
2011-10-24 23:31 cth103 Status new => feedback
2011-11-15 15:51 cth103 Target Version 3.0-beta1 => 3.0-beta2
2012-01-10 20:46 cth103 Target Version 3.0-beta2 => 3.0-beta3
2012-02-11 11:11 johmue-eo Note Added: 0012782
2012-02-12 22:23 johmue-eo Note Edited: 0012782
2012-02-14 17:20 paul Target Version 3.0-beta3 => 3.0 beta4
2012-04-23 22:06 cth103 Status feedback => acknowledged
2012-05-23 15:07 cth103 Target Version 3.0 beta4 => 3.0
2012-06-24 10:43 johmue-eo Note Added: 0013681
2012-06-24 12:06 paul Note Added: 0013683
2012-06-24 12:23 johmue-eo Note Added: 0013684
2012-06-24 12:23 johmue-eo Note Edited: 0013684
2012-06-24 12:37 paul Note Added: 0013685
2012-06-24 13:03 johmue-eo Note Added: 0013686
2012-06-24 13:05 johmue-eo Note Edited: 0013686
2013-02-01 16:15 johmue-eo Note Added: 0014621
2013-02-01 16:38 paul Note Added: 0014622
2013-02-01 16:38 paul Status acknowledged => resolved
2013-02-01 16:38 paul Resolution open => fixed
2013-02-01 16:38 paul Assigned To => paul
2020-04-19 20:15 system Note Added: 0022684
2020-04-19 20:15 system Status resolved => closed