MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007489ardourbugspublic2017-10-14 03:432018-06-16 07:21
Reportermendred 
Assigned To 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSKubuntuOS Version17.10
Product Version5.12 
Target VersionFixed in Version 
Summary0007489: pointer exception on startup for new project in safe mode
DescriptionArdour crashes on startup with a pointer exception.

This happens with the downloaded executable from ardour.org. So downloaded the associated source code, compiled and ran in debug mode as per instructions on ardour site. Log has been setup in pastebin - link below in additional information
Steps To ReproduceStart ardour and start new project in safe mode plugins disabled. This happens every time it is run
Additional Informationbacktrace
for 5.12
https://pastebin.com/v9WHtVkt [^]




TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0007502resolvedx42 crach since ubuntu upgrade 
has duplicate 0007632closedx42 Crash while opening any project 

-  Notes
(0020054)
mendred (reporter)
2017-10-14 03:45

Have tried getting the latest code from git and running that to see if that makes a difference - same result
(0020055)
x42 (administrator)
2017-10-14 07:19

Can you try if uninstalling the "csladspa" (csound ladspa plugin) package helps?

Some other Ubuntu users mentioned this on IRC before, but I don't know what exactly the issue is with it on Ubuntu.

Smells like some C++/C++11 ABI issue with the plugin using strings in the plugin descriptor.
(0020056)
mendred (reporter)
2017-10-14 14:49

Yep that solved it. thanks X42 you are a star (As always!)
(0020057)
mendred (reporter)
2017-10-14 14:50

Removing the csladspa plugin from ubuntu (apt remove csladspa) fixed this

- Issue History
Date Modified Username Field Change
2017-10-14 03:43 mendred New Issue
2017-10-14 03:45 mendred Note Added: 0020054
2017-10-14 07:19 x42 Note Added: 0020055
2017-10-14 14:49 mendred Note Added: 0020056
2017-10-14 14:50 mendred Note Added: 0020057
2017-10-14 14:50 mendred Status new => closed
2017-10-14 14:50 mendred Resolution open => fixed
2018-03-18 12:12 x42 Relationship added has duplicate 0007502
2018-06-16 07:21 x42 Relationship added has duplicate 0007632


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker