MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007091ardourbugspublic2016-11-02 14:572017-03-16 19:21
Reporterunfa 
Assigned Topaul 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusfeedbackResolutionreopened 
PlatformGNU/Linux AMD64OSLinux MintOS Version18 MATE
Product Version5.4 
Target VersionFixed in Version 
Summary0007091: Session export doesn't start
DescriptionThis is something I'm struggling with since Ardour 3.

It tends to express itself in session that have more than exceed a certian level of complexity. Simple one-song projects seem to be unaffected at all. When mastering 4 songs in one session, it sometimes happens, but for project with 35+ tracks/busses and 80 minutes of material - this happens 90% of the time*

*The other 10% when the rendering actually starts - Ardour crashes somewhere in the middle (usually after rendering no more than 25% of the session.

So the issue is: after setting up the session export using Session > Export to Audio file(s). I press "Export" and Ardour does nothing. DSP load is at 100%, minutes go by, nothing happens. Ardour only creates an 88-byte WAV file.

I can Cancel the export, and get back to work. It's not crashing, or freezing. Just - the rendering never really happens.
Steps To Reproduce1. Create a really big session
2. Configure exporting it to a file
3. Press "Export"
4. Wait forever or wait 'till it crashes, if it actually starts exporting
Additional InformationI usually have to workaround this by recording output of my Master bus into a stereo track (watch out for feedback!).

Problem is, Ardour also seems to have problems with jack_freewheel when working in big sessions, so I need to render 80 mintes in realtime.

Trying to enable jack_freewheel makes playback in Ardour freeze for a few minutes, and then it stops or glitches out or I give up waiting, kill it all, and restart the "Master recording" in realtime.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0018911)
robsco (reporter)
2016-11-05 22:35

I have also run into similar issues in the past in terms of exporting. For me they are usually related to either buggy plugins or running pulseaudio concurrently with jack. I don't know if either of these are relevant to your specific issues though.

The buggy plugins is a tough one to figure out. Someone with some knowledge of the code can take a look at any backtraces you attach here and may be able to tell you which specific plugins are the issue. Aside from that, a trial and error approach is the only thing I can think of. Here is a resource for capturing backtraces: https://ardour.org/debugging_ardour [^]

You also have the option of trying/using the ALSA backend for your exports.
(0019122)
timbyr (developer)
2016-12-05 23:03

There have been some changes to export recently and while they are probably unrelated to the issue you are experiencing I would appreciate if you could test a nightly build >= 5.5.33 and leave feedback if you get a chance.

Do you still experience these export issues if you use the ALSA audio backend?
(0019140)
unfa (reporter)
2016-12-10 10:19

Ok, I did some test.

Stable 5.5:
I tried 3 different sessions, a few times - the exportnig never starts. I sometimes had to kill Ardour.

Nightly 5.5.72 (64 bit, GCC5):
Three session exported fine. No problems so far (but I'll need to give it some more time).
(0019144)
efenstor (reporter)
2016-12-11 03:52
edited on: 2016-12-11 03:56

I have this problem as well (only when using JACK): in nightly 5.5.72 the progress bar appears but export does not start. These was no such problem in 5.5.

Just tried the older build 5.5.36 on a different machine with a PCI sound card and export goes fine there. I'll try more different configurations soon and report the results.

(0019145)
efenstor (reporter)
2016-12-11 07:00

I've found that the problem is caused by the latest jackd2 upgrade from the kxstudio repositories, the previous version (1.9.11~20160620) works fine, while the latest (1.9.11~20161209) messes the things up. Anyway, this is weird, as the realtime playback and recording works flawlessly, only export is getting stuck with qjackctl overloading the CPU.
(0019185)
paul (administrator)
2016-12-19 14:57

Bugs when exporting using Jack2 need to be fixed by fixing Jack2.
(0019523)
unfa (reporter)
2017-03-11 11:18
edited on: 2017-03-11 11:19

Yes, I'm using Jack2.

I'm experiencing this issue again in Ardour 5.8.

Running Linux Mint 18 KDE 5 64-bit now.

Should I create a new issue, or the Ardour version can be updated here to 5.8?

Could GDB backtrace provide some helpful information about the issue?

(0019525)
timbyr (developer)
2017-03-11 22:05
edited on: 2017-03-16 19:21

What version of Jack2?

Is this specific to the Jack backend?

If you can confirm it is then I don't think you need to create a new issue, we/you can just change the Summary to "Session export doesn't start with Jack2" and then we can try and track which versions don't work so people can upgrade/etc.


- Issue History
Date Modified Username Field Change
2016-11-02 14:57 unfa New Issue
2016-11-05 22:35 robsco Note Added: 0018911
2016-12-05 23:03 timbyr Note Added: 0019122
2016-12-05 23:03 timbyr Status new => feedback
2016-12-10 10:19 unfa Note Added: 0019140
2016-12-10 10:19 unfa Status feedback => new
2016-12-11 03:52 efenstor Note Added: 0019144
2016-12-11 03:56 efenstor Note Edited: 0019144 View Revisions
2016-12-11 07:00 efenstor Note Added: 0019145
2016-12-19 14:57 paul Note Added: 0019185
2016-12-19 14:57 paul Status new => resolved
2016-12-19 14:57 paul Resolution open => no change required
2016-12-19 14:57 paul Assigned To => paul
2017-03-11 11:18 unfa Note Added: 0019523
2017-03-11 11:18 unfa Status resolved => feedback
2017-03-11 11:18 unfa Resolution no change required => reopened
2017-03-11 11:18 unfa Note Edited: 0019523 View Revisions
2017-03-11 11:19 unfa Note Edited: 0019523 View Revisions
2017-03-11 22:05 timbyr Note Added: 0019525
2017-03-16 19:21 timbyr Note Edited: 0019525 View Revisions


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker