MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006541ardourbugspublic2015-08-24 09:032018-02-04 14:22
Reporterfpiesik 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusconfirmedResolutionfixed 
PlatformOSOS Version
Product Version4.1 
Target VersionFixed in Version5.X git (version in description) 
Summary0006541: parallel playback of linked midi regions->no note-offs
DescriptionMake a midi region with some midi notes, dublicate it and let them play parallel on two different tracks witch different instruments. The result is that the instruments don't react to note-off messages anymore. if one unlinks those midi regions, the problem vanishes.
Additional InformationI'm using the official build of Ardour 4.2 on an archlinux 64bit system.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0017107)
x42 (administrator)
2015-08-24 16:18

confirmed, I can reliably reproduce this.


probably related to http://tracker.ardour.org/view.php?id=6287#c16671 [^] (same midi source iterators are used in different contexts)
(0017108)
x42 (administrator)
2015-08-24 19:01

Ardour 4.2-64-g1387e75 has a fix for this issue, please test.

It's not an ideal fix however (it may not perform well for huge midi regions). further work is needed.
(0017115)
fpiesik (reporter)
2015-08-26 04:39

I'm afraid I can't test the fix of, because I'm not a subsriber and have no access to the nightly builds (because I haven't got a credit card and paypal does not allow for subscribtions without. But I do support Ardour, of course:))
(0018929)
drobilla (developer)
2016-11-08 17:40

Deeper fix without the performance issues added in c613732
(0018972)
timbyr (developer)
2016-11-15 20:57

I can confirm this is still fixed. Tested with nightly build 5.4.357 (64bit linux).

Marking as resolved.
(0020149)
HuguesDK (reporter)
2018-02-04 14:08

It seems that this bug reappeared.

See http://tracker.ardour.org/view.php?id=7244 [^]

I can reproduce it with Ardour 5.12 (official binary) as well as with the current Git version (built from source: b69d818).

- Issue History
Date Modified Username Field Change
2015-08-24 09:03 fpiesik New Issue
2015-08-24 16:18 x42 Note Added: 0017107
2015-08-24 16:18 x42 Status new => confirmed
2015-08-24 19:01 x42 Note Added: 0017108
2015-08-24 19:01 x42 Status confirmed => feedback
2015-08-26 04:39 fpiesik Note Added: 0017115
2016-11-08 17:40 drobilla Note Added: 0018929
2016-11-15 20:57 timbyr Note Added: 0018972
2016-11-15 20:57 timbyr Status feedback => resolved
2016-11-15 20:57 timbyr Fixed in Version => 5.X git (version in description)
2016-11-15 20:57 timbyr Resolution open => fixed
2016-11-15 20:57 timbyr Assigned To => timbyr
2016-11-15 20:57 timbyr Assigned To timbyr =>
2018-02-04 14:08 HuguesDK Note Added: 0020148
2018-02-04 14:08 HuguesDK Note Added: 0020149
2018-02-04 14:08 HuguesDK Status resolved => confirmed
2018-02-04 14:08 HuguesDK Note Deleted: 0020148


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker