MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006478ardourbugspublic2015-07-26 15:552017-05-11 16:13
ReporterSideboard 
Assigned Tox42 
PrioritynormalSeveritycrashReproducibilityalways
StatusfeedbackResolutionopen 
PlatformOSOS Version
Product Version5.X git (version in description) 
Target VersionFixed in Version 
Summary0006478: Crash after some time of recording
DescriptionWith Ardour_64bit-4.1.405-dbg I was recording with four mono tracks. After an hour or so the program crashed. After restarting the program part of the old tracks were not shown. Resuming recording was followed by another crash after some shorter time than before. Same thing the third time. The crashed recording files are in the appropriate directory but not within their tracks in Ardour.

I could reproduce the issue with a new project.
Additional InformationI could not reproduce with Ardour_64bit-4.1.446-dbg since another bug prevents saving the tracks so recording is stopped after about two seconds already (without crash).
TagsNo tags attached.
Attached Filestxt file icon gdb.txt [^] (31,050 bytes) 2015-07-26 15:55 [Show Content]
log file icon gdb-Ardour-4.1.485-dbg.log [^] (6,750 bytes) 2015-08-01 15:55
log file icon Ardour_64bit_4.4-dgb_crash_backtrace.log [^] (2,146 bytes) 2015-10-26 14:17
log file icon Ardour_64bit_4.4.143-dgb_crash_backtrace.log [^] (1,762 bytes) 2015-10-26 14:17
txt file icon Ardour_64bit_4.4.143-dgb_crash_backtrace.txt [^] (29,584 bytes) 2015-10-26 14:21 [Show Content]
log file icon ardour-4.7.660-dbg.log [^] (31,745 bytes) 2016-04-10 14:56
log file icon Ardour_64bit-4.7.914-dbg-gcc5.log [^] (32,356 bytes) 2016-05-01 14:26
? file icon ardour-recording-crash-bt [^] (58,461 bytes) 2017-05-02 12:08 [Show Content]

- Relationships
has duplicate 0006690new Ardour terminates while recording 
has duplicate 0006958assignedpaul Application crashes while recording- C++ Runtime error 
has duplicate 0007128closed Ardour crashes suddenly while recording without further user interaction 
has duplicate 0007250closed Ardour 4.7 occasionally dumps core mid-MIDI recording 
has duplicate 0007335new Crash when recording 
related to 0007309new Tracker bug for possible issues with rewaveview branch 

-  Notes
(0016982)
Sideboard (reporter)
2015-08-01 15:54

Could now reproduce with Ardour-4.1.485-dbg.
(0016986)
Sideboard (reporter)
2015-08-04 03:56

The above tests were done with Ubuntu 14.04 LTS.
(0017128)
Sideboard (reporter)
2015-08-31 12:17

Could reproduce with Ardour-4.2.64-dgb.
(0017132)
x42 (administrator)
2015-09-02 05:42

There is a potential fix for this in Ardour-4.2-148-g93aa8d3

but I could not reproduce the issue in the first place, so I can't be sure.
(0017134)
x42 (administrator)
2015-09-02 07:56
edited on: 2015-09-02 07:58

another backtrace from the_CLA (just in case) with Ardour-4.2-146-g7521028 http://pastebin.com/kH2XZyw2 [^]

(0017516)
Sideboard (reporter)
2015-10-26 14:16
edited on: 2015-10-26 14:24

Issue still there, both with 4.4 and 4.4.143.

Edit: Sorry, I uploaded backtrace logs without symbols and don't know how to delete them. I uploaded a better version afterwards.

(0017517)
paul (administrator)
2015-10-26 18:42

I also cannot reproduce this. Assuming that you still can, could you run a debug build from the command line with

    -D waveview

added to the command? It will print out quite a bit of information - we would want the last 100 or so lines before the crash. Thanks.
(0017522)
paul (administrator)
2015-10-26 19:20

replicated here, and run with appropriate debugging ...
(0017719)
x42 (administrator)
2015-12-10 09:44

another BT: http://pastebin.com/93PiQgFM [^] from the CLA.
(0017720)
paul (administrator)
2015-12-10 11:28

same cause as before ... using a cairo surface with a zero reference count.
(0018038)
x42 (administrator)
2016-03-04 08:10

We believe this issue is resolved since Ardour 4.7-274.

It'd be great to get feedback from users who previously experienced these crashes.
(0018146)
Sideboard (reporter)
2016-04-10 14:56

Sorry for the enormous delay.

I tried 4.7.408 some weeks ago but it crashed after a short time with the Ardour window still open but greyed out and unresponsive. I thought that would be a different error that might get fixed soon as had happened in the past.

Now I checked 4.7.660 and it's the same symptom. Not sure if it's the same bug I opened the issue for but the backtrace might help anyway.
(0018166)
Sideboard (reporter)
2016-05-01 14:26

Tried 4.7.909, now 4.7.914. Both crashed. Last one after about 10 minutes of recording with four mono tracks and one stereo track. Backtrace attached.
(0018167)
paul (administrator)
2016-05-01 15:15

OK, I guess this establishes that this is still a problem. A simple fix for us is to just disable threaded waveviews again, but we still have no idea of how this crash is happening.
(0019531)
x42 (administrator)
2017-03-15 06:44

It's possible that this issue is actually https://bugs.freedesktop.org/show_bug.cgi?id=91967 [^] (fixed in libcairo 1.14.8) related to X11/Xshm which would explain why it's grapics-card/system/memory dependent and some systems are affected differently than others.

Ardour nightly builds since 2017-03-15 Ardour-5.8-139-gcd44623 now come with updated libcairo.

It's still unclear that if this is the actual cause, so it would be great if users if users who have affected systems could try some long-term recordings and report back.

PS. On the_CLA's test-rig (which was affected) the issue seems gone.. 2 x ~2 hours continuous recording without crashes.
(0019646)
colinf (updater)
2017-05-02 04:58

I saw this at the weekend on my studio desktop machine, with Saturday's ardour git built from source on fully up-to-date Debian testing, which as far as I know has libcairo 1.14.8-1. I think this is the first time it's happened on that machine.

I have a backtrace if anyone's interested, though I presume it's unlikely to shed much further light, but one other thing I recently changed on that machine was to replace the standard debian 4.9.0-2-amd64 kernel with 4.9.25 built from source with PREEMPT_FULL.

The machine has dual graphics cards: I think they're NVidia, with the free driver. I'll double-check the model next time I'm there.
(0019647)
x42 (administrator)
2017-05-02 05:14

@Colinf, if you could attach the backtrace here, that might be helpful. Is this also a

cairo-surface.c:928: cairo_surface_reference: Assertion `((*&(&surface->ref_count)->ref_count) > 0)' failed

or something different?
(0019648)
colinf (updater)
2017-05-02 07:26

I think it was that same assertion failure, yes, though I was trying to both play guitar and engineer the session when it happened, so my attention was somewhat divided...

I'll grab the backtrace from the studio machine when I'm passing by there later.
(0019650)
colinf (updater)
2017-05-02 12:25

As promised, backtrace attached.

Incidentally, lspci tells me I have two of:

02:00.0 VGA compatible controller: NVIDIA Corporation GT218 [NVS 300] (rev a2)

- Issue History
Date Modified Username Field Change
2015-07-26 15:55 Sideboard New Issue
2015-07-26 15:55 Sideboard File Added: gdb.txt
2015-08-01 15:54 Sideboard Note Added: 0016982
2015-08-01 15:55 Sideboard File Added: gdb-Ardour-4.1.485-dbg.log
2015-08-04 03:56 Sideboard Note Added: 0016986
2015-08-31 12:17 Sideboard Note Added: 0017128
2015-09-02 05:42 x42 Note Added: 0017132
2015-09-02 07:56 x42 Note Added: 0017134
2015-09-02 07:57 x42 Note Edited: 0017134
2015-09-02 07:58 x42 Note Edited: 0017134
2015-10-26 14:16 Sideboard Note Added: 0017516
2015-10-26 14:17 Sideboard File Added: Ardour_64bit_4.4-dgb_crash_backtrace.log
2015-10-26 14:17 Sideboard File Added: Ardour_64bit_4.4.143-dgb_crash_backtrace.log
2015-10-26 14:21 Sideboard File Added: Ardour_64bit_4.4.143-dgb_crash_backtrace.txt
2015-10-26 14:24 Sideboard Note Edited: 0017516
2015-10-26 18:42 paul Note Added: 0017517
2015-10-26 19:20 paul Note Added: 0017522
2015-11-30 16:21 x42 Relationship added has duplicate 0006690
2015-12-10 09:44 x42 Note Added: 0017719
2015-12-10 11:28 paul Note Added: 0017720
2016-02-22 03:41 timbyr Status new => confirmed
2016-03-04 08:10 x42 Note Added: 0018038
2016-03-04 08:10 x42 Assigned To => x42
2016-03-04 08:10 x42 Status confirmed => feedback
2016-04-10 14:56 Sideboard Note Added: 0018146
2016-04-10 14:56 Sideboard Status feedback => assigned
2016-04-10 14:56 Sideboard File Added: ardour-4.7.660-dbg.log
2016-05-01 14:26 Sideboard Note Added: 0018166
2016-05-01 14:26 Sideboard File Added: Ardour_64bit-4.7.914-dbg-gcc5.log
2016-05-01 15:15 paul Note Added: 0018167
2016-08-17 18:56 x42 Relationship added has duplicate 0006958
2016-11-22 14:10 timbyr Relationship added has duplicate 0007128
2016-11-22 14:11 x42 Assigned To x42 =>
2016-11-22 15:12 timbyr Product Version 4.X git (version in description) => 5.X git (version in description)
2017-03-04 02:40 timbyr Relationship added has duplicate 0007250
2017-03-15 06:44 x42 Note Added: 0019531
2017-03-15 06:44 x42 Assigned To => x42
2017-03-15 06:44 x42 Status assigned => feedback
2017-05-02 04:58 colinf Note Added: 0019646
2017-05-02 05:14 x42 Note Added: 0019647
2017-05-02 07:26 colinf Note Added: 0019648
2017-05-02 12:08 colinf File Added: ardour-recording-crash-bt
2017-05-02 12:12 colinf Relationship added has duplicate 0007335
2017-05-02 12:25 colinf Note Added: 0019650
2017-05-11 16:13 timbyr Relationship added related to 0007309


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker