MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004388ardourbugspublic2011-10-23 05:442011-11-21 16:37
Reporteroofus 
Assigned Tocth103 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDell D830 core2duo T9300 2.5GHzOSKubuntuOS Version11.10
Product Version 
Target Version3.0-beta2Fixed in Version3.0-beta2 
Summary0004388: When a session has a midi track in it, the playback buffer indication on the tool bar always shows 0% when playing.
DescriptionWhen a session has a midi track in it, the playback buffer indication on the tool bar always shows 0% when playing.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0011767)
cth103 (administrator)
2011-10-24 13:08

This is because when there is no more MIDI data on a track MidiDiskstream::playback_buffer_load returns 0 as there is nothing to read in _playback_buf.
(0012056)
cth103 (administrator)
2011-11-15 10:05

Fixed in SVN 10619.
(0012177)
oofus (developer)
2011-11-21 16:37

Fixed, thanks

- Issue History
Date Modified Username Field Change
2011-10-23 05:44 oofus New Issue
2011-10-23 05:44 oofus cost => 0.00
2011-10-23 11:37 cth103 Status new => confirmed
2011-10-23 11:37 cth103 Target Version => 3.0-beta1
2011-10-24 13:08 cth103 Note Added: 0011767
2011-11-14 07:55 cth103 Target Version 3.0-beta1 => 3.0-beta2
2011-11-15 10:05 cth103 Note Added: 0012056
2011-11-15 10:05 cth103 Status confirmed => resolved
2011-11-15 10:05 cth103 Fixed in Version => 3.0-beta2
2011-11-15 10:05 cth103 Resolution open => fixed
2011-11-15 10:05 cth103 Assigned To => cth103
2011-11-21 16:37 oofus Note Added: 0012177
2011-11-21 16:37 oofus Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker