MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003399ardourfeaturespublic2010-08-13 11:462012-01-29 14:18
Reporteroofus 
Assigned ToSaBer 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformDell D830 core2duo T9300 2.5GHzOSMandrivaOS Version2010
Product Version 
Target Version3.XFixed in Version 
Summary0003399: The export dialogue needs a preview of what the file name will be.
DescriptionThe export dialogue needs a preview of what the file name will be. This will then show how all of the options affect how the file name will be.
Tagsexport
Attached Files

- Relationships

-  Notes
(0009335)
oofus (developer)
2010-11-03 03:14

Having thought about this a bit more, as there are possibly multiple exports happening in a single export instance, my suggestion needs modifying. Rather than having one preview line could the time span table show the file name on each line. It could be that multiple formats are being exported to but that only effects the file name's extension (ie .wav, .ogg etc). The extension could be left off the preview so the one filename is correct for all formats.

I still think this is necessary so the user can see the effect of adding a version number, changing the label, adding the date etc.
(0012702)
SaBer (developer)
2012-01-29 12:59

Implemented in r11383.
The preview is located in the filename widget, since that is where it mostly gets modified. Feedback is welcome if there are problems with this approach :)
(0012703)
oofus (developer)
2012-01-29 13:18

I think this works fine. No other comments really. Thanks.

- Issue History
Date Modified Username Field Change
2010-08-13 11:46 oofus New Issue
2010-08-13 11:46 oofus cost => 0.00
2010-11-03 03:14 oofus Note Added: 0009335
2012-01-28 10:54 SaBer Tag Attached: export
2012-01-29 12:59 SaBer Note Added: 0012702
2012-01-29 12:59 SaBer Status new => resolved
2012-01-29 12:59 SaBer Resolution open => fixed
2012-01-29 12:59 SaBer Assigned To => SaBer
2012-01-29 13:18 oofus Note Added: 0012703
2012-01-29 14:18 oofus Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker