Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002794 [ardour] bugs major always 2009-07-27 09:42 2011-11-27 17:08
Reporter nickm View Status public  
Assigned To paul
Priority normal Resolution reopened  
Status feedback   Product Version SVN/2.0-ongoing
Summary 0002794: [PATCH] Creating a send from a bus to another bus results in out of sync audio until after a session reload
Description Steps to reproduce:

1. Download my 14MB test session from http://nickm.net/national-copy.tar.gz [^]
2. Start ardour and load the session
3. Create a new send with two output on the Drums bus, connected to the Drums Rev bus
4. Activate the send
5. Start playback and note that audio playing through Drums Rev is out of sync with the rest of the session (confirm by muting and un-muting the bus)
6. Save changes and close ardour
7. Start ardour and load the same session
8. Start playback - audio playing through Drums Rev is now in sync with the rest of the session

I found it impossible to reproduce with a trivial session but it is 100% reproducible on real world sessions, so it may be dependent on track count or routing complexity...
Additional Information
Tags fixed in A3
Attached Files ? file icon 2794.patch [^] (1,651 bytes) 2010-04-05 17:35 [Show Content]
? file icon route-sort2.patch [^] (1,378 bytes) 2010-11-19 16:48 [Show Content]

Sponsor -  Users sponsoring this issue
Sponsors List Total Sponsorship = US$ 50

2009-07-27 19:06: nickm (US$ 50)

- Relationships

-  Notes
(0006533)
nettings (manager)
2009-08-14 19:15

can't reproduce this using your session with r5499.
i followed your recipe, and recorded the left channel of the drums bus and the left channel of the drums rev bus into a new stereo track. they were perfectly in sync.

do you still have this issue?
(0006554)
nickm (reporter)
2009-08-15 10:39

Yes the issue has been present in ardour for ages and is still present.

You shouldn't need to record anything, it should be obvious during playback.

Since it doesn't happen on trivial sessions and you can't reproduce, I guess it may be load related...
(0007431)
kernel_geek (reporter)
2010-04-02 07:46

nickm: I have this issue, I had to move all my drums back and foward verying amounts, between 50 and 250 smpte frames. Even w/o reverb I have issues. My tracks go into a drum bus, then into a master bus, then to my card.
(0007432)
nickm (reporter)
2010-04-02 11:01

This bug is about the fact that when the session is first loaded everything is in sync, but that certain actions on buses can cause the audio routed through those buses to go out of sync. Reload the session and everything is in sync again. Is this the problem you are having kernel_geek?
(0007435)
kernel_geek (reporter)
2010-04-03 02:48

No. I adjusted the positions of my regions and now they're in sync even after a close/save/reboot/open etc.. I reset the positions of the regions in question and connected the output of the bus to my sound card direct (parallel with the other buses) and this solved the problem. Should I start a new bug then ?
(0007445)
cth103 (administrator)
2010-04-05 14:36

I can reproduce this with A3.
(0007447)
cth103 (administrator)
2010-04-05 17:30

Perhaps you could try the attached patch against 2.0 and let me know if it helps?
(0007448)
cth103 (administrator)
2010-04-06 05:14

I have committed an equivalent fix to A3 SVN.
(0007449)
kernel_geek (reporter)
2010-04-06 05:44

cth103: I can try the patch this evening (thats 5 hours by my timezone)
(0007641)
paul (administrator)
2010-04-28 14:15

patch applied to 2.0-ongoing (rev 7014), not needed for 3.0.
(0008374)
nickm (reporter)
2010-07-02 09:34

I'm not convinced this is fixed - in fact it seems to have worsened in the latest version. I can now trigger it just by inserted a plugin on a track :(
(0008693)
nickm (reporter)
2010-08-02 06:08

Commenting out the call to resort_routes in Session::route_redirects_changed fixes the problem. So it seems fairly certain that the patch introduces a far worse problem - inserting a plugin on a track causes tracks to go out of sync with each other. Removing the plugin restores correct sync. This patch should be reverted ASAP. NB: I can't reproduce the plugin problem on a new session so it seems this is also related to session size perhaps...
(0009158)
cth103 (administrator)
2010-09-24 07:29
edited on: 2010-09-24 07:30

Where are you inserting the plugin, what plugin is it and what tracks does it cause to be delayed?

(0009232)
nickm (reporter)
2010-10-09 12:32

I'm inserting the plugin pre-fader, on any track.

It's hard to tell exactly which tracks are out of sync as its a big mix, but its pretty obvious that something is wrong when it happens.
(0009447)
cth103 (administrator)
2010-11-19 16:17

I'd be interested to see if adding the attached route-sort.patch (keeping 2794.patch in as well) helps at all.
(0009451)
plutek (reporter)
2010-11-20 07:28

i have a session which was consistently causing this issue, also with some busses which did *not* have plugins on them, but which did have sends to other busses. i sent the session to cth103 and he wrote route-sort2.patch -- since applying the patch, i have not yet been able to make any busses fall out of sync in that session! i've added/removed/disabled/enabled plugins and sends, and everything seems to just keep rolling in sync.

i'd say, so far, this appears to be a break-through on this issue.

big thanks, cth103!
(0009457)
cth103 (administrator)
2010-11-20 16:50

Thanks for the testing plutek!

I've applied this patch to 3.0 SVN.
(0009458)
plutek (reporter)
2010-11-20 20:19

not being applied to the 2.0 branch? so i'll patch every time i update from svn?
(0009459)
cth103 (administrator)
2010-11-21 03:49

It will probably be applied to 2.0 soon.
(0009484)
plutek (reporter)
2010-11-23 08:52

another report, a few days in, just to confirm.... i've done a lot of work over the last couple of days, with other sessions similar to the one i sent to cth103. everything still appears to be fine.
(0009547)
nickm (reporter)
2010-12-04 14:40

I've tried your patch and I can still trigger the problem if I change a track's outputs from the master bus to some other bus... but I'm not sure if this is related or not?
(0009572)
cth103 (administrator)
2010-12-07 17:21
edited on: 2010-12-10 17:59

Do you have a repeatable test case for that? And are you using both patches from this bug?

(0012224)
cth103 (administrator)
2011-11-27 17:08

For what it's worth at this late stage, I think A3 contains a fix which stands a good chance of solving this problem; if it is still affecting people we can look at a backport.

- Issue History
Date Modified Username Field Change
2009-07-27 09:42 nickm New Issue
2009-07-27 19:06 nickm Sponsorship Added nickm: US$ 50
2009-07-27 19:06 nickm Sponsorship Total 0 => 50
2009-07-27 19:06 nickm Issue Monitored: nickm
2009-08-14 19:15 nettings Note Added: 0006533
2009-08-14 19:15 nettings Status new => feedback
2009-08-15 10:39 nickm Note Added: 0006554
2010-04-02 07:46 kernel_geek Note Added: 0007431
2010-04-02 11:01 nickm Note Added: 0007432
2010-04-03 02:48 kernel_geek Note Added: 0007435
2010-04-05 14:36 cth103 Note Added: 0007445
2010-04-05 14:36 cth103 Status feedback => confirmed
2010-04-05 17:29 cth103 File Added: 2794.patch
2010-04-05 17:30 cth103 Note Added: 0007447
2010-04-05 17:30 cth103 Status confirmed => feedback
2010-04-05 17:31 cth103 File Deleted: 2794.patch
2010-04-05 17:31 cth103 File Added: 2794.patch
2010-04-05 17:35 cth103 File Deleted: 2794.patch
2010-04-05 17:35 cth103 File Added: 2794.patch
2010-04-06 05:14 cth103 Note Added: 0007448
2010-04-06 05:44 kernel_geek Note Added: 0007449
2010-04-24 03:28 cth103 Category bugs => bugs2
2010-04-24 03:29 cth103 Category bugs2 => bugs
2010-04-26 06:38 cth103 Tag Attached: fixed in A3
2010-04-28 14:15 paul cost => 0.00
2010-04-28 14:15 paul Note Added: 0007641
2010-04-28 14:15 paul Status feedback => resolved
2010-04-28 14:15 paul Resolution open => fixed
2010-04-28 14:15 paul Assigned To => paul
2010-07-02 09:34 nickm Note Added: 0008374
2010-07-02 09:34 nickm Status resolved => feedback
2010-07-02 09:34 nickm Resolution fixed => reopened
2010-08-02 06:08 nickm Note Added: 0008693
2010-08-05 07:40 cth103 Target Version => 2.8.12
2010-09-24 07:29 cth103 Note Added: 0009158
2010-09-24 07:30 cth103 Note Edited: 0009158
2010-10-09 12:32 nickm Note Added: 0009232
2010-11-19 16:16 cth103 File Added: route-sort.patch
2010-11-19 16:17 cth103 Note Added: 0009447
2010-11-19 16:48 cth103 File Deleted: route-sort.patch
2010-11-19 16:48 cth103 File Added: route-sort2.patch
2010-11-20 07:28 plutek Note Added: 0009451
2010-11-20 16:50 cth103 Note Added: 0009457
2010-11-20 20:19 plutek Note Added: 0009458
2010-11-21 03:49 cth103 Note Added: 0009459
2010-11-23 08:52 plutek Note Added: 0009484
2010-12-04 14:40 nickm Note Added: 0009547
2010-12-07 17:21 cth103 Note Added: 0009572
2010-12-10 10:19 in0giro Issue Monitored: in0giro
2010-12-10 17:59 cth103 Note Edited: 0009572
2011-03-07 10:23 cth103 Summary Creating a send from a bus to another bus results in out of sync audio until after a session reload => [PATCH] Creating a send from a bus to another bus results in out of sync audio until after a session reload
2011-11-27 17:08 cth103 Note Added: 0012224


Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker