MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002275ardourbugspublic2008-06-02 05:502008-06-19 03:26
Reporteroofus 
Assigned ToNoStar 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDual 666MHz PIIIOSMandrivaOS Version2007
Product VersionSVN/2.0-ongoing 
Target VersionFixed in VersionSVN/2.0-ongoing 
Summary0002275: Editor horizontal scroll bar doesn't always allow scrolling to all of the session.
DescriptionI have a session that is 15 Min's long. When the session is started only a portion of that is shown (the view I left it it when closing previously). However it appears impossible to scroll further up the time line to look at later parts of the session. The upper limit appears to be related to the latest point in time shown when the session was opened.

I think by default the scroll bar should allow access/scrolling to the session end point, I should be able to scroll in time through the whole session unimpeded. If scrolling beyond the end point is required it should be accommodated also.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005002)
johne53 (reporter)
2008-06-07 10:55

I'd like to support oofus on this one. Although it sounds like a trivial problem, it's one of the most frustrating aspects of Ardour IMO. For whatever reason, I've always assumed that it was somehow connected to the end marker.

I can see how an end marker might be useful for certain operations (for example defining (or limiting) a range to be exported - and of course, jumping quickly to the end of a sequence) but I don't think the end marker should play any part in how much of the timeline you can see - or play beyond - or scroll beyond.
(0005006)
paul (administrator)
2008-06-11 06:37

so, how much of the timeline should the scrollbar reflect?
ardour's GUI now uses signed 64 bit integers for everything, which makes the theoretical maximum length something totally absurd. *something* has to make a decision about what range the scrollbar covers - i'm all ears for better suggestions than zero->end marker (because i am sure there are some)
(0005012)
oofus (developer)
2008-06-11 14:45

OK, my thoughts are that by default the scroll bar should allow scrolling between the start and end markers so the whole session can be accessed. If the user needs to see/gain access to time before or after these points then the arrows either end of the scroll bar should be clicked stepping the view further up or down the timeline. These new max/min positions should now be the extent of the scrolling.

This seems like a two parter to me. 1) There is a bug because it is currently not possible to scroll to the end of a session. Scrolling is limited to some arbitrary point mid session. 2) Implementing gaining access beyond the current scroll limit.
(0005016)
johne53 (reporter)
2008-06-12 11:31
edited on: 2008-06-12 11:33

With regard to the scrolling range (i.e. how 'big' it should be) my suggestion would be slightly different. I'd suggest having a user option whereby left/right scrolling could be done via a pair of convention "fast-forward" and "rewind" buttons. It would be nice if they could work in tandem with the horizontal scrollbar but I suspect that the two options would need to be mutually exclusive.

When the "button drive" option was selected, the scrollbar would disappear and there wouldn't need to be any upper or lower scrolling limit (except 00:00:00:00 time). With "scrollbar drive" selected the buttons would disappear and the scrolling range would just need to be slightly bigger than it is at present - say, 10 minutes earlier than the start of audio (or the first marker, if it's earlier) and 10 minutes later than the end of audio (or the last marker, if it's later).

(0005055)
NoStar (developer)
2008-06-19 01:35

The problem of not being able to scroll to end should be fixed. The behavior we discussed on irc is currently implimented this way for now:

The playhead is used to seek past the end marker, the scrollbar will resize accordingly.

Clicking the 'Zoom to Session' button will reset the canvas to the area between the start and end cursor, with a small amount added past the end, so that the end marker is visible.
(0005058)
oofus (developer)
2008-06-19 03:26

A Vast improvement and working well.

- Issue History
Date Modified Username Field Change
2008-06-02 05:50 oofus New Issue
2008-06-07 10:55 johne53 Note Added: 0005002
2008-06-11 06:37 paul Note Added: 0005006
2008-06-11 14:45 oofus Note Added: 0005012
2008-06-12 11:31 johne53 Note Added: 0005016
2008-06-12 11:32 johne53 Note Edited: 0005016
2008-06-12 11:33 johne53 Note Edited: 0005016
2008-06-19 01:28 NoStar Status new => assigned
2008-06-19 01:28 NoStar Assigned To => NoStar
2008-06-19 01:35 NoStar cost => 0.00
2008-06-19 01:35 NoStar Status assigned => resolved
2008-06-19 01:35 NoStar Fixed in Version => SVN/2.0-ongoing
2008-06-19 01:35 NoStar Resolution open => fixed
2008-06-19 01:35 NoStar Note Added: 0005055
2008-06-19 03:26 oofus Status resolved => closed
2008-06-19 03:26 oofus Note Added: 0005058


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker