MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001103ardourfeaturespublic2005-09-28 13:422010-06-23 06:28
Reportergiso 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformOSOS Version
Product Version 
Target Version3.XFixed in Version 
Summary0001103: vertical scaling/zooming of waveform view
DescriptionWhen working with recordings at low signal level vertical zooming of the waveform view could be desireable. Working with a headroom of 10-20 dB shows only thin lines even at largest track height.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0006262)
seablade (manager)
2009-07-04 15:17

The ability to zoom vertically is accomplished in recent versions of Ardour by adjusting the track height. You can now adjust the track height to any size, not just preset sizes, so you can zoom in to your screen size. Resolving issue.
(0006337)
giso (reporter)
2009-07-05 01:29

Well, I think this is not really fixing the problem: If you have a linear waveform view and a recording with 20 dB headroom (nothing special in recording of classical music) even the linear scaling of a track hight to maximum will not bring the desired result (it is more a waste of screen space).

However, due to the available logarithmic waveform view feature this is only a minor feature request. I suggested quite a while ago (August 2007) to close this issue because of the log view, but Paul mentioned that this is not a full fix and thus it should stay open.
(0006343)
Ichthyostega (reporter)
2009-07-05 07:29
edited on: 2009-07-05 07:30

Please excuse me putting it this bluntly, but your "resolution" is a lame excuse.

The issue is that you can't *work* with track recorded with a reasonable headroom. For this, it doesn't help me if I can blow up a *single* track (and even there remains the limitation of the maximum window height). I need to work with *several* tracks without having to manipulate them. In classical music, we don't have "beats" everywhere and we have long piano passages. It is still impossible to do a serious multi track edit with ardour (whithout having to resort to external srcripting and other hacks and quirks). This is *not* a minor or cosmetic issue.

What is needed is a to have a persistent vertical zoom setting for every track.

(0006348)
seablade (manager)
2009-07-05 12:21
edited on: 2009-07-05 12:26

I am updating this issue to apply to a future version of Ardour instead of an obsolete one, and am taking it out of feedback mode.


- Issue History
Date Modified Username Field Change
2005-09-28 13:42 giso New Issue
2005-09-28 13:42 giso email => gg3137@vegri.net
2005-09-28 13:42 giso name => Giso
2009-07-04 15:17 seablade Note Added: 0006262
2009-07-04 15:17 seablade Status new => resolved
2009-07-04 15:17 seablade Resolution open => fixed
2009-07-05 01:29 giso Note Added: 0006337
2009-07-05 01:29 giso Status resolved => feedback
2009-07-05 01:29 giso Resolution fixed => reopened
2009-07-05 07:29 Ichthyostega Note Added: 0006343
2009-07-05 07:30 Ichthyostega Note Edited: 0006343
2009-07-05 12:21 seablade Note Added: 0006348
2009-07-05 12:21 seablade Status feedback => acknowledged
2009-07-05 12:21 seablade Resolution reopened => open
2009-07-05 12:21 seablade Product Version 0.99 => SVN 3.0
2009-07-05 12:26 seablade Note Edited: 0006348
2010-06-23 06:28 cth103 cost => 0.00
2010-06-23 06:28 cth103 Target Version => 3.X


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker