View Issue Details

IDProjectCategoryView StatusLast Update
0009495ardourbugspublic2023-10-21 14:47
Reportertseaver Assigned Tox42  
Status resolvedResolutionno change required 
PlatformGNUOSLinuxOS Version(any)
Product Version8.1 
Summary0009495: “Transport | Playhead | Jump to next mark” starts transport
DescriptionUnder Ardour 8.x, using either the `Transport` menu items or the keyboard shortcuts (`W` and `Q`) to move to a mark causes the transport to start.

It didn't used to do this under 7.x or previously.
Steps To Reproduce1. Set multiple markers in a project with existing audio on a track.
2. Move the playahead to a spot between markers.
3. Select `Transport | Playahead | Jump to next mark` (or press `W` or `Q` keys).
4. Listen to your audio playing, when all you wanted to do was move the playahead.
Additional InformationSee screencap video attached.
TagsNo tags attached.



2023-10-21 02:37

reporter   ~0028228

Screencap I meant to attach earlier.


2023-10-21 03:06

administrator   ~0028229

Still no attachment.

Also, I cannot replicate this. I suspect you may have accidentally enabled auto-play. Does Ardour play when you locate anywhere at all?


2023-10-21 03:37

reporter   ~0028230

> Still no attachment.

Yup. I dragged the 1.6 Mb screencap to the window, let it sit for about 5 minutes with the green "barber pole" spinning, and finally hit the "Add Note" button (I've just tried again, with the same result, and expect not to see the attachment).

> Also, I cannot replicate this. I suspect you may have accidentally enabled auto-play. Does Ardour play when you locate anywhere at all?

In fact, Ardour does play when I click in the timeline. Is the "auto-play" preference set in the "Preferences" dialog?

I wouldn't knowingly have set it -- does it maybe have a new-ish keyboard shortcut which I might've triggered by default?


2023-10-21 03:39

reporter   ~0028231

Yup, no attachment upload.

Looking at the "Transport" menu, I see that it *is* checked, and shows a keyboard shortcut of `Ctrl-7`. I can however see no other visual indication of that setting: am I missing anything?

At any rate, my own issue is closed: I will likely always be able to remember to look for the option on the `Transport` menu.

It might still be an issue for others, particularly that there is no "visible by default" indicator of that status on the editor view (without opening the menu).


2023-10-21 14:47

administrator   ~0028232

We used to have an "auto play" button in the main toolbar, but it was too prominent for a rarely used feature.

Issue History

Date Modified Username Field Change
2023-10-21 02:31 tseaver New Issue
2023-10-21 02:37 tseaver Note Added: 0028228
2023-10-21 03:06 paul Note Added: 0028229
2023-10-21 03:37 tseaver Note Added: 0028230
2023-10-21 03:39 tseaver Note Added: 0028231
2023-10-21 14:47 x42 Assigned To => x42
2023-10-21 14:47 x42 Status new => resolved
2023-10-21 14:47 x42 Resolution open => no change required
2023-10-21 14:47 x42 Note Added: 0028232