View Issue Details

IDProjectCategoryView StatusLast Update
0009428ardourbugspublic2023-08-29 06:32
Reporterpsmith Assigned To 
Status newResolutionopen 
PlatformUbuntuOSLinuxOS Version(any)
Product Version7.5 
Summary0009428: Cue Learn Midi does not work
DescriptionI cannot get midi input to trigger clip playback from the cue.

I have tried using Virtual MIDI keyboard and Akai MPKMini. Using either of these keyboards I can play to synthesizer tracks. I can also map midi controls to faders, and then I can control faders from midi keyboard. But trying to get "midi learn" function to work from the Cue view never works.

In MIDI connection manager I have connected the keyboard to "Cue Control In". In MIDI tracer I can see the midi keyboard inputs displayed in the "Cue Control In".

The documentation says that this should work. Have I mis-configured or missed a step? Or is it broken?

Steps To ReproduceLaunch Ardour with new session and empty template.
Open the following Windows: MIDI Tracer, MIDI Connections, Virtual Keyboard.
Go to Cue view by clicking "Cue" at top right.
Drag Click-120bpm.flac from the clips list and drop in the cue so it is imported into cue A slot1
Check the clip plays when the Play arrow is clicked with the mouse.
In the MIDI connections window, connect the Virtual Keyboard source to the "Cue Control In" Ardour destination
In the MIDI Tracer pick the "Cue Control In" dropdown.
Check that note presses on the virtual keyboard show up in MIDI tracer.

Right click on the clip slot in A1 and pick "MIDI Learn" from the dropdown. The dropdown disappears, there is no prompt for any further action.
Press a note on the virtual keyboard, the keypress information shows up in MIDI tracer.
Press the note on the virtual keyboard again. I expect the clip to play, but nothing happens.
Additional Informationforum message refers

Ardour version :Ardour 7.5.0~ds "Neroli"
(rev 7.5.0~ds-1~bpo22.04.1~ppa1)
Intel 64-bit

Running on Ubuntu Studio
TagsNo tags attached.



2023-08-01 07:03


Screenshot_20230731_091614.png (174,571 bytes)   
Screenshot_20230731_091614.png (174,571 bytes)   


2023-08-01 14:22

administrator   ~0027929

Working fine here. Please test with a nightly build from


2023-08-01 15:46

reporter   ~0027930

Interesting... I installed from

and that works, exactly as it should.

downloaded and ran the packaged version from Ardour website Ardour 7.5.0 from and it does not work
(rev 7.5)

downloaded and ran full paid nightly version and it does not work.
Ardour 7.5.240
(rev 7.5-240-g1d31ace29d)
Intel 64-bit

Reinstalled and ran the nightly demo build again, and it works again.

So i cannot get any full version to learn midi in the cue view but the nightly demo works perfectly.


2023-08-02 11:26

reporter   ~0027934

This is very weird.
Tried the latest nightly demo (.243) this morning and it didn't work.
Reverted to yesterdays nightly demo (.240), which worked yesterday, it no longer works.

So it looks like there is some config variable or file that has been overwritten or deleted....

The binary that worked yesterday does not work today... so that implies it is a config issue... I think.


2023-08-02 15:29

reporter   ~0027939

Might be getting somewhere now ... I have got it working properly on last night's full build!
Ardour 7.5.243
(rev 7.5-243-g9f4a0b444e)
Intel 64-bit

I think it only works if I drop a midi clip into the cue view and do a "midi learn" on that slot first. I can then import an audio clip onto the cues and "midi learn" works on that slot.

If I don't import a midi clip, or import the midi clip second then it doesn't work.

My hypothesis is that importing the MIDI clip to a cue slot is "fixing" the config option that I have missed, or is setting up some pre-requisite that I cannot get at from the GUI.

Needs more testing as I am a bit baffled and have made many config changes at this point....


2023-08-18 08:24

reporter   ~0027981

I have the same issue with a build from git I made about 1h ago.
Ardour 7.5.321
(rev 7.5-321-gb354f41fc2)

My Behringer UMX shows up in the midi tracer window and delivers control messages as expected there.
But neither Midi learn for cue slots nor via middleclick does anything.


2023-08-27 08:18

reporter   ~0027997

Windows nightly build does not learn midi cue inputs either. control inputs eg fader mappings work fine.


2023-08-29 06:32

reporter   ~0028000

Update: I just renamed the User Appdata\Ardour7\config file and restarted Ardour on Windows and started a New empty session...
then dragged a midi clip onto the cue view
checked that I could hear the cue and also hear notes played on the virtual MIDI keyboard
opened MIDI connections and clicked the box to connect virtual keyboard to cue control in

 and this time cue learn with the virtual midi keyboard worked.

So it looks to me that it is the same behaviour on Windows and Linux. It works if the cue learn on the midi track is the first thing you do with a default config file... but if you do something different first then the config gets messed up and cue learn never works again.

Issue History

Date Modified Username Field Change
2023-08-01 07:03 psmith New Issue
2023-08-01 07:03 psmith File Added: Screenshot_20230731_091614.png
2023-08-01 14:22 paul Note Added: 0027929
2023-08-01 15:46 psmith Note Added: 0027930
2023-08-02 11:26 psmith Note Added: 0027934
2023-08-02 15:29 psmith Note Added: 0027939
2023-08-18 08:24 zettberlin Note Added: 0027981
2023-08-27 08:18 psmith Note Added: 0027997
2023-08-29 06:32 psmith Note Added: 0028000