View Issue Details

IDProjectCategoryView StatusLast Update
0000093ardourbugspublic2003-11-02 03:55
Reporterant Assigned Totaybin  
Status closedResolutionno change required 
Summary0000093: Stops on Xruns without any Xrun occuring
DescriptionWith the 'stop recording on xrun' option on ardour will
always stop recording after 1-3 minutes. Jack reports absolutely *no xruns*. Turning the option off, recording
proceeds fine without any audible glitches.
Additional Informationbeta3 and beta5. jack 0.80. Tested on two machines.
TagsNo tags attached.



2003-10-26 18:25

administrator   ~0000103

i will need more details on this, particularly jack configuration. in looking at the code, we only use the stop_on_xrun setting when in the xrun callback registered with JACK. JACK invokes the xrun callback only if delayed_usecs reported by the driver is "too large", and when this happens, its always prints to stderr (not necessarily an xrun message, however - this particular message can occur without an xrun message). so, you may not see an xrun (because ALSA may not have detected one), but you should always see something on stderr when the xrun callback is invoked.

i just tried it locally with -p 4096 -n 2 (JACK ALSA settings), recorded for 14 mins without any problems. stop_on_xrun was enabled.


2003-10-26 19:41

reporter   ~0000105

Last edited: 2003-10-26 20:01

Yes, I looked at the ardour code path and it must be a jack issue.


JACK compiled with System V SHM support
creating alsa driver ... ice1712|ice1712|1024|2|48000|nomon|swmeter|rt

I just tried again. Recorded 8 tracks. No probs tll about 2:30. Then an xrun
shut down recording. OK, so I restarted from where it left off but only went
30 secs or so till it stopped without any xrun reported. Next take went 2 mins,
stopped, no xrun reported. What else can i provide?

Edit: I just wrote a quick client to simply print to stderr when the xrun
callback is invoked. I started jack with -v and see no unusual output other
than transport -> stopped. Yet my client reports calls (2) to the xrun callback.

edited on: 10-26-03 12:01


2003-10-29 23:06

reporter   ~0000128

This is jack's fault. We can close it.


2003-10-31 17:08

administrator   ~0000135

This is a bug in jack. Hopefully it'll be fixed soon.

Issue History

Date Modified Username Field Change
2003-10-26 16:47 ant New Issue
2003-10-26 17:53 paul Status new => assigned
2003-10-26 17:53 paul Assigned To => paul
2003-10-26 18:25 paul Note Added: 0000103
2003-10-26 18:25 paul Status assigned => feedback
2003-10-26 19:41 ant Note Added: 0000105
2003-10-26 20:01 ant Note Edited: 0000105
2003-10-29 23:06 ant Note Added: 0000128
2003-10-31 17:08 taybin Status feedback => resolved
2003-10-31 17:08 taybin Resolution open => no change required
2003-10-31 17:08 taybin Assigned To paul => taybin
2003-10-31 17:08 taybin Note Added: 0000135
2003-11-02 03:55 taybin Status resolved => closed