View Issue Details

IDProjectCategoryView StatusLast Update
0009099ardourbugspublic2022-11-21 10:37
ReporterHirokiFutami Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
PlatformUbuntuOSLinuxOS Version(any)
Product Version7.1 
Summary0009099: I cannot use Vital in Ardour 7.1.
DescriptionNice to meet you. I would like to report a problem.

I am enjoying Ardour 7.1, but I have a problem.
It is that Vital installed in {.deb} format is not recognized by Ardour7.1.
Ardour 6.9 recognized them properly, but 7.1 does not show them in the plugin list no matter how much I scan.
This is probably a bug and I am reporting it.

I love Ardour, I use it all the time.
Thank you very much.
TagsNo tags attached.

Activities

x42

2022-11-17 14:56

administrator   ~0026897

Where is the plugin installed to?
 Is it a LV2 or VST2? If the latter have you configured Ardour to search that location?

HirokiFutami

2022-11-18 18:24

reporter   ~0026902

Hello.

Yes, I have set up VST2 and VST3 folders to search, and both Ardour version 6.9 and 7.1 have the same search settings, but for some reason 7.1 is the only one that does not recognize Vital.

Of course, the version of Vital is the latest version currently available.

x42

2022-11-18 20:39

administrator   ~0026903

There should be no difference for VST3 plugins between Ardour 6.9 and 7.1 - so this is a bit of a mystery
Is there any information in Ardour's Plugin Manager when you scan for the plugin?

PS. there should be no need to set a custom VST3 path same for LV2 (only VST2 requires this).

HirokiFutami

2022-11-20 00:27

reporter   ~0026905

I'm sharing images from my scans with each of Ardour 6.9 and Ardour 7.1!

(I've been using the VST3 version for a long time because I couldn't figure out how to get the LV2 version to work.)
Ardour6.9_.png (12,130 bytes)   
Ardour6.9_.png (12,130 bytes)   
Ardour7.1_.png (13,983 bytes)   
Ardour7.1_.png (13,983 bytes)   

x42

2022-11-20 00:58

administrator   ~0026906

Select the Vital.vst3 and at the bottom the error message should show

HirokiFutami

2022-11-20 10:54

reporter   ~0026914

VST3 module-path '/usr/lib/vst3/Vital.vst3/Contents/x86_64-linux/Vital.so'
[Info]: Scanning: /usr/lib/vst3/Vital.vst3
[ERROR]: Could not load VST3 plugin '/usr/lib/vst3/Vital.vst3/Contents/x86_64-linux/Vital.so': /lib/x86_64-linux-gnu/libsecret-1.so.0: undefined symbol: g_task_set_name
Cannot load VST3 module: '/usr/lib/vst3/Vital.vst3/Contents/x86_64-linux/Vital.so'
Scan Failed.


I got the above message.

x42

2022-11-20 12:51

administrator   ~0026915

That looks like https://forum.vital.audio/t/not-working-on-linux-libraries-are-not-statically-linked/2194/13 is back.

HirokiFutami

2022-11-21 10:37

reporter   ~0026920

I saw the page you linked to.
Does this mean that the problem is on the Vital side and not Ardour?
Sorry if I am wrong X(

Issue History

Date Modified Username Field Change
2022-11-17 13:51 HirokiFutami New Issue
2022-11-17 14:56 x42 Note Added: 0026897
2022-11-18 18:24 HirokiFutami Note Added: 0026902
2022-11-18 20:39 x42 Note Added: 0026903
2022-11-20 00:27 HirokiFutami Note Added: 0026905
2022-11-20 00:27 HirokiFutami File Added: Ardour6.9_.png
2022-11-20 00:27 HirokiFutami File Added: Ardour7.1_.png
2022-11-20 00:58 x42 Note Added: 0026906
2022-11-20 10:54 HirokiFutami Note Added: 0026914
2022-11-20 12:51 x42 Note Added: 0026915
2022-11-21 10:37 HirokiFutami Note Added: 0026920