View Issue Details

IDProjectCategoryView StatusLast Update
0009057ardourbugspublic2022-12-03 08:22
Reporterjaskah Assigned To 
Status newResolutionopen 
PlatformDebian GNUOSLinuxOS Version(any)
Product Version7.0 
Summary0009057: cannot apply fades
Descriptionwhen i try to apply a fade (in or out) to a region, the fades "snap" back after pulling them a certain distance. i cannot, for example, set a 30 second fade.
Steps To Reproducetried this on two separate machines (both debian linux). also tried opening a new session.
TagsNo tags attached.



2022-10-31 21:33



2022-10-31 23:08

administrator   ~0026795

There seem to be no regions to adjust the fades on here. Could you set up the session that is failing and then attach that?

If I record a region in the session you attached i can adjust the fades without issue.


2022-11-01 06:39

reporter   ~0026797

sorry, am uploading again.


2022-11-01 08:02

reporter   ~0026800

I can reproduce the issue if the fade you want to set is bigger than ca. 7 senconds.


2022-11-01 08:10

reporter   ~0026802

yes, that is exactly the problem i'm having.


2022-11-01 08:11

reporter   ~0026803

and i don't believe that i was experiencing this in 6.9.


2022-11-01 08:37

reporter   ~0026805

Okay 7 seconds is not constant but I canmostly reproduce the behaviour in all new sessions. Here are some archives where you can trigger it.


2022-11-01 08:47

reporter   ~0026806

"test fade.ardour-session-archive" is the max-7-seconds-fade session

al f

2022-11-01 09:17

reporter   ~0026808

On Manjaro KDE, I have the same issue with Ardour 7.0.0.

But running Ardour 7.0.105-dbg changing fading works as expected.


2022-11-01 16:57

reporter   ~0026810

i just installed nightly build and i'm still experiencing the same problem with not being able to create long fades without the fade region snapping back.


2022-11-01 16:58

reporter   ~0026811

have attached an archive using Ardour-7.0.170-x86_64-gcc5


2022-11-01 17:12

administrator   ~0026812

Which archive? I only see the one from Oct 31 ... is that it?


2022-11-01 17:17

reporter   ~0026813

am attaching again


2022-11-01 17:18

reporter   ~0026814

would there be any way to get v. 6.9 to try this again? i no longer have the installer for this version on my computers.


2022-11-01 18:01

administrator   ~0026816

I see only 1 attachment, call ed test_2022-10-31_223322.ardour-session-archive that was added yesterday.

We do not make older copies available. You can (and likely should) parallel instal multiple versions.


2022-11-01 18:01

administrator   ~0026817

ah, you put it on dropbox.


2022-11-01 18:30

administrator   ~0026818

pulled the latest ... tested here ... dragged fades long (very long) and short ... no issues

Maybe try renaming ~/.config/ardour7 and see if that helps at all

btw, nice guitar playing from someone!


2022-11-01 18:31

administrator   ~0026819

ah, found a likely related issue. i don't have the problem you describe but after some manipulation i can no longer shorten the fades. Will investigate shortly.


2022-11-01 19:57

reporter   ~0026820

Hi Paul, I deleted my ardour7 config, no difference. Always reproducible. Here is a short video:
(It didn't record the cursor but the blue line in Ardour indicates its position)

If you mean the little acoustic guitar peace, yep thats mine. But to be honest it is an instrument plugin. I had no microphone to record it (And apart from that, I would never have been able to play it so well). But the composition is mine and I simply take it as compliment anyway / too ;D


2022-11-02 03:45

administrator   ~0026821

I was wrong. Just confused about dragging the handles. As far as I can tell, this is fixed in current git master OR it's something that we don't understand.


2022-11-02 08:09

reporter   ~0026823

i just installed the latest nightly but am still experiencing this problem. would anyone happen to have an installer for v. 6.9? i no longer have this on any of my computers, and this situation is putting me in a bind. thanks.

al f

2022-11-02 08:45

reporter   ~0026824

If it's OK by Paul, you can get the installer for 6.9.0 from me. I'll put it online in a temporary folder.


2022-11-02 08:54

reporter   ~0026825

thanks, this is putting me in a bind. i should've done a parallel install with the newest version, keeping 6.9, but actually i've never run into an issue like this with ardour before. learned my lesson!

al f

2022-11-02 09:10

reporter   ~0026826
This link will expire after 1 download. Just for you, jaskah :-)


2022-11-02 09:55

reporter   ~0026828

thanks, but i just tried to download but got the message, "file cannot be found."

al f

2022-11-02 10:24

reporter   ~0026829

Try agai. If not email me (address at the link) and we'll find another way.


2022-11-02 11:20

reporter   ~0026830

Still present in latest nightly v7.0-197 2022-11-02 (after deleting .config/ardour7 again)


2022-11-02 12:15

reporter   ~0026832

My observations so far have been made in Ubuntu 22.10
On the same machine I also have Windows 11 installed (dual boot). I installed latest Ardour nightly on Windows and there I don't have this issue.

What I noticed as well is that the fades I set on Ubuntu and Windows look slightly different. I have sreenshots attached. Maybe there is a relation to this? I don't know. (At least Linux fade looks a bit like a spring so that might explain it ;D )

My system is a Huawei Matebook 2020 AMD Ryzen 7 4800H, 16gb ram, 512gb ssd, Ubuntu 22.10 and Windows 11 Dualboot
Windows.png (437,988 bytes)
Linux.png (270,382 bytes)


2022-11-02 12:19

reporter   ~0026833

(Linux Screenshot was taken while holding mouse button on fade edge to prevent the fade snapping back)


2022-11-02 13:41

reporter   ~0026834

was able to finally download v. 6.9 thanks again for your help.


2022-11-03 10:03

reporter   ~0026847

I installed Nightly-Ardour on an old Thinkpad T420 with Ubuntu 22.04 and there fades do work. Although they look like the screenshot Linux.png in my last reply (little bend in the cross).


2022-11-03 18:05

reporter   ~0026848

i also have an old thinkpad (T530) and fades -- also with a nightly build -- definitely do not work here. i'm on debian 11.


2022-11-03 19:22

reporter   ~0026849

I did a Ubuntu upgrade on my Thinkpad T420 from 22.04 to 22.10. Started Ardour nightly again, Fades worked. Removed Ardour nightly, removed .config/ardour7, installed Ardour 7.1
Now Fades dont't work anymore.
Maybe I did some other minor steps between removing Ardour nightly and installing 7.1 but I can't remember. Silly me.


2022-11-03 20:19

reporter   ~0026850

just installed 7.1 but am still experiencing this issue with fades springing back. is there any way this could be addressed? thanks.

al f

2022-11-08 09:01

reporter   ~0026868

Manjaro KDE with Ardour 7.1.0.
Fades < about 7 seconds works as expected
Fades > about 7 seconds cannot be reliably placed.

Behaviour documented in a short video at


2022-11-30 15:33

reporter   ~0026965

I installed latest Ardour nightly v7.1-196 2022-11-30 on my thinkpad t420 and my Huawei matebook 2020 AMD, both latest Ubuntu 22.10. On Thinkpad it's gone, on my Matebook the issue is still present.


2022-12-03 08:22

reporter   ~0026969

For what it's worth, this happens to me too in Ardour 7.1.0, but appears to be fixed in rev 7.1-196-g5d42509a21

Here's something interesting to try for those who are experiencing this issue:

1. Open your 7.1.0 session where you can't make fades longer than 7 seconds in 7.1-196 (current nightly)
2. In 7.1-196, extend a fade beyond 7 seconds, save the session.
3. Open the session again in 7.1.0. Observe that the fade is still there, and is how you left it in 7.1-196 (and longer than 7 seconds).
4. Attempt to change the length of the fade. For me, each time I changed the length of the fade, it got incrementally bigger.
5. Eventually as more modifications to the fade are made, the fade will go beyond the end of the region (screenshot attached).

Strange stuff indeed.

(In case it's relevant, my system is: UbuntuStudio 22.04 LTS, Ubuntu GNOME desktop, kernel 6.0.11, Mesa 22.3.0. Ryzen 5900X, Radeon 6800XT. JACK + PulseAudio.)

Issue History

Date Modified Username Field Change
2022-10-31 21:33 jaskah New Issue
2022-10-31 21:33 jaskah File Added: test_2022-10-31_223322.ardour-session-archive
2022-10-31 23:08 paul Note Added: 0026795
2022-11-01 06:39 jaskah Note Added: 0026797
2022-11-01 08:02 krischan941 Note Added: 0026800
2022-11-01 08:10 jaskah Note Added: 0026802
2022-11-01 08:11 jaskah Note Added: 0026803
2022-11-01 08:37 krischan941 Note Added: 0026805
2022-11-01 08:47 krischan941 Note Added: 0026806
2022-11-01 09:17 al f Note Added: 0026808
2022-11-01 16:57 jaskah Note Added: 0026810
2022-11-01 16:58 jaskah Note Added: 0026811
2022-11-01 17:12 paul Note Added: 0026812
2022-11-01 17:17 jaskah Note Added: 0026813
2022-11-01 17:18 jaskah Note Added: 0026814
2022-11-01 18:01 paul Note Added: 0026816
2022-11-01 18:01 paul Note Added: 0026817
2022-11-01 18:30 paul Note Added: 0026818
2022-11-01 18:31 paul Note Added: 0026819
2022-11-01 19:57 krischan941 Note Added: 0026820
2022-11-02 03:45 paul Note Added: 0026821
2022-11-02 08:09 jaskah Note Added: 0026823
2022-11-02 08:45 al f Note Added: 0026824
2022-11-02 08:54 jaskah Note Added: 0026825
2022-11-02 09:10 al f Note Added: 0026826
2022-11-02 09:55 jaskah Note Added: 0026828
2022-11-02 10:24 al f Note Added: 0026829
2022-11-02 11:20 krischan941 Note Added: 0026830
2022-11-02 12:15 krischan941 Note Added: 0026832
2022-11-02 12:15 krischan941 File Added: Windows.png
2022-11-02 12:15 krischan941 File Added: Linux.png
2022-11-02 12:19 krischan941 Note Added: 0026833
2022-11-02 13:41 jaskah Note Added: 0026834
2022-11-03 10:03 krischan941 Note Added: 0026847
2022-11-03 18:05 jaskah Note Added: 0026848
2022-11-03 19:22 krischan941 Note Added: 0026849
2022-11-03 20:19 jaskah Note Added: 0026850
2022-11-08 09:01 al f Note Added: 0026868
2022-11-30 15:33 krischan941 Note Added: 0026965
2022-12-03 08:22 lem18 Note Added: 0026969
2022-12-03 08:22 lem18 File Added: Ardour 7.1.0 fade beyond region.png