View Issue Details

IDProjectCategoryView StatusLast Update
0009026ardourbugspublic2022-10-27 20:07
Reportermc888 Assigned To 
Status newResolutionopen 
PlatformDebian GNUOSLinuxOS Versionbullseye/KDE
Product Version7.0 
Summary0009026: waveforms not visible during recording
DescriptionWaveforms do not appear in Editor window while recording, until transport is stopped.

In previous version the waveform display would be delayed, but would appear.

Righ now I'm tracking 6 channels and just get a big red block until I press stop to see if it's working.

Tested with both Clear Current and New playlists.
TagsNo tags attached.



2022-10-23 00:31

reporter   ~0026674

Just as a sanity check, I deselected "Show waveforms while recording". Exit and restarted. Checked the box again to enable it, exit and restart. No change. Always acts as if this box is deselected.

The problem does not occur in 6.9.


2022-10-24 03:20

administrator   ~0026684

Working just fine here. I would recommend that you start by renaming ~/.config/ardour7 (the directory) and see if that helps fix it.


2022-10-24 13:38

reporter   ~0026688

Ok. Renamed the directory and this time I did not copy config from Ardour 6 when prompted at startup.

Verified "Show waveforms while recording" is selected by default. Created new playlists for testing (recording output from a MIDI instrument).

Rolled it for 8 bars and waveforms still did not appear until I stopped transport.

Before reporting it yesterday, I already tried creating a new session in Ardour 7 so there would be no leftover Ardour 6 data in the session. But I did create a template in Ardour 6 and used it for the new Ardour 7 session. That should be clean, yes?

If it's not the config and not the session, I don't know where else to look.


2022-10-24 14:09

administrator   ~0026689

An obvious test would be to create a new session without the template ....


2022-10-24 14:42

reporter   ~0026690

That worked.

What could possibly be stored in a routing template that could impact this? I have a lot of templates accumulated since Ardour 4...


2022-10-24 14:48

administrator   ~0026691

attach the template and I'll take a look.


2022-10-24 16:43

reporter   ~0026693

I want to test a few more to see if I can reproduce it consistently from older templates. And narrow the scope for fault isolation.

If I can do that, I'll post one for you to look at.


2022-10-27 20:07

reporter   ~0026715

I've had limited time for testing. As it turns out, I was mistaken about still having templates from Ardour 4. i still have templates from Ardour 3.

Since I've been primarily using Mixbus32C with Store Mixer Settings, I only had 3 templates from Ardour 6.2. All 3 loaded and worked fine without the waveform problem.

The two sessions showing this problem were created in 6.9. One of the two (a test copy of the same session) was modified in Ardour 7.

Issue History

Date Modified Username Field Change
2022-10-22 22:49 mc888 New Issue
2022-10-23 00:31 mc888 Note Added: 0026674
2022-10-24 03:20 paul Note Added: 0026684
2022-10-24 13:38 mc888 Note Added: 0026688
2022-10-24 14:09 paul Note Added: 0026689
2022-10-24 14:42 mc888 Note Added: 0026690
2022-10-24 14:48 paul Note Added: 0026691
2022-10-24 16:43 mc888 Note Added: 0026693
2022-10-27 20:07 mc888 Note Added: 0026715