View Issue Details

IDProjectCategoryView StatusLast Update
0008883ardourbugspublic2022-04-16 00:36
ReporterArkforest Assigned Topaul  
PrioritynormalSeverityminorReproducibilityrandom
Status feedbackResolutionopen 
PlatformGNUOSLinuxOS Version(any)
Product Version6.9 
Summary0008883: Ardour destroys individual MIDI files upon closing and reopening of projects.
DescriptionI am using Ardour 6.7.0 (rev 6.7) on Bandshed Records' AV Linux (my current OS is based on the outdated MX Linux 19), but this problem also occurred when I used to use Obarun Linux (based on Arch Linux, but with S6 instead of systemd) last year as well, so it's not OS exclusive. There is a small chance (small, but significant) that whenever I close and reopen a project, Ardour destroys a few MIDI files in my music projects. This became particularly problematic with me recently, as I had been manually tuning my vocal takes with x42 autotune and MIDI, and it was those autotune clips I lost, which I struggle to remember the notes for since they're not used the normal way. I have also tried to find it among the interchange and dead folders, but that failed, since the specific files I needed came from another project (I saved this project from another one to reuse the same mix template, and it seems I didn't clear the dead MIDI from the previous project). This bug is one of those ones which is infrequent enough for people to underreport it, and I know the famous musician and YouTuber unfa also has this problem and I, also a somewhat popular musician and YouTuber, am now speaking about this problem too. I would like to be able to find a solution to this problem that can allow it to be patched somehow.
Steps To ReproduceIt usually happens when I save a project, close a project and then reopen it again. There is a low chance of reproduction with this bug and will potentially need extensive testing.
Tags6.7, Midi, MIDI region, missing source, overwrite

Activities

Arkforest

2022-02-25 21:21

reporter  

ardourbug1.png (86,829 bytes)   
ardourbug1.png (86,829 bytes)   
ardourbug2.png (156,858 bytes)   
ardourbug2.png (156,858 bytes)   
ardourbug3.png (168,086 bytes)   
ardourbug3.png (168,086 bytes)   
ardourbug4.png (114,309 bytes)   
ardourbug4.png (114,309 bytes)   

unfa

2022-02-25 21:35

reporter   ~0026336

I see Ardour 6.9 silently deleting data from MIDI files all the time.
I save a project, I load in the next day or next 15 minutes and some regions are just empty.
Recently I also had a few instances of Ardour refusing to load the entire session because some MIDI file was made empty (0 bytes).
I had to delete that file or remove a reference to in in the .ardour session file.
I don't know if it's the same issue we see here, but I think they all must have a common cause.

Ardour is eating MIDI files on a regular basis and that's just horrible.
PLEASE - FIX THIS!

Bugzey

2022-03-26 06:56

reporter   ~0026359

I can confirm I encountered this issue too today. After finishing up a project, some midi files were gone with the above described error message the next morning.

The only thing different for me is that I had duplicated a previously existing session using Session -> Save as, and then I continued working on the new session. This new session was affected by the bug, but only midi files added after the duplication disappeared. Midi files that existed in the old session are still there in the new session.

I ran a quick text search, and I'm finding instances of the old session's path still being referenced. I renamed "fiddling" to "fatal piano", and searching for fiddling showed the following:

$ grep fatal\ piano/ -Eire fiddling
fatal piano/fatal piano.ardour: <Option name="audio-search-path" value="/run/media/radi/Archives/Dropbox/Documents/Ardour/fiddling/interchange/fiddling/audiofiles"/>
fatal piano/fatal piano.ardour.bak: <Option name="audio-search-path" value="/run/media/radi/Archives/Dropbox/Documents/Ardour/fiddling/interchange/fiddling/audiofiles"/>

System: Linux 5.15.28-1-MANJARO 0000001 SMP PREEMPT Fri Mar 11 14:12:57 UTC 2022 x86_64 GNU/Linux
Screenshot_20220326_085305.png (33,355 bytes)   
Screenshot_20220326_085305.png (33,355 bytes)   

paul

2022-04-16 00:36

administrator   ~0026388

Please describe a precise step-by-step recipe that replicates this behaviour predictably, and I will be happy to take a look.

Issue History

Date Modified Username Field Change
2022-02-25 21:21 Arkforest New Issue
2022-02-25 21:21 Arkforest Tag Attached: 6.7
2022-02-25 21:21 Arkforest Tag Attached: Midi
2022-02-25 21:21 Arkforest Tag Attached: MIDI region
2022-02-25 21:21 Arkforest Tag Attached: missing source
2022-02-25 21:21 Arkforest Tag Attached: overwrite
2022-02-25 21:21 Arkforest File Added: ardourbug1.png
2022-02-25 21:21 Arkforest File Added: ardourbug2.png
2022-02-25 21:21 Arkforest File Added: ardourbug3.png
2022-02-25 21:21 Arkforest File Added: ardourbug4.png
2022-02-25 21:35 unfa Note Added: 0026336
2022-03-26 06:56 Bugzey File Added: Screenshot_20220326_085305.png
2022-03-26 06:56 Bugzey Note Added: 0026359
2022-04-16 00:36 paul Note Added: 0026388
2022-04-16 00:36 paul Assigned To => paul
2022-04-16 00:36 paul Status new => feedback