View Issue Details

IDCategoryLast Update
0008798features2021-09-19 16:53
ReporterviktorsmariAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.9 
Fixed in Version 
Summary0008798: Tooltips (hover) for MouseMode should also tell which keyboard shortcuts enable them
DescriptionJust like when we hover over 'Follow Range' button, we see in the tooltip 'Shortcut: Ctrl + 3'

This is super helpful and teaches us how we can switch modes faster.

We should also add tooltips with shortcuts for the MouseModes, so we can learn faster which mode does what.


We can of course use Alt+k and search for the commands, but tooltips are much faster, and teach us even if we did not intend on learning the shortcut.
Needless to say, I don't like guessing the keys blindly, because I am afraid some keys might do some damage to the regions without noticing.
Steps To ReproduceHover over any of the MouseModes (Grab, Draw, Edit etc).

The tooltip is there, but it does not say which keyboard shortcut can be used.
Tagsmouseover, usability

Activities

viktorsmari

2021-09-19 09:05

reporter  

x42

2021-09-19 16:53

administrator   ~0026149

Fixed in Ardour 7.0-pre0-985-gbcb9487c39

Issue History

Date Modified Username Field Change
2021-09-19 09:05 viktorsmari New Issue
2021-09-19 09:05 viktorsmari Tag Attached: mouseover
2021-09-19 09:05 viktorsmari Tag Attached: usability
2021-09-19 09:05 viktorsmari File Added: 2021-09-19-105232_557x164_scrot.png
2021-09-19 09:05 viktorsmari File Added: 2021-09-19-105147_223x126_scrot.png
2021-09-19 16:53 x42 Assigned To => x42
2021-09-19 16:53 x42 Status new => resolved
2021-09-19 16:53 x42 Resolution open => fixed
2021-09-19 16:53 x42 Note Added: 0026149