View Issue Details

IDCategoryLast Update
0008789bugs2021-10-20 16:04
ReporterspiffykAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformGNUOSLinuxOS Version(any)
Product Version6.9 
Fixed in Version 
Summary0008789: MIDI notes pass through a note effect plugin that is deleting them from the buffer
DescriptionI am developing a note effect plugin (downloads for testing purposes here: https://librearp.gitlab.io/download/). This plugin takes input MIDI notes, keeps their relevant data in memory, deletes them from the MIDI buffer, and creates new notes based on its configuration, for the purpose of being sent to a synthesizer. In Ardour, the note deletion is somehow ignored and the "note on" signal is passed through the plugin into the synth, causing unintended behaviour.

This problem only affects the VST3 version of the plugin, the LV2 version seems to be behaving correctly.
Steps To Reproduce- Add a new MIDI track with LibreArp (VST3 version; LV2 is not affected)
- Add a synthesizer *after* LibreArp
- Draw a chord in the edit view for the track to play
- Draw a pattern in LibreArp
- Play the chord

Expected behaviour: Only the arpeggio generated by LibreArp should be played
Actual behaviour: The original chord as well as the arpeggio are played
TagsMidi, VST3

Activities

spiffyk

2021-08-21 16:25

reporter   ~0026120

This issue also only affects Ardour, no other DAW exhibits this behaviour.

x42

2021-08-23 05:11

administrator   ~0026124

Thanks for the heads up. Fixed in 7.0-pre0-869-g1e84f217ac

anonymous

2021-10-20 16:04

viewer   ~0026193

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-08-21 16:03 spiffyk New Issue
2021-08-21 16:03 spiffyk Tag Attached: Midi
2021-08-21 16:03 spiffyk Tag Attached: VST3
2021-08-21 16:25 spiffyk Note Added: 0026120
2021-08-23 05:11 x42 Assigned To => x42
2021-08-23 05:11 x42 Status new => resolved
2021-08-23 05:11 x42 Resolution open => fixed
2021-08-23 05:11 x42 Note Added: 0026124
2021-10-20 16:04 anonymous Note Added: 0026193
2021-10-20 16:04 anonymous Status resolved => closed