View Issue Details

IDCategoryLast Update
0008772bugs2021-07-09 01:35
Reportertjm3803Assigned To 
Reproducibilityalways 
Status newResolutionopen 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.8 
Fixed in Version 
Summary0008772: Reloading midi hardour based project not reloaded as it was saved.
DescriptionPossible Bugs:
Ardour 6.7-6.8

My set-up requires the Ardour output to be sent to Midi hardware. I do not use any of the audio capability that Ardour provides. I don’t need to. Yes, my laptop will have an easy life.

When I save a project, I expect all the outputs for the various midi tracks that I have created to be saved according to my systems requirements. Unfortunately this is not the case. When I reload any of my projects, every one of those midi outputs has been erroneously changed from “Hardware” to “Ardour Busses”. In other words Ardour is not delivering the project back to me in the configuration that I saved it. I find myself needing to reconfigure each and every track back to “hardware”, before all my various instruments wake up. More: When I pull the USB plug out of the laptop, the need to remain connected to “hardware” is forgotten and the preferred (!?) connection lapses to “Ardour Busses”. And once again all the tracks must be adjusted to output to “hardware”.

Spurious Performance Patch Change Message:
A characteristic which I have only recently noticed, is the tendency for Ardour to send a performance patch change out through midi when I open it. The message changes the patch in my performance Studio Set. Very odd, and not constructive. But at this stage I don’t know if it is me, or the Ardour to blame!

My Rig Configuration
I use a Roland FA-08 to play midi info into the USB port of my laptop.
The midi out port of the FA-08 is configured to be a midi thru port, so that midi info from my laptop will go to my Roland 2080 via the FA-08 out (thru) port.
Yes, I have the potential for many more connections – but I’m keeping it simple at the moment.

In Conclusion
I get the unsettled feeling that this aspect of Ardour’s operation has not been fully tested, such is the gravity of this particular bug. therefore expect to come across other bugs, as I work my way through Ardour and its complexities.

Tim Morland
9 July 2021
Steps To ReproduceSave project, reload - check outputs. They will have changed from hardware to Ardour busses
Additional InformationI think I 've covered it pretty well.
TagsNo tags attached.

Activities

x42

2021-07-09 01:35

administrator   ~0026043

Would you mind elaborating on the following:

> When I reload any of my projects, every one of those midi outputs has been erroneously changed from “Hardware” to “Ardour Busses”

Could you post a screenshot of the mixer window perhaps? What busses are there that receive data from MIDI track?

I cannot reproduce this Ardour retains connections as-is when the session is re-loaded, including direct MIDI outputs of MIDI tracks without synths (using Ardour/ALSA, no jack)

What backend do you use (Ardour Menu > Window > Audio/MIDI Setup)?

> When I pull the USB plug out of the laptop, the need to remain connected to “hardware” is forgotten

This is correct, tracks ouputs should be disconnected, and remain so.

--

PS. MIDI *inputs* however may be directly connected depending on selection. See Preferences > MIDI > MIDI Port config.

Issue History

Date Modified Username Field Change
2021-07-09 00:46 tjm3803 New Issue
2021-07-09 01:35 x42 Note Added: 0026043