View Issue Details

IDCategoryLast Update
0008770features2021-07-07 04:03
ReportermcdenkoAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionno change required 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.8 
Fixed in Version 
Summary0008770: Waveforms of mono regions
DescriptionHi, since Ardour 6.6 Waveforms of mono (1 channel) regions are displayed on top of region (in place where left chanel is), instead of center displaying.
Is it possible to add an option to display waveform as it was before (in Ardour 6.5). Has it been changed intentionaly?
Additional InformationLinux MInt 20.1
TagsNo tags attached.

Activities

mcdenko

2021-07-06 10:22

reporter  

6.5.png (103,542 bytes)
6.5.png (103,542 bytes)
6.8.png (93,559 bytes)
6.8.png (93,559 bytes)

x42

2021-07-07 02:57

administrator   ~0026033

It was a bug in 6.5. Note that there is Preferences > Signal Flow > Replicate missing channel regions
A mono region may or may not play on both channels, this was misleadingly indicated by showing the waveform expand.

Also try a stereo source on a 3 channel track. This quickly gets confusing if the waveforms expand to channels that are not present.

Furthermore adding/removing ports to an existing track did not update the waveform display in 6.5. It was possible to have a stereo region show 2 channels on a mono track, which ought to be impossible.

x42

2021-07-07 02:58

administrator   ~0026034

Intentional change -- not a bug

mcdenko

2021-07-07 04:03

reporter   ~0026035

OK, it makes sense. I am using Ardour in 2 channels mode and sometimes have to add mono regions :)
Thank you very much :)

Issue History

Date Modified Username Field Change
2021-07-06 10:22 mcdenko New Issue
2021-07-06 10:22 mcdenko File Added: 6.5.png
2021-07-06 10:22 mcdenko File Added: 6.8.png
2021-07-07 02:57 x42 Note Added: 0026033
2021-07-07 02:58 x42 Assigned To => x42
2021-07-07 02:58 x42 Status new => resolved
2021-07-07 02:58 x42 Resolution open => no change required
2021-07-07 02:58 x42 Note Added: 0026034
2021-07-07 04:03 mcdenko Note Added: 0026035