View Issue Details

IDProjectCategoryView StatusLast Update
0008751ardourbugspublic2023-10-01 18:33
Reporterjumase Assigned Topaul  
Status closedResolutionfixed 
PlatformDebian GNUOSLinuxOS Version(any)
Product Version6.7 
Summary0008751: Ruler is displayed wrongly when snap is not activated
DescriptionWhen changing from 1/8 (or bigger) to 1/16 (or smaller) grids, the ruler always shows 1/8, regardless of which value you choose. If you _previously_ activate snap, then it behaves correctly -if you select 1/16 it shows fifteen lines between bar lines included the reference numbers (beats and ticks). However, if you firstly select, for example, 1/16 and then activate "snap", the ruler doesn't diplay that resolution. So you have to set a greater value and then go back to 1/16 in order to get the right ruler.

Expected behaviour: ruler always displays the selected grid value, no matter if "snap" is on or off.
Steps To Reproduce1. Turn snap off
2. Select 1/8 (or bigger) grid
3. Change to 1/16 (or smaller) grid
4. The ruler always shows 1/8, instead of 1/16 (or the smaller grid you have chosen)
Additional InformationIt doesn't matter which mode you use. I've also tried changing "General Snap options" in preference, but it didn't seem to affect this behaviour.

I tried this on 6.7.187, 6.7.0 and 6.6.0 versions.
TagsNo tags attached.


related to 0008857 resolvedpaul Gridlines not visible for 1/16 or smaller without snap on 



2022-11-07 22:41

reporter   ~0026867

I confirm this error, please fix it, due to this error I am unable to edit a multi-track recording of live drums.


2023-07-10 07:58

reporter   ~0027885

This is really a duplicate of 8857. Here's my take on describing the issue. I'll copy paste my comment from the other ticket here as well:

I have the same issue. Without snap mode activated, setting grid mode to 1/16 note or smaller (1/32, etc.) will not show the vertical grid lines of this granularity. However it's useful to use this granularity if you don't want to snap, but still have visual indication of (sub)beats inside the bar.

Workaround is to:
- first activate snap mode
- then select the 1/16 or smaller gride mode
- then deactivate the snap again
- after some activity these gride lines disappear again (for example after zooming out and in again).

So you need to repeat the workaround all the time, which is quite annoying.


2023-10-01 18:33

reporter   ~0028128

Tested on version 8.0.rc2.15 (rev 8.0-rc2-15-g460b9a24ff) and it's fixed. Thanks!

Issue History

Date Modified Username Field Change
2021-06-19 18:07 jumase New Issue
2022-01-11 12:18 x42 Relationship added related to 0008857
2022-11-07 22:41 Napadator Note Added: 0026867
2023-07-10 07:58 Krio Note Added: 0027885
2023-07-26 12:43 paul Assigned To => paul
2023-07-26 12:43 paul Status new => resolved
2023-07-26 12:43 paul Resolution open => fixed
2023-10-01 18:33 jumase Status resolved => closed
2023-10-01 18:33 jumase Note Added: 0028128