View Issue Details

IDCategoryLast Update
0008751bugs2021-06-19 18:07
ReporterjumaseAssigned To 
Reproducibilityalways 
Status newResolutionopen 
PlatformDebian GNUOSLinuxOS Version(any)
Product Version6.7 
Fixed in Version 
Summary0008751: Ruler is displayed wrongly when snap is not activated
DescriptionWhen changing from 1/8 (or bigger) to 1/16 (or smaller) grids, the ruler always shows 1/8, regardless of which value you choose. If you _previously_ activate snap, then it behaves correctly -if you select 1/16 it shows fifteen lines between bar lines included the reference numbers (beats and ticks). However, if you firstly select, for example, 1/16 and then activate "snap", the ruler doesn't diplay that resolution. So you have to set a greater value and then go back to 1/16 in order to get the right ruler.

Expected behaviour: ruler always displays the selected grid value, no matter if "snap" is on or off.
Steps To Reproduce1. Turn snap off
2. Select 1/8 (or bigger) grid
3. Change to 1/16 (or smaller) grid
4. The ruler always shows 1/8, instead of 1/16 (or the smaller grid you have chosen)
Additional InformationIt doesn't matter which mode you use. I've also tried changing "General Snap options" in preference, but it didn't seem to affect this behaviour.

I tried this on 6.7.187, 6.7.0 and 6.6.0 versions.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-06-19 18:07 jumase New Issue