View Issue Details

IDCategoryLast Update
0008717bugs2021-08-25 00:44
ReporterdgdgddgdAssigned ToBenLoftis 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.7 
Fixed in Version6.7 
Summary0008717: by changing grid mode Rulers (meter && tempo) that I have nothing to do with them appear
Descriptionafter change grid mode from X to Y (1/16 to 1/4 or 1/3 to other grid mode) meter and tempo ruler appear
why ?? i dont need ruler
I just want change the grid mode I do not want the ruler to appear
TagsNo tags attached.

Relationships

related to 0008320 new A6 no longer remembers user-selected ruler fields 

Activities

dgdgddgd

2021-05-22 15:22

reporter  

Untitled.jpg (62,192 bytes)
Untitled.jpg (62,192 bytes)

BenLoftis

2021-05-24 21:48

developer   ~0025888

The current operation is based on the idea that most people will choose one grid "type" (bbt, smpte, hms) for a given session/project. And when they select the desired grid we should make sure that a matching ruler is provided. In the case of music, the full set of BBT, Meter and Tempo are displayed.

It was a mistake to trigger this behavior when the user only selects a different beat subdivision but stays within the musical (bbt) grid type. I have fixed this so it only switches when you change between bbt/smpte/hms grid type; not when selecting different subdivisions: git sha 627741

anonymous

2021-07-21 15:22

viewer   ~0026070

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-05-22 15:22 dgdgddgd New Issue
2021-05-22 15:22 dgdgddgd File Added: Untitled.jpg
2021-05-24 21:48 BenLoftis Assigned To => BenLoftis
2021-05-24 21:48 BenLoftis Status new => resolved
2021-05-24 21:48 BenLoftis Resolution open => fixed
2021-05-24 21:48 BenLoftis Fixed in Version => 6.7
2021-05-24 21:48 BenLoftis Note Added: 0025888
2021-07-21 15:22 anonymous Note Added: 0026070
2021-07-21 15:22 anonymous Status resolved => closed
2021-08-25 00:44 x42 Relationship added related to 0008320