View Issue Details

IDCategoryLast Update
0008685bugs2021-05-03 06:39
ReporterKlickerAssigned To 
Reproducibilityhave not tried 
Status closedResolutionfixed 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.6 
Fixed in Version 
Summary0008685: Segmentation fault opening specific project
DescriptionI've created a tiny project which was saving/loading OK, then suddenly crashed and has been crashing any time I try to open it since. Other projects open and run fine, but the program doesnt like this project in particular.

I've included the project files in an archive (the project is tiny), and included is a file called gdb-output - this is the output from running ardour with the --gdb tag and hitting the error.

The error message I'm seeing is "Thread 1 "ArdourGUI" received signal SIGSEGV, Segmentation fault.", followed by a long stack trace which means very little to me.

Ardour 6.6.0
"Desert Island Selection"
(rev 6.6)
Intel 64-bit

Linux Mint 20.1 (Ulyssa)

Steps To ReproduceI cant give exact steps on how to reproduce - this is day 1 of me using Ardour, so I'm doing a lot of clicking around without fully understanding what I'm doing...

I was editing a midi track, adding/removing/editing notes in the "piano roll" (or whatever you guys call it). That's about as specific as I can be, sorry :/
TagsNo tags attached.

Activities

Klicker

2021-05-02 21:35

reporter  

MidiPlay.tar.gz (11,147 bytes)

Klicker

2021-05-03 06:38

reporter   ~0025789

Looks like this is the same issue as https://tracker.ardour.org/view.php?id=8586#c25572 and has been fixed in a later version. Deleting the instant.xml allows the project to load for now, and I'll keep an eye for the update being released.

Thanks!

Issue History

Date Modified Username Field Change
2021-05-02 21:35 Klicker New Issue
2021-05-02 21:35 Klicker File Added: MidiPlay.tar.gz
2021-05-03 06:38 Klicker Note Added: 0025789
2021-05-03 06:39 Klicker Status new => closed
2021-05-03 06:39 Klicker Resolution open => fixed