View Issue Details

IDProjectCategoryView StatusLast Update
0008665ardourbugspublic2021-10-22 01:23
Reporterericfontaine Assigned To 
Status newResolutionopen 
PlatformArchOSLinuxOS Version(any)
Product Version6.6 
Summary0008665: when stop recording, ardour sometimes puts undesired empty region ontop of recorded region
DescriptionI’m sporadically encountering issue where the last region I recorded shows the waveform fine as it is recording, but then when I press stop, an empty region is placed on top of the recorded region. I don’t hear my recorded region when I playback and it appears as though nothing recording because a blank region is placed ontop of my recorded audio. However the audio did record, and can be found by clicking on the empty region and pressing delete.

Steps To ReproduceNot easily reproducible, and I haven't determined the exact conditions which this happens on my computer, but it seems the more audio regions I record, the more likely I am to encounter this issue.
TagsNo tags attached.



2021-04-16 22:17

administrator   ~0025713

Just to clarify: there is a correct region with expected audio underneath, and simply deleting the empty region fixes things?


2021-04-17 00:03

reporter   ~0025714

yes, there is a correct region underneath the blank region, and simply deleting the empty region fixes things.


2021-06-22 19:07


Image1.png (112,313 bytes)   
Image1.png (112,313 bytes)   
Image2.png (62,449 bytes)   
Image2.png (62,449 bytes)   
Issue.ardour (100,592 bytes)


2021-06-22 19:07

reporter   ~0025991

Hi, I found something similar to this but couldn't reproduce it.

I started up a new project and started recording with Transport -> Follow Playhead and Stationary Playhead activated. These were the only different things I set, so I thought that could be the cause of this issue, but I couldn't reproduce it again by activating those preferences. I mention this here because I got this problem on the first recording. I "fixed" it by editing the region end (I tried to make it larger; of course that would be imposible, but when I released mouse, the waveform was there).

Recently I noticed that region name finishes in .2, indicating it is a "second edit region", but I think I hadn't done any edits when I did the screenshot. What I mean is that maybe the region with the waveform was under the .2 region.

Another difference from what ericfontaine reported is that I actually could hear the recorded audio, though no waveform was shown.

Lastly, I tried to drag and drop region Gtr-1.2 from the Region List but it didn't work. It creates another region, but shows nothing in the track, not even an empty region.

I attach two images. The second one has the track unarmed to show metrics. I also upload the session file as it may help (it has another track and a few edits and automation added).

Version used: 6.7.0 from


2021-10-22 01:23

reporter   ~0026194

I just experienced this issue again. On a 3-day fresh install of KDE neon user edition (which is based on Ubuntu 20.04-lts and KDE plasma 23.0) using the linux install binary from the Ardour website. My session has 3 tracks: "alto-flute", "06 Conv...Melody", "conveyer...larinet.2". I was recording my first take on alto-flute for the project duration (1 min 20 sec). After recording completed, I see there is a region "Take1_alto-flute-1.2" with no audio which is covering up what I actually recorded (region name "Take1_alto-flute-1.1").
bug-happened.tar.gz (26,391 bytes)

Issue History

Date Modified Username Field Change
2021-04-16 22:12 ericfontaine New Issue
2021-04-16 22:17 x42 Note Added: 0025713
2021-04-17 00:03 ericfontaine Note Added: 0025714
2021-06-22 19:07 jumase File Added: Image1.png
2021-06-22 19:07 jumase File Added: Image2.png
2021-06-22 19:07 jumase File Added: Issue.ardour
2021-06-22 19:07 jumase Note Added: 0025991
2021-10-22 01:23 ericfontaine File Added: bug-happened.tar.gz
2021-10-22 01:23 ericfontaine Note Added: 0026194