View Issue Details

IDCategoryLast Update
0008656bugs2021-06-07 21:15
ReporterrugubaraAssigned Tox42 
Reproducibilityalways 
Status closedResolutionduplicate 
Platformx86_64OSGentoo LinuxOS Versionrolling
Product Version6.6 
Fixed in Version 
Summary0008656: session crashes on open
DescriptionThe session used to work ok, but crashes on every open now even in safe mode.
anton@PF16W6Y2 ~/Music/??????? ? ?? $ ardour6 -O -d
Ardour6.6.0 (built using 6.6 and GCC version 10.2.0)
Ardour: [INFO]: Your system is configured to limit Ardour to 524288 open files
Ardour: [INFO]: Loading system configuration file /etc/ardour6/system_config
Ardour: [INFO]: Loading user configuration file /home/anton/.config/ardour6/config
Ardour: [INFO]: No H/W specific optimizations in use
Ardour: [INFO]: Loading plugin meta data file /usr/share/ardour6/plugin_metadata/plugin_tags
Ardour: [INFO]: Loading plugin statistics file /home/anton/.config/ardour6/plugin_metadata/plugin_stats
Ardour: [INFO]: Loading default ui configuration file /etc/ardour6/default_ui_config
Ardour: [INFO]: Loading user ui configuration file /home/anton/.config/ardour6/ui_config
Ardour: [INFO]: Loading 451 MIDI patches from /usr/share/ardour6/patchfiles

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.017: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.017: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.017: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.018: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.018: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.019: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.019: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.019: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.019: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.019: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.020: Unable to locate theme engine in module_path: "murrine",
Ardour: [INFO]: Loading color file /usr/share/ardour6/themes/dark-ardour.colors

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.045: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.045: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.045: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.046: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.046: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.046: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.047: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.047: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.047: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.047: Unable to locate theme engine in module_path: "murrine",

(ardour-6.6.0:3298729): Gtk-WARNING **: 00:02:27.047: Unable to locate theme engine in module_path: "murrine",
Ardour: [INFO]: Loading ui configuration file /etc/ardour6/clearlooks.rc
Ardour: [INFO]: Loading bindings from /etc/ardour6/ardour.keys
Loading ui configuration file /etc/ardour6/clearlooks.rc
Ardour: [INFO]: CPU vendor: GenuineIntel
Ardour: [INFO]: AVX-capable processor
Ardour: [INFO]: AVX with FMA capable processor
Ardour: [INFO]: CPU brand: Intel(R) Core(TM) i7-8850H CPU @ 2.60GHz
Found nothing along /home/anton/.config/ardour6/templates:/usr/share/ardour6/templates
lilv_world_add_plugin(): warning: Duplicate plugin <urn:ardour:a-fluidsynth>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/ardour6/LV2/a-fluidsynth.lv2/
lilv_world_add_plugin(): warning: ... and file:///opt/Mixbus-6.2.70/lib/LV2/a-fluidsynth.lv2/ (ignored)
lilv_world_load_bundle(): warning: Ignoring bundle <file:///opt/Mixbus-6.2.70/lib/LV2/a-delay.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-delay> loaded from <file:///usr/lib64/ardour6/LV2/a-delay.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///opt/Mixbus-6.2.70/lib/LV2/a-exp.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-exp> loaded from <file:///usr/lib64/ardour6/LV2/a-exp.lv2/>
lilv_world_add_plugin(): warning: Duplicate plugin <https://community.ardour.org/node/7596>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/ardour6/LV2/reasonablesynth.lv2/
lilv_world_add_plugin(): warning: ... and file:///opt/Mixbus-6.2.70/lib/LV2/reasonablesynth.lv2/ (ignored)
lilv_world_load_bundle(): warning: Ignoring bundle <file:///opt/Mixbus-6.2.70/lib/LV2/a-reverb.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-reverb> loaded from <file:///usr/lib64/ardour6/LV2/a-reverb.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///opt/Mixbus-6.2.70/lib/LV2/a-comp.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-comp> loaded from <file:///usr/lib64/ardour6/LV2/a-comp.lv2/>
lilv_world_load_bundle(): warning: Replacing version 1.1 of <http://gareus.org/oss/lv2/fil4#mono> from <file:///usr/lib64/lv2/fil4.lv2/>
lilv_world_load_bundle(): note: New version 1794.0 found in <file:///opt/Mixbus-6.2.70/lib/LV2/fil4.lv2/>
lilv_world_load_bundle(): warning: Replacing version 1.1 of <http://gareus.org/oss/lv2/fil4#stereo> from <file:///usr/lib64/lv2/fil4.lv2/>
lilv_world_load_bundle(): note: New version 1794.0 found in <file:///opt/Mixbus-6.2.70/lib/LV2/fil4.lv2/>
error: failed to open file /opt/Mixbus-6.2.70/lib/LV2/.harrison_version.txt/manifest.ttl (Not a directory)
lilv_world_load_file(): error: Error loading file `file:///opt/Mixbus-6.2.70/lib/LV2/.harrison_version.txt/manifest.ttl'
lilv_world_load_bundle(): error: Error reading file:///opt/Mixbus-6.2.70/lib/LV2/.harrison_version.txt/manifest.ttl
lilv_world_load_bundle(): warning: Ignoring bundle <file:///opt/Mixbus-6.2.70/lib/LV2/a-eq.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-eq> loaded from <file:///usr/lib64/ardour6/LV2/a-eq.lv2/>
Scanning folders for bundled LV2s: /usr/lib64/ardour6/LV2
lilv_world_add_plugin(): warning: Duplicate plugin <urn:ardour:a-fluidsynth>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/ardour6/LV2/a-fluidsynth.lv2/
lilv_world_add_plugin(): warning: ... and file:///opt/Mixbus-6.2.70/lib/LV2/a-fluidsynth.lv2/ (ignored)
lilv_world_load_bundle(): warning: Ignoring bundle <file:///opt/Mixbus-6.2.70/lib/LV2/a-delay.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-delay> loaded from <file:///usr/lib64/ardour6/LV2/a-delay.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///opt/Mixbus-6.2.70/lib/LV2/a-exp.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-exp> loaded from <file:///usr/lib64/ardour6/LV2/a-exp.lv2/>
lilv_world_add_plugin(): warning: Duplicate plugin <https://community.ardour.org/node/7596>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/ardour6/LV2/reasonablesynth.lv2/
lilv_world_add_plugin(): warning: ... and file:///opt/Mixbus-6.2.70/lib/LV2/reasonablesynth.lv2/ (ignored)
lilv_world_load_bundle(): warning: Ignoring bundle <file:///opt/Mixbus-6.2.70/lib/LV2/a-reverb.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-reverb> loaded from <file:///usr/lib64/ardour6/LV2/a-reverb.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///opt/Mixbus-6.2.70/lib/LV2/a-comp.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-comp> loaded from <file:///usr/lib64/ardour6/LV2/a-comp.lv2/>
lilv_world_load_bundle(): warning: Replacing version 1.1 of <http://gareus.org/oss/lv2/fil4#mono> from <file:///usr/lib64/lv2/fil4.lv2/>
lilv_world_load_bundle(): note: New version 1794.0 found in <file:///opt/Mixbus-6.2.70/lib/LV2/fil4.lv2/>
lilv_world_load_bundle(): warning: Replacing version 1.1 of <http://gareus.org/oss/lv2/fil4#stereo> from <file:///usr/lib64/lv2/fil4.lv2/>
lilv_world_load_bundle(): note: New version 1794.0 found in <file:///opt/Mixbus-6.2.70/lib/LV2/fil4.lv2/>
error: failed to open file /opt/Mixbus-6.2.70/lib/LV2/.harrison_version.txt/manifest.ttl (Not a directory)
lilv_world_load_file(): error: Error loading file `file:///opt/Mixbus-6.2.70/lib/LV2/.harrison_version.txt/manifest.ttl'
lilv_world_load_bundle(): error: Error reading file:///opt/Mixbus-6.2.70/lib/LV2/.harrison_version.txt/manifest.ttl
lilv_world_load_bundle(): warning: Ignoring bundle <file:///opt/Mixbus-6.2.70/lib/LV2/a-eq.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-eq> loaded from <file:///usr/lib64/ardour6/LV2/a-eq.lv2/>
Set cursor set to default
 loading from /home/anton/Music/??????? ? ?? as ??????? ? ?? templ is_new 0 bp 0
Reading player:Calf Fluidsynth took 189 microseconds, final size = 152
Reading player:Drums took 1179 microseconds, final size = 2486
Reading player:Calf Fluidsynth took 205 microseconds, final size = 152
Reading player:Calf Fluidsynth took 534 microseconds, final size = 152
Reading player:Calf Fluidsynth 2 took 249 microseconds, final size = 428
Reading player:Drums took 130 microseconds, final size = 28
Reading player:Helm took 1 microseconds, final size = 0
Segmentation fault (core dumped)

Steps To Reproduceopen the attached session
TagsNo tags attached.

Relationships

duplicate of 0008586 closedx42 Ardour-6.6 Segfault on startup 

Activities

rugubara

2021-04-08 21:20

reporter   ~0025682

I can't attach the session file for some reason. The problematic file can be downloaded from https://1drv.ms/u/s!AiRuwd9jlr57gpQfvcOMYHrP8w7LZg?e=C6elAX

x42

2021-04-08 21:38

administrator  

issue-8656.png (195,670 bytes)
issue-8656.png (195,670 bytes)

x42

2021-04-08 21:38

administrator   ~0025683

The session loads fine here (misses some plugins and media).
Maybe this is due to https://tracker.ardour.org/view.php?id=8586#c25572 (instant.xml) - Does deleting the instant.xml file help.
if not we need more info https://ardour.org/debugging_ardour

rugubara

2021-04-09 12:44

reporter   ~0025684

To the point! removing instant.xml lets the session to load. Thank you very much Robin!

rugubara

2021-04-09 12:58

reporter   ~0025685

I made a diff between an old and new instant.xml if you need it for analisys.

@@ -1,7 +1,8 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <instant>
- <Main x="0" y="54" w="3840" h="1966" current-tab="editor"/>
- <Editor id="41" edit-horizontal-pane-pos="0.89999997615814209" notebook-shrunk="0" edit-vertical-pane-pos="0.89999997615814209" mixer-width="Wide" zoom-focus="ZoomFocusMouse" zoom="2048" grid-type="GridTypeBeatDiv4" snap-mode="SnapOff" internal-grid-type="GridTypeBeat" internal-snap-mode="SnapOff" pre-internal-grid-type="GridTypeBeatDiv4" pre-internal-snap-mode="SnapMagnetic" edit-point="EditAtMouse" visible-track-count="-1" playhead="9483900" left-frame="0" y-origin="196" maximised="0" follow-playhead="0" stationary-playhead="0" mouse-mode="MouseObject" join-object-range="0" show-editor-mixer="1" show-editor-list="0" editor-list-page="0" show-marker-lines="0" show-touched-automation="0" nudge-clock-value="428478">
+ <LastUsedSnapshot name="??????? ? ??"/>
+ <Main x="78" y="132" w="3070" h="1709" current-tab="editor"/>
+ <Editor id="42" edit-horizontal-pane-pos="0.89999997615814209" notebook-shrunk="0" edit-vertical-pane-pos="0.89999997615814209" zoom-focus="ZoomFocusPlayhead" zoom="2048" grid-type="GridTypeNone" snap-mode="SnapOff" internal-grid-type="GridTypeBeat" internal-snap-mode="SnapOff" pre-internal-grid-type="GridTypeNone" pre-internal-snap-mode="SnapOff" edit-point="EditAtMouse" visible-track-count="-1" playhead="1663232" left-frame="0" y-origin="0" maximised="0" follow-playhead="1" stationary-playhead="0" mouse-mode="MouseObject" join-object-range="0" show-editor-mixer="0" show-editor-list="0" editor-list-page="0" show-marker-lines="0" show-touched-automation="0" nudge-clock-value="240000">
     <Window name="Editor" visible="0" x-off="-1" y-off="-1" x-size="-1" y-size="-1" tabbed="1"/>
     <Buttons>
       <Press/>
@@ -9,30 +10,17 @@
     </Buttons>
     <Selection>
       <StripableView id="161259"/>
- <MIDINotes region-id="109195">
- <note note-id="3308520"/>
- </MIDINotes>
- <MIDINotes region-id="96285">
- <note note-id="3268490"/>
- </MIDINotes>
- <MIDINotes region-id="140536">
- <note note-id="3107845"/>
- </MIDINotes>
- <MIDINotes region-id="63010">
- <note note-id="3249146"/>
- </MIDINotes>
     </Selection>
     <RegionList/>
- <EditorLocations clock-mode="BBT"/>
+ <EditorLocations clock-mode="Timecode"/>
   </Editor>
- <Mixer mixer-rhs-pane1-pos="0.60000002384185791" mixer-rhs_pane2-pos="0.69999998807907104" mixer-list-hpane-pos="0.20000000298023224" mixer-inner-pane-pos="0.80000001192092896" narrow-strips="0" show-mixer="0" maximised="0" show-mixer-list="1" monitor-section-visible="0" foldback-strip-visible="1" show-vca-pane="1">
+ <Mixer mixer-rhs-pane1-pos="0.60000002384185791" mixer-rhs_pane2-pos="0.69999998807907104" mixer-list-hpane-pos="0.20000000298023224" mixer-inner-pane-pos="0.80000001192092896" narrow-strips="0" show-mixer="0" maximised="0" show-mixer-list="1" monitor-section-visible="1" foldback-strip-visible="1" show-vca-pane="1">
     <Window name="Mixer" visible="0" x-off="-1" y-off="-1" x-size="-1" y-size="-1" tabbed="1"/>
   </Mixer>
   <Preferences>
- <Window name="Preferences" visible="0" x-off="555" y-off="499" x-size="2016" y-size="1052" tabbed="0"/>
+ <Window name="Preferences" visible="0" x-off="0" y-off="0" x-size="2481" y-size="1282" tabbed="0"/>
   </Preferences>
   <Meterbridge show-meterbridge="0">
     <geometry x-size="600" y-size="400" x-pos="1" y-pos="1"/>
   </Meterbridge>
- <LastUsedSnapshot name="??????? ? ??"/>
 </instant>

x42

2021-04-09 13:06

administrator   ~0025686

Yeah the issue is the MIDI Note selection.

anonymous

2021-06-07 21:15

viewer   ~0025927

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-04-08 21:15 rugubara New Issue
2021-04-08 21:20 rugubara Note Added: 0025682
2021-04-08 21:38 x42 File Added: issue-8656.png
2021-04-08 21:38 x42 Note Added: 0025683
2021-04-09 12:44 rugubara Note Added: 0025684
2021-04-09 12:58 rugubara Note Added: 0025685
2021-04-09 13:05 x42 Relationship added duplicate of 0008586
2021-04-09 13:06 x42 Note Added: 0025686
2021-04-09 13:06 x42 Assigned To => x42
2021-04-09 13:06 x42 Status new => resolved
2021-04-09 13:06 x42 Resolution open => duplicate
2021-06-07 21:15 anonymous Note Added: 0025927
2021-06-07 21:15 anonymous Status resolved => closed